cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1130
Views
0
Helpful
10
Replies
Highlighted

Issue with CVP, Script and Call Studio

Hi, when test the script via SIP Phone LinPhone only hear Sorry, We experience difficulties

I have a UCCE Packaged 10.5; I made a script with Call Studio very simple; only play Hello World with TTS in the Item 1 in Audio options.

The validate and deploy was successful. So I upload the holamundo.zip to CVP OAMP via VXML Applications and iwas successful also.

The configuration in the gateway XML is:

application
service new-call flash:bootstrap.vxml
!
service survivability flash:survivability.tcl
!
service holamundo flash:CVPSelfService.tcl
  param CVPPrimaryVXMLServer 10.10.5.114
  param CVPBackupVXMLServer 10.10.5.114
  param CVPSelfService-port 7000
  param CVPSelfService-app holamundo

And the dial-peer is:

dial-peer voice 1000 voip
session protocol sipv2
session transport tcp
incoming called-number .
codec g711ulaw
no vad
!

The application that performed the test is LinPhone where I listen sorry, we experience ......

I can debug thje script in Call Studio and was functionality correct; also verify with status.batch file and the application show Session Ending for holamundo application.

Any ideas for fix the problem?

Thanks so much.

1 ACCEPTED SOLUTION

Accepted Solutions
Rising star

Re: Issue with CVP, Script and Call Studio

Yes, it looks like you don't have a TTS server.

In Call Studio, there's an element in the Elements/Context/Application

Modifier.

Drag that in, click on its Settings tab.

Set default audio path to: /CVP/audio if you want to use VXMLServer's

tomcat to serve audio.

Then put any audio files you may have onto your

Cisco/CVP/VXMLServer/Tomcat/webapps/CVP/audio directory. The

installation comes with a few audio files in there already: like

helloworld_audio.wav

Note Tomcat is case-sensitive.

If you'd prefer to use IIS to serve up audio (and if it's running on

your CVP system) then it usually runs by default from *C:/inetpub/wwwroot/ *

Upon installing CVP, it usually puts system prompts into

C:/inetpub/www/en-us/sys

To use audio from the en-us/sys directory, then set the Default Audio

Path to http://IPaddress/en-ys/sys

10 REPLIES 10
Rising star

Re: Issue with CVP, Script and Call Studio

Also, you can look in the Activity and Error logs for info about your

errors. They're on the CVP system under

CVP\VXMLServer\applications\appname\logs

Re: Issue with CVP, Script and Call Studio

Let me check the logs

Re: Issue with CVP, Script and Call Studio

Hi Janine, how are you?

After review this path:

C:\Cisco\CVP\VXMLServer\applications\holamundo\logs\ErrorLog

I see in the file error_log2016-06-08 the next:

10.10.5.114.1465399775092.13.holamundo,06/08/2016 09:29:35.138,A VoiceXML error occurred of type "error.com.cisco.media.resource.unavailable.tts"

10.10.5.114.1465399775092.13.holamundo,06/08/2016 09:29:35.138,An error has occurred.

10.10.5.114.1465399791612.14.holamundo,06/08/2016 09:29:51.659,A VoiceXML error occurred of type "error.com.cisco.media.resource.unavailable.tts"

10.10.5.114.1465399791612.14.holamundo,06/08/2016 09:29:51.659,An error has occurred.

10.10.5.114.1465399832843.15.holamundo,06/08/2016 09:30:32.890,A VoiceXML error occurred of type "error.com.cisco.media.resource.unavailable.tts"

10.10.5.114.1465399832843.15.holamundo,06/08/2016 09:30:32.890,An error has occurred.

Is necesary the server that you comment?

Sorry I am inexperienced in Call Studio and VXML.


Regards...

Rising star

Re: Issue with CVP, Script and Call Studio

Yes, it looks like you don't have a TTS server.

In Call Studio, there's an element in the Elements/Context/Application

Modifier.

Drag that in, click on its Settings tab.

Set default audio path to: /CVP/audio if you want to use VXMLServer's

tomcat to serve audio.

Then put any audio files you may have onto your

Cisco/CVP/VXMLServer/Tomcat/webapps/CVP/audio directory. The

installation comes with a few audio files in there already: like

helloworld_audio.wav

Note Tomcat is case-sensitive.

If you'd prefer to use IIS to serve up audio (and if it's running on

your CVP system) then it usually runs by default from *C:/inetpub/wwwroot/ *

Upon installing CVP, it usually puts system prompts into

C:/inetpub/www/en-us/sys

To use audio from the en-us/sys directory, then set the Default Audio

Path to http://IPaddress/en-ys/sys

Re: Issue with CVP, Script and Call Studio

Hi Janine, how are you?

I test with other Script and work fine!!! But I need import other script but when I try, the import tool dont find any file.

The folder application have this folders:

admin

data

java

logs

What I need for import the script in call studio?

Thanks so much Janine..

Rising star

Re: Issue with CVP, Script and Call Studio

You've imported a vxml server (runtime) version of the app.

You need to find the studio version of the app - it'll have folders

callflow and deploy.

There's no decompiler to convert from vxml server app to studio app

Rising star

Re: Issue with CVP, Script and Call Studio

By the way, you can register to attend CVPD training remotely! It's with

me (live instructor) via webex and totally hands-on programming using my

remote student pods. Gets great reviews! Look for my website

trainingtheexperts.com/courses.html

Re: Issue with CVP, Script and Call Studio

Thanks, I send email for some questions. Regards

Rising star

Re: Issue with CVP, Script and Call Studio

You need to have a Nuance TTS $Server to use the TTS feature. And you'd

need to configure the gateway to connect to it. If you haven't purchased

Nuance TTS, then use pre-recorded audio in the URI portion of the Audio

tab.

Re: Issue with CVP, Script and Call Studio

Hi Janine, how configure: pre-recorded audio in the URI portion of the Audio tab.

I need the media file server for this option?

Regards...

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards