cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1319
Views
0
Helpful
13
Replies
Highlighted
Beginner

Issues with EmbeddedWebApp on Finesse

I'm testing the EmbeddedWebApp from the Finesse sample gadgets on GitHub.  I've updated the URL based on the documentation and updated the 3 files to the 3rdpartygadget folder via WinSCP.  

 

I've updated Finesse layout with:

                           <gadget>http://localhost:8082/3rdpartygadget/files/EmbeddedWebApp/EmbeddedWebApp.xml</gadget>

or

<gadget>/3rdpartygadget/files/EmbeddedWebApp/EmbeddedWebApp.xml</gadget>

 

I've tested this on the a UCCX 10.6 box and 11.5 box and got the same problem.  The gadget loads with a blank page like the attached photo.

 

EmbeddedWebApp Gadget Screenshot.JPG

I've tried multiple browsers and multiple web sites.

 

Any ideas?

 

13 REPLIES 13
Highlighted
Cisco Employee

Re: Issues with EmbeddedWebApp on Finesse

Hi,

There are usually two reasons why it would be blank:
1. The URL you put into the iframe doesn't support being embedded within an iframe. There are iframe checkers online. Here is the first one that comes up on google: http://www.tinywebgallery.com/blog/advanced-iframe/free-iframe-checker

2. The browser is blocking the page from being displayed due to mixed content blocking. This means that the Finesse desktop is using https while the url that is being loaded within the iframe is http, or visa versa.

Thanx,
Denise
Highlighted
Beginner

Re: Issues with EmbeddedWebApp on Finesse

I had this same problem, and this issue was due to mix content setting.
You can give it a try,
Open firefox,
write about:config
allowmixcontent =true (by default its fault)

and refresh the page.

Hope this will work.
Highlighted
Beginner

Re: Issues with EmbeddedWebApp on Finesse

Thanks for the info.  I have tried allowing mixed content setting in IE and Firefox and didn't have any luck.  I've also tried many URL's including https://www.bing.com which I believe uses iframes.  

 

I checked the browser debugging and got the attached error.  

Highlighted
Beginner

Re: Issues with EmbeddedWebApp on Finesse

Which Application URL you are opening inside the iframe?
Also, check are you able to access the.xml file directly on browser  

Highlighted
Beginner

Re: Issues with EmbeddedWebApp on Finesse

Yes access via a browser directly to the XML works just fine.  

 

I'm just testing with https://www.bing.com.  

Highlighted
Beginner

Re: Issues with EmbeddedWebApp on Finesse

Screenshot of browsing to the XML directly.  

Highlighted
Contributor

Re: Issues with EmbeddedWebApp on Finesse

Is the Finesse server itself able to access this URL?

If not, then this could be your issue.

 

The Finesse server also needs to be able to access teh gadget XML. If this is a cloud based gadget you will need to open Firewall rules to allow FInesse to access it or place on the gadget on the FInesse server itself into the 3rd party gadget folder (and host locally).

 

Finesse server itself does not yet support a proxy to allow this to be done easily.

 

Gerry

Highlighted
Beginner

Re: Issues with EmbeddedWebApp on Finesse

Can you show the gadget code? 

Theoretically, it should work, maybe something wrong with the code. 

 

BTW you are trying for the screen pop when the call arives right 

Highlighted
Beginner

Re: Issues with EmbeddedWebApp on Finesse

I've verified the firewall is allowing the traffic.  

 

This is just the embedded web app gadget, just trying to get an external page to display in a finesse gadget.  

 

I've attached the code.  Again, this was taken strait for the dev net site.  

Highlighted

Re: Issues with EmbeddedWebApp on Finesse

Hi everybody,

 

In my case it works, but when I try to create a new embedded gadget doesn´t work, it shows a page in grey, but the another work properly, I have tried modifying the name on XML and .js files because maybe can crash with the previous configued, has anybody tried to configure more than one embbeded gadget?

 

Thanks.

Highlighted
Contributor

Re: Issues with EmbeddedWebApp on Finesse

These are the things to watch for

 

1) If the gadget is hosted on an webserver and not on the finesse server itself - The Finesse server AND the client both need access to connect to the gadget. If not hosting on Finesse - make sure to  host it on a HTTPS enabled webserver. i.e. use HTTPS

2) The Web link within the EmbeddedWebApp also needs to use HTTPS and most browsers will no longer support mixed content - see here - to tempoary allow https://kb.iu.edu/d/bdny

3) When using HTTPS and if a non public signed cert or self signed certs - you need to import the CA or self signed cert into FInesse Certification  (Go to Finesse OS admin GUI)

 

 

Gerry

Highlighted

Re: Issues with EmbeddedWebApp on Finesse

Hi Gerry,

 

I send my responses.

 

1.My gagdgets are in Finesse and are refernced to work with https://IP/

 

2. I have enabled mixed mode on 3 differents browsers (firefox, chrome and IE), but only in IE I receive a message regarding with a problem with certificates

 

3. I will try to do thea last one and I´ll inform my results.

 

Regards.

 

Highlighted
Contributor

Re: Issues with EmbeddedWebApp on Finesse

Hi,

 

>My gagdgets are in Finesse and are refernced to work with https://IP/

If the embeded website is references as you have detailed above using an "Ip address", e.g. https://123.123.123.123/folder/index.htm, you will ALWAYS get a cert warning - no matter what you do.

 

Test the https Link in a web browser and make sure that no get no cert warnings and use that same address in the embededed finesse gadget

 

A cert will usually have the FQDN name of the server in it - so you need to reference the web server as

https://myserver.mydomin.xyz/folder/index.htm

And not

https://myserver/folder/index.htm

OR

https://123.123.123.123/folder/index.htm

 

i.e. you might be able to get to the page - but only after accepting cert warnings....

 

This is because the cert which conatins the server FQDN needs matches the address entered (and has nothing to do with Cisco / Finesse - just standard https requirements).

Gerry