cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4010
Views
8
Helpful
10
Replies

JTAPI Resynce error - UCCX 7.0(1)SR5 & CUCM 7.1(5)SU4

binhtngu
Cisco Employee
Cisco Employee

I'm running into this problem that JTAPI client synchronization failed with CUCM 7.1(5)SU4 new installation.  I read a lot of TAC cases and tried all the suggestions below, but no luck. 

Has anyone resolved this problem recently?

Cisco JTAPI Client

An error has occurred while trying to resynchronize the Cisco JTAPI Client. Please try Cisco JTAPI Resync in Cisco Unified CCX Administration again.

Tried suggestions:

- Download and reinstalled JTAPI version from the CUCM PUB on the UCCX server

- Restarted CTIManager, then rebooted UCCX server.

- Run CET and checked and verified JTAPI version there, manually configured it 

All these have been applied and still failed.

However, I still be able to configured call control group fine without any issue.

Thanks,

Binh.

1 Accepted Solution

Accepted Solutions

Hi Binh,

Glad to know that it is working after the creation of new CCG, Route points :-).

It was mentioned in one of the below links that without having any CCG, RP's JTAPI sync fails,

https://learningnetwork.cisco.com/thread/10881

That was the reason I told you (in my last post) to create a CCG, RP and try resyncing it.

Please dont forget to rate the helpful posts.

Thanks,

Anand

View solution in original post

10 Replies 10

binhtngu
Cisco Employee
Cisco Employee

Logs:

652: Mar 06 10:01:35.140 PST %MADM-ADM_CFG-7-UNK:JTAPIUtil.isJTAPIVersionSame() - Calling the installJtapi method

653: Mar 06 10:01:35.140 PST %MADM-ADM_CFG-7-UNK:JTAPIUtil.isJTAPIVersionSame() - wfavvidDir is: C:\Program Files\wfavvid\

654: Mar 06 10:01:35.171 PST %MADM-ADM_CFG-7-UNK:JTAPIUtil.isJTAPIVersionSame() - winntDir is: C:\WINNT\

655: Mar 06 10:01:35.171 PST %MADM-ADM_CFG-7-UNK:JTAPIUtil.isJTAPIVersionSame() - jtapiExeDir is: C:\Program Files\wfavvid\java\current\bin\

656: Mar 06 10:01:35.234 PST %MADM-ADM_CFG-7-UNK:JTAPIUtil.isJTAPIVersionSame() - JTAPICMVersion is: 7.1(5.10000)-6

657: Mar 06 10:01:35.250 PST %MADM-ADM_CFG-7-UNK:JTAPIUtil.isJTAPIVersionSame() - JTAPICRSVersion is: unknown

658: Mar 06 10:01:35.250 PST %MADM-ADM_CFG-7-UNK:JTAPIUtil.isJTAPIVersionSame() - serverName is: ROS-ALPHA-UCCX

659: Mar 06 10:01:35.250 PST %MADM-ADM_CFG-7-UNK:JTAPIUtil.isJTAPIVersionSame() - myNode.getId() 1

660: Mar 06 10:01:35.250 PST %MADM-ADM_CFG-7-UNK:JTAPIUtil.isJTAPIVersionSame() - JTAPI Versions are inconsistent.

661: Mar 06 10:01:35.250 PST %MADM-ADM_CFG-7-UNK:MainMenuController.checkJtapiConsistency() - JtapiConsistent is: false

662: Mar 06 10:01:35.250 PST %MADM-ADM_CFG-7-UNK:MainMenuController.checkJtapiConsistency() - JtapiConsistent is: false

663: Mar 06 10:01:35.250 PST %MADM-ADM_CFG-7-UNK:MainMenuController.checkJtapiConsistency() - errorMsg is: The Cisco JTAPI Client versions are inconsistent. Please go to Cisco JTAPI Resync in the Unified CM Telephony Subsystem to install the Cisco JTAPI Client.

664: Mar 06 10:01:35.250 PST %MADM-ADM_CFG-7-UNK:MainMenuController.checkSetupStatus() - JtapiErrorMsg is: The Cisco JTAPI Client versions are inconsistent. Please go to Cisco JTAPI Resync in the Unified CM Telephony Subsystem to install the Cisco JTAPI Client.

665: Mar 06 10:01:35.250 PST %MADM-ADM_CFG-7-UNK:MainMenuController.checkSetupStatus() - Errorbean is set

666: Mar 06 10:01:35.250 PST %MADM-ADM_CFG-7-UNK:MainMenuController.License() - setupstatus set to main menu

667: Ma

Try this out and see if it works

1) Browse to "C:\WINNT\java\lib" and take a backup copy of all of the

files in this folder. After you get a backup, delete the files you can

(If you get a message saying you cannot delete a file because it is in

use then just leave it)

2) Browse to "C:\WINDOWS\java\lib" and copy the contents into the

"C:\WINNT\java\lib" directory. Replace any files with the one from the

\WINDOWS if prompted.

3) Right click My Computer > Properties > Advanced Tab > Environment

Variables

-> Click on the "CLASSPATH" and click on Edit

-> Please change the variable value to what I have EXACTLY AS BELOW:

.;C:\WINNT\java\lib\jtapi.jar;;

4) Reboot the server

5) Log into AppAdmin and see if the JTAPI resync message comes up again,

if it does, go ahead and attempt to do the JTAPI resync again.

6) Additional reboot is required after this.

- JTAPI resync should work at this point, logs should start to be written as well.

Thank you

Anuj

Hi,

-Disable the antivirus on UCCX boxes (if its a HA node, do it on both the nodes).

-Perform JTAPI client resync from the UCCX admin page.

-Restart the CRS Node manager on both the nodes.

-Once everthing comes back in servie, enable the anivirus once again.

Hope it helps.

Anand

Hi Anuj,

it is running on Windows 2003, and therefore, there is no C:\WINNT directory.  Thanks for the reply.

Hi Anand,

There is no Anti-virus software running on this CCX server.  Thanks for the reply.

Hi ,

Could you please try creating a call control group (say with 2-4 cti ports) , and couple of route points and than try syncing it.

Please let me know the outcome of it.

- Also try the same operation from the UCCX second node (resync JTAPI) if its a HA setup.

Waiting for your reply.

Thanks,

Anand