cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1055
Views
5
Helpful
4
Replies
loprestid
Beginner

Need Help with a gadget to show a website ( attached is the code I'm using )

<?xml version="1.0" encoding="UTF-8"?>

<Module>

<ModulePrefs

title="Description" height="800">

</ModulePrefs>

<Content type="url" href="http://yahoo.com;" />.    (just an example)

</Module>

and for instance in desktop

  <tab>

                <id>test</id>

                <label>Test</label>

                <gadgets>                                          

                        <gadget>http://localhost/3rdpartygadget/files/Test1.xml</gadget>                              

</gadgets>

            </tab>

And this is 10.5 es8

Any suggestions welcome.

Right now just getting a blank page...

4 REPLIES 4
dekwan
Cisco Employee

Hi,

Not all pages allow the site to be shown in an iframe. I know you said the yahoo link is just an example, but that is one of the sites that does not work. Also, you do not need to have a ';'. I tried using bing.com (which I know works) and it loaded correctly:

<?xml version="1.0" encoding="UTF-8"?>

<Module>

<ModulePrefs

title="Description" height="800">

</ModulePrefs>

<Content type="url" href="https://bing.com" />

</Module>

Thanx,

Denise

Denise, Thank you for your reply I really appreciate it. Yahoo was just something I put in the string to show an example I never even really tried that link... 

What I'm ultimately trying to do is display a CUIC permalink

and a web page...

I tried this as well

<?xml version="1.0" encoding="UTF-8"?>

<Module>

<ModulePrefs title="Real Time Display"

        description="Real Time Display"

thumbnail="http://localhost:8080/"

        height="400"

        scrolling="true">

    <Require feature="settitle" />

    <Require feature="dynamic-height" />

    <Require feature="pubsub-2" />

  <Require feature="setprefs" />

</ModulePrefs>

<Content type="html">

<![CDATA[

  <!DOCTYPE html>

<body>

  <a href="http://www.cnn.com">CNN</a>

</body>

]]>

</Content>

</Module>

Is there another way to do this without Iframe that you're aware of?

Hi,

Ah, I see. Did you make sure to change the & to &amp; in the URL? Other than that, the format looks correct. Here are instructions if you weren't already aware of them: Instructions for creating CUIC Gadgets

Also, another option is to use the CUIC sample gadget: finesse-sample-code/CUICSampleGadget at master · CiscoDevNet/finesse-sample-code · GitHub

As far as the other webpage, you can use the embedded web app sample gadget: https://github.com/CiscoDevNet/finesse-sample-code/tree/master/EmbeddedWebAppSampleGadget

All of these solutions use iframes unfortunately.

Thanx,

Denise

BalajiSivaraj49175
Participant

https://developer.cisco.com/docs/finesse/#!gadget-configuration/gadget-configuration
This document may helpful to modify the field of the gadget configure the webpage to finesse gadget

 

Gadget Configuration
Class finesse.gadget.Config
Provides configuration data from the container page for the gadgets Config object in the Finesse desktop. When Finesse desktop load successfully, the container loads configuration details from the server. While creating gadgets, these configurations are passed to the gadgets as finesse.gadget.Config object. For more information on gadgets.
Field Details
Field                          Description
authorization              The Base64 encoded "id:password" that can be used for non-SSO authentication by the gadget to make Finesse REST API requests.
authToken                 The token used for authentication in SSO deployments.
clientDriftInMillis         The time difference between the client and the server in milliseconds.

Content for Community-Ad