cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
377
Views
20
Helpful
12
Replies
Highlighted
Participant

no ringback tone while pressing 0 to operator

In our client office they have UCCX with 5 agents. 

 

When calling  calling from PSTN to Pilot number caller gets IVR to select language. after selecting language voice prompt says to   press 0 for operator or press extension number of the person you know. if they press extension number caller can hear ringback tone. but if press 0 caller cannot hear ringback tone . but agents can answer the call and establish the call without any issue . 

 

Sometimes caller wait for some times agent didnt answer for while the caller disconnects the calls because they cannot hear ringback tone. 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Participant

The issue is solved as follows:
I followed the below link from cisco:
Troubleshoot Music On Hold Failure When Gateway is Integrated Service Router 4431 - Cisco

 

  • Log in to Cisco Unified CM Administration page
  • Select System Service Parameters
  • Select Server dropdown and choose the Publisher node
  • Select Service dropdown and choose Cisco CallManager (Active)
  • Click on the Advanced button
  • Locate the Clusterwide Parameters (Service) section
  • Duplex Streaming Enabled: Default is False (change to True) and click Save

 


Their Voice gateway is ISR 4331/k9 firmware version 16.7(3r)

View solution in original post

12 REPLIES 12
Highlighted
Enthusiast

I think the network audio file plays the ringing tone to the caller. You
can upload a ringing tone to the cucm and select this ringing tone for the
operator's extension number in the cucm (under devices)
Highlighted

As I told you. even if the same agent transfer the call to come extension. then also caller can hear the ring tone.

 

only when they press 0 option no ring tone.

 

even if we try to call that extensio directly also we can hear ring tone..

Highlighted

Have you tried to call from your internal extension to the pilot number ? Do you have the same issue when pressing 0?

Highlighted

As you said, Today client tried to call from extension to pilot number internally say 1000.

then he got welcome and language selection prompt. After selecting the language, another prompt to press 0 for operator and enter the extension you wish to call.

This time when he pressed 0 instead of ringback tone he is able to listen the music and the operator answered the call. 

 

So internally its working fine and external call only they are facing problem when they press 0. In this case, issue is in VG or CUCM?

 

Their VG protocol is H323.

Highlighted
Participant

any update on this issue..

Highlighted

Yes. It is related to the music on hold .I will try it out in my lab tomorrow and update. Under the directory number for the operator's extension,can you uplaod a screenshot ?

Highlighted
Participant

Pls help... I think its something related to music on hold issue. thats whay they cannot hear it. i want to know where that will be missing. 

Highlighted
Enthusiast

I have four a smiliar thread. Check the link below and see it can help

https://community.cisco.com/t5/ip-telephony-and-phones/no-ringback-tone-on-transferred-call/m-p/3838408

Highlighted
Participant

So this is what i understand.

when people press 0 moh plays and caller will listen to music instead of ringback tone . at that time phone ring and agent picks the call.

 

in this case if caller is from PSTN side when he press 0 , he cannot hear any music instead only silence at that time.

 

i checked MRGL and h323 gateway has assinged devicepool properly and device pool contains that MGRL..

 

so why still music cannot hear PSTN caller..

Highlighted
Participant

The issue is solved as follows:
I followed the below link from cisco:
Troubleshoot Music On Hold Failure When Gateway is Integrated Service Router 4431 - Cisco

 

  • Log in to Cisco Unified CM Administration page
  • Select System Service Parameters
  • Select Server dropdown and choose the Publisher node
  • Select Service dropdown and choose Cisco CallManager (Active)
  • Click on the Advanced button
  • Locate the Clusterwide Parameters (Service) section
  • Duplex Streaming Enabled: Default is False (change to True) and click Save

 


Their Voice gateway is ISR 4331/k9 firmware version 16.7(3r)

View solution in original post

Highlighted


Wow!  Congratulations!!.

So what does the caller hear, music or ring tone?

 

Highlighted

Its music. MOH file uploaded to CUCM. 

 

Content for Community-Ad