cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
313
Views
0
Helpful
5
Replies
Highlighted
Enthusiast

PCCE 11.5 - CVP Reporting Server Down in OAMP after a New Installation

Dear members,

This is a PCCE environment version 11.5.

The system is up and running since almost 3 years. 

Recently our customer decided to configure Courtesy Call Back, and one of the things to be done is to install the CVP Reporitng Server as it was not installed previously.

The installation went just fine and the server has been deployed in OAMP but the issue is that the status is showing as Down.

In the Reporting Server logs, we noticed the below error:

1042: ReportingServerIP: Apr 01 2020 11:14:41.884 +0300: %CVP_11_5_MSGBUS-1-PLUGIN_INITIALIZATION_FAILURE: SYS_RPT1 Plugin initialization failed due to being unable to find the server at CallServerIP port=23003. Exception: java.net.ConnectException: Connection refused: connect [id:9]

Telnet from Reporting Server to CallServer on port 23003 is failing noting that there is no firewall in between and windows firewall is shutdown on both servers.

Even Telnet on the reporting server itself on port 23003 is failing.

Restarting the reporting server didn't solve the issue.

Below is the content of the messageAdapter.properties on the reporting server: 

# --------------- REPORTING SS OUTPROCESS PLUGIN -------------------
MessageAdapter.RPT3.active = true
MessageAdapter.RPT3.plugin.SYS_RPT1.class = com.cisco.msg.msgbus.outprocess.OutProcessClientPlugin
MessageAdapter.RPT3.plugin.SYS_RPT1.param.pluginType = OUT_PROCESS
MessageAdapter.RPT3.plugin.SYS_RPT1.param.adapterName = RPT3
MessageAdapter.RPT3.plugin.SYS_RPT1.param.adapterType = RPT
MessageAdapter.RPT3.plugin.SYS_RPT1.param.primaryServerHostname = CVP-Call-VXML-Server-IP
MessageAdapter.RPT3.plugin.SYS_RPT1.param.primaryServerPort = 23003
MessageAdapter.RPT3.plugin.SYS_RPT1.param.socketReadTimeout = 0
MessageAdapter.RPT3.plugin.SYS_RPT1.param.waitForApplication = 3
MessageAdapter.RPT3.plugin.SYS_RPT1.param.mirrorPluginName = MSGBUS_RPT3
MessageAdapter.RPT3.plugin.SYS_RPT1.param.qosLevel = default

Do you think that the the primaryServerHostname should be the Reporting Server IP instead of the Call Server IP? 

Anyone can advise?

Thank you in advance.

 

 

5 REPLIES 5
Highlighted
Rising star

Re: PCCE 11.5 - CVP Reporting Server Down in OAMP after a New Installation

I've ran into this several times and it's almost always one of two issues...
1. Not associating at least one Call Server to the Reporting Server in OAMP
2. No license file or an expired license file
It's usually the latter for me
If you grab one of the regular log files (not the Error log file) from C:\Cisco\CVP\logs, do you see anything that mentions the license expired or that the evaluation period ended? I recently upgraded a customer to 11.6 and we didnt have a license applied for a while... I attached a screen shot of what comes up if I search for LICENSE within the C:\Cisco\CVP\logs directory using Notepad++

Highlighted
Enthusiast

Re: PCCE 11.5 - CVP Reporting Server Down in OAMP after a New Installation

Hello Omar Deen,
Thank you for taking the time to respond.
The server has already been licensed and associated with one of the CVP servers.
If you have access to a CVP Reporting Server, could you please check if you're able to telnet locally on port 23003 and the same on the CVP server.
Thank you.
Highlighted
Rising star

Re: PCCE 11.5 - CVP Reporting Server Down in OAMP after a New Installation

I cannot telnet locally on the CVP Reporting Server, however, I can on the CVP Call Server. What matters is if you can telnet from the CVP Reporting Server to the CVP Call Server. If you cannot, then I think you've closed in on the problem.

Highlighted
Rising star

Re: PCCE 11.5 - CVP Reporting Server Down in OAMP after a New Installation

These might be naive questions, but
Did you Save&Deploy the OAMP config?
I OAMP, did you associate your VXML Server(s) with the CVP Call Server, and the Save&Deploy.
Have you rebooted your CVP Call Server? Sometimes that's needed.
For CCB, you have to use OAMP (or perhaps SPOG?) and configure under System > CourtesyCallback - select the Reporting Server and select 'allow all phone numbers to be called back'. Then Save & Deploy.
Highlighted
Enthusiast

Re: PCCE 11.5 - CVP Reporting Server Down in OAMP after a New Installation

Hello Janine,
Thank you for taking the time to share your knowledge.
We have tried many times to save and deploy the reporting server but with no luck.
VXML server is already associated with the call server; The system is up since almost 3 years.
As for rebooting the call server, we haven't tried this yet. We will do it and check.
And regarding the CCB, shouldn't the reporting server be UP before we start configuring CCB?
I appreciate your feedback.
Thank you.
CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey