Showing results for 
Search instead for 
Did you mean: 

PCCE courtesy callback internal server error




my setup consists of PCCE version 12.0


i am configuring the courtesy callback on cceadmin interface for PCCE and i am getting the below error:


error occured.

The request reached the server but it took to long to respond.try loading the page




and after we save the page:


internal server error. please try again later and contact your administrator


 2 screenshots attached


Appreciate your feedback.


to note as well that i tried changing the tomcat http request timeout from 5000 to 50000 with no luck




1 Accepted Solution

Accepted Solutions
15 Replies 15

VIP Advocate VIP Advocate
VIP Advocate

Is it possible that you're running into this, since it sounds somewhat similar as far as PCCE v12, same error message, etc.?

Hi Bill,

Thanks for the feedback, but I am facing this issue only when trying to reach the CVP reporting server, and not the Dialed number section. Could be same cause ??


Unfortunately, only Cisco would be able to tell you that. It could be one of those situations where they didn't include a lot of detail in the defect and it covers multiple flavors of the issue, or it could be completely coincidental. Only TAC would be able to tell you for sure, unless someone else on PCCE v12 who reads this thread can confirm for you.

Konstantin Vaksin
Cisco Employee
Cisco Employee

As first step, I would recommend you to check tomcat logs.

You will be able to see from where this error comes from


Hi Konstantin,


From AW Tomcat Logs, i can see the below error:


Jun 02, 2020 2:48:51 PM org.apache.shindig.gadgets.http.BasicHttpFetcher fetch
INFO: Got Exception fetching - 12ms PKIX path building failed: unable to find valid certification path to requested target


does it say something to you?



For me it says, that you have to import certificate to AW from the Reporting server

Here is details


Hi konstantin,


I have already implemented this but still facing the same issue... 

i have installed the AWA and AWB CER certs 64 bit encoded and then uploaded them to CVP reporting server.

but still no luck to make it work. what about the CVP reporting server certificate ?? how can we import its certificate to AWA and AWB?? specially that CVP reporting does not have any tomcat service available, so i cannot see where can i extract the CVP reporting certs?



There is Tomcat with CallServer service.

Shoot SR to Cisco TAC, if that doesn’t help


Are you using a CA signed of self-signed for the CVP Reporting server?  I had the same issue when using a CA signed and when I switched to self-signed on the CVP Reporting server and installed on the AWs it worked. 

I tried installing the CVP reporting server self signed certificate, but didn't work. And I noticed that when I opened the certificate, the CN was the server hostname without the FQDN. in other words, the CN of the self signed certificate is hostname, while it should be is this normal ?? And if not how can we generate the self signed certificate with the CN = FQDN and not just the hostname


Thank you in advance

You need to gave FQDN in certificate.

You can always re-generate it

Hi Konstantin,


CVP reporting server does not have any IIS, i am trying to generate the certificate and it worked for me but whenever i open the below link:




the browser is still requesting the old wsm certificate. how can i force the tomcat to use the new generated self signed certificate and not the default one



Thank you konstantin.


That was helpful



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers