cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
687
Views
0
Helpful
5
Replies

Recover CCX Script from v8.5

Hello, I create a demo script using CCX v8.5.1 with DB access included time ago, now I want to recover and use the script using CCX v11.5.1 but I got an error message when trying to edit script with CCX Editor.

 

Captura.JPG

How can I recover access to the script??  I think that I need CCX Editor v8.5.1 for doing this, is this correct?? If the answer is yes I´m looking for someone that please could give me a link to download CCX Editor versión 8.5.1, I´m not able to get the CCX installation of that versión to get it.

 

I really appreciate all of your help.

 

Regards,

Juan Carlos Arias

 

5 REPLIES 5
Sean Lynch
Rising star

Were you previously using a customer .jar file that did not get copied over?  Also, did you verify that you updated/uploaded your jdbc drivers to access your database DSNs?

 

-Sean

Hello Sean, I upload same database driver used before (jtds-1.2.5.jar) and also define DataSource, the JDBC URL it´s defined with different IP address, I really don´t remember the previous IP address used for the SQL Server.

 

But, does this matters??  I mean if I edit script on a standalone mode without connecting to CCX, I should be able to open it, is this right??  I just need to access to the code, not to connect to database.

 

Thanks for you comments.

Regards,

Juan Carlos Arias

 

That sounds correct.  On your new instance of UCCX, the new remote database IP address should not matter, and it shows "Test Connection Successful" when you "Test Connection" link on your Data Source Configuration--correct?

 

The other concern, was (and I see a typo on my part in my previous response); do you have any custom .jar files imported on your old system that did not get imported into the new system?  If there is a reference to a custom .jar file in the script, it will not load in the new editor if the resources are not available.

 

-Sean

Sean, yes the connection success with new data source configuration.

 

Not that I remember I loaded a custom .jar file, I was also thinking about the CCX Editor version, I think that it must match version on how the script was generated, but the problem is that I´m not able to get that CCX version, I need to get a CCX editor version 8.5, don´t you think this could be a solution??

 

Regards,

Juan Carlos Arias

You can open previous versions of scripts with newer versions of the script editor.  That's how we validate and upload them to a new cluster migration.  You must validate a script with the version of the script editor of the application/UCCX software release  you are running.

 

 

-Sean

 

Create
Recognize Your Peers
Content for Community-Ad