Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

Redirect step in UCCX does not have ringback on the sip trunk


I have probelm when I use a redirect step in UCCX script. When the call is directed to the destination the calling party will not hear ringback tone (dead air) till the destination pick up the phone. This happens only if the call is received from out side call manager through sip trunk, but if the phone is registered with call manager the ringback is working.

The version of UCCX is 7.0 and the call manager is 5.1

Do you have any idea what the cause of the problem. and how can I solve it??



Andrew Skelly
Rising star

I had this same problem on 7.0 as well.  Resolved it by enabling Media Termination Point Required on the SIP trunk.

Please rate helpful posts by clicking the Chuck Taylor logo!

Hi Andrew,

I am having the same problem as well with our SIP - CUCM 8. - UCCX 8. setup.

When an inbound call comes in from the SIP Trunk to the IVR(which is a script in a UCCX), then the caller dials an extension through the IVR no ring back is heard.

I have enabled "Media Termination Point Required" and tried it but did not work.  Would you have any other configuration that i might have missed?  Do I have to enable MTP as well on the cube?

Please let me know if you need more info.

I had the same problem with CUCM 9.1(1a) and UCCX 9.0(2).   I enable MTP on the CUBE gateway and checked the MTP resource on the CUCM SIP trunk configuration and it resolved the issue.

Hi Dennis

We had same problem with call manager and UCCX version , but we running Telstra SIP CUBE and DO NOT select this option. CM Software MTP only supports G.711 as the telstra recommend .

So which menas we have to enable MTP on CALL manager and CUBE gateway for fix this issue ?

Please advise .



Brett Hanson

I had a similar but not the same problem in a later version - it didn't involve UCCX and I did get ringback/fast busy but where I receive immediate ringback before it even knows if the call will be able to connect - e.g. if a phone was busy - it would ring a few times then present fast busy.

If the phone wasn't busy, it would ring a few times (to the caller) before it started ringing at the other side.

I believe my issue was resolved by setting 

"SIP Rel1XX Options" to "Send PRACK if 1xx Contains SDP" in the SIP Profile configuration in CUCM.

Note that we also use a CUBE router.

Don't know if this helps at all - but it might be where you need to look.

Yours may be set to "disabled" (which means that 180 [ringing] messages are not reliably delivered) or you may need to set it to "Send PRACK for all 1XX messages"

Options available are (per ) 

SIP Rel1XX Options

This field configures SIP Rel1XX, which determines whether all SIP provisional responses (other than 100 Trying messages) get sent reliably to the remote SIP endpoint. Valid values follow:

Disabled—Disables SIP Rel1XX.

Send PRACK if 1XX contains SDP—Acknowledges a 1XX message with PRACK, only if the 1XX message contains SDP.

Send PRACK for all 1XX messages—Acknowledges all1XX messages with PRACK.

If you set the RSVP Over SIP field to E2E, you cannot choose Disabled.


Hope this helps anyone else out there.

Content for Community-Ad

Spotlight Awards 2021