cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

659
Views
0
Helpful
2
Replies
sathesujit
Beginner

Send to VRU failure in ICM script

Hi,

This is my first install/Configuration of UCCE. I am in a process of to configuring a lab environment FOR 11.5 and have completed instaling a SPRAWLER and CVP Combo server.

Created a test script that simply plays "thankyou.wav" from sys folder on CVP.  It fails at "Run External Script" node which I believe internally invokes "Send to VRU". I know the script is fine because its working fine in 10.0 lab.

I went through the "Send to VRU" Troubleshooting guide PDF but could not relate it with my environment which has only 4 components below -

SPRAWLER

Cvp Combo

CUCM

VXML Gateway

Attached are the VXML gateway and CVP Combo server logs.

Thanks for the help !

Sujit Sathe

2 REPLIES 2
Edward Umansky
Enthusiast

What model of router and IOS version are you using on the ingress and VXML gateways for this call flow? Have you made sure to upload the 11.5 version of all CVP gateway files (i.e. TCL and VXML scripts)?

Cisco 2821 router & IOS 12.4

I don't have ingress gateway. soft phone is registered with CUCM and call gets to ICM script using a CTI routepoint in CUCM.

I think your 2nd question is pointing to the issue. I have not uploaded the TCL and VXML for 11.5. because I was trying to share the VXML gateway with 10.0 lab..and thought I could use the tcl andxml files from 10.0 CVP for 11.5.. but looks like it doesn't work that way..

I was able to make the script work using the Virtual voice gateway without issues.

Thanks for your reply.

Regards,

Sujit Sathe

Content for Community-Ad