cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
479
Views
4
Helpful
5
Replies

Spark Team Announcements

anihiser
Beginner
Beginner

Hello,

I have been following along with the Spark Team Announcements and Finesse integration. I believe everything appears to be configured correctly but I wanted to get confirmation on what I think might be causing an authentication error.

When I log into finesse I am using local domain credentials, the Finesse authentication is requesting credentials I chose when I signed up for the free account. I just read that the free spark app will work with Finesse so I am missing something here I am sure. How do I reconcile the differences between finesse and spark free app credentials to make this integration work?

To describe what is happening:

1) sign into finesse using my enterprise credentials (LDAP)

2) get a pop up that takes me to the Cisco spark sign in page. Also get the Spark Team Announcements segment with a status of "loading..."

3) I sign into Cisco spark using my Cisco spark credentials.

4) Once signed in I get a persistent "authenticating" on an all white web page. I've waited for quite some time and this doesn't seem to go through.

Could this be due to separate credentials? Or have I truly messed up the configuration somewhere along the line?

Thank you ahead of time for any assistance on this.

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Adam,

That is good that you were able to move forward and get the page to close.

Since you said that you got it to work once, that means that you should have everything configured properly. There is a chance that when you logged back in the second time, it is loading an older cached version that has the wrong values? I would recommend you use the nocache option in the url to verify.

If it works with the nocache, please restart the "Cisco Finesse Tomcat" (or sometimes even the whole finesse server) to clear the cache.

If it does not, try to clear your browser cache. Then, take a look at the client logs either via the browser's developer tools' console or by submitting the client logs to see what the issue is. Most likely it cannot find the spark token in the cookie. If so, take a look at the browser's cookie to see if you can see it yourself. If you can't, then the issue is in the oauth.html where it isn't setting the cookie correctly.

Thanx,

Denise

View solution in original post

5 REPLIES 5

dekwan
Cisco Employee
Cisco Employee

Hi Adam,

Someone had the same issue where the "authenticating" page never went away a week ago. Their issue was that in the oauth.html code, their var OAuthRedirectURI was set incorrectly. This value should be exactly the same as what you put into the Spark's Integration detail's "Redirect URI(s)". For example: https://finesse.cisco.com:8445/3rdpartygadget/files/oauth.html

If this isn't the case for you, I would recommend adding an error section to the ajax call of the oauth.html and see the response that the Spark API is returning. I am assuming that it is going into the error section. If it isn't getting into the error section, I would add some alerts or logging into the success scenario and see where it is getting stuck.

Seeing the response that the Spark API call for getting the token will let you know if you have bad credentials or what the issue is.

Thanx,

Denise

Thank you Denise I followed your advise and was able to move to the next step. The Authenticating message now pops up and goes away after signing in to Spark. Now the Finesse Gadget just show "loading...".

Strangely enough I got it to work briefly after creating a new room and changing the "Spark Room=" parameter in the finesse admin console. It worked once, I was able to send out an announcement to the room I logged out and back in and it is back to "loading...". I can see the test message via the Spark web client.

Hi Adam,

That is good that you were able to move forward and get the page to close.

Since you said that you got it to work once, that means that you should have everything configured properly. There is a chance that when you logged back in the second time, it is loading an older cached version that has the wrong values? I would recommend you use the nocache option in the url to verify.

If it works with the nocache, please restart the "Cisco Finesse Tomcat" (or sometimes even the whole finesse server) to clear the cache.

If it does not, try to clear your browser cache. Then, take a look at the client logs either via the browser's developer tools' console or by submitting the client logs to see what the issue is. Most likely it cannot find the spark token in the cookie. If so, take a look at the browser's cookie to see if you can see it yourself. If you can't, then the issue is in the oauth.html where it isn't setting the cookie correctly.

Thanx,

Denise

Hello Denise,

Thanks for all of the help!! I got this up and running now and this is such a great feature you have created for us to integrate with Finesse. Thank you and the rest of the devs working on this project!!

I found that the spark token was not being accepted. I noticed I had been logging in using the format https://finesseip:port/desktop/container so I tried <https://fqdn:port/desktop/container and it accepted the token. I also noticed that the finesse admin gadget configuration was so long it split the code across 2 lines. It wasn't properly split and there was a space between line 1 and line 2. Once these 2 issues were resolved it worked. Thanks again for all the help.

Hi Adam,

I'm glad you were able to get the gadget working!

Thanx,

Denise

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: