cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1137
Views
5
Helpful
1
Replies

Studio Callback sample error "no Gateway Address defined"

Quigath
Enthusiast
Enthusiast

I have been going through tutorials to set up the Cisco sample callback application. So far my ICM script is working and I can get it to hit the CallbackEntry script. However, it is failing at the Validate_01 element, here is the activity log:

10.10.90.9.1529430041672.92.CallbackEntry,06/19/2018 10:40:46.501,Validate_01,element,warning,"Error: no Gateway Address defined" returned from sending Callback_Validate request to CallbackServlet

Looking at the code in Validate.java on line 444, this error is sent due to httpClient.getXMLReturnStatus(); not returning "success" as the http result. The httpClient status code looks to still be 200 at this point so I think the url it has is correct.

Wondering if there's some server config or routing that I missed in order to get the correct gateway address. I'm not actually sure what the value is or what it's supposed to be.

For reference, the _ccbServlet parameter is:

10.10.90.9.1529430041672.92.CallbackEntry,06/19/2018 10:40:41.672,,start,parameter,_ccbServlet=http://10.10.90.9:8000/cvp/CallbackServlet

Can anyone help with this?

1 Reply 1

Quigath
Enthusiast
Enthusiast

Make sure you call in from an external line so it hits the CUBE and not UCM.

Recheck your setup of CCB - https://community.cisco.com/legacyfs/online/legacy/2/2/8/86822-Courtesy Callback quick configuration steps 1.1.pdf
This must have something to do with my CUBE. After I reboot it, my CCB script works perfectly.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers