cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1912
Views
0
Helpful
4
Replies

UCCE 11.6 . CUIC - Live Data Datasource Not Connected

awickland
Beginner
Beginner

I am in the process of updating a lab environment to match a customer's Production environment. The entire lab is up and active and everything is working as it should, except for Live Data.

 

Looking in to the LiveData datasources,  both LD servers in the lab environment show disconnected. I have proceed to validate the SQL user credentials and permissions to connect to the AW HDS are valid and I am able to connect and run the following commands:

 

show live-data aw-access

show live-data cuic-datasource

show live-data machine-services

 

All of the responses appear to come back clean. 

 

Firing up RTMT to look at the CUIC server and check the Real Time 

 

I see the following: 

 

0000000431: 10.53.114.50: Nov 06 2019 17:20:05.577 -0500: %CCBU_CUIC_DATA_PROCESSING-0-ERROR:   <- StreamingConnectionPoolManager.java:185Error while retrieving token from livedata service: UNAUTHORIZED - The realm denies access for the provided user-credentials.

0000000432: 10.53.114.50: Nov 06 2019 17:20:05.577 -0500: %CCBU_CUIC_DATA_PROCESSING-0-EXCEPTION_INFO: %[build_date=Jan 18, 1970 4:14 AM][build_type=rel][exception=java.lang.RuntimeException: UNAUTHORIZED - The realm denies access for the provided user-credentials.

                at com.cisco.ccbu.cuic.objectmodel.datasource.plugin.streaming.StreamingConnectionPoolManager.getToken(StreamingConnectionPoolManager.java:178)

                at com.cisco.ccbu.cuic.objectmodel.datasource.plugin.streaming.StreamingConnectionPoolManager.getToken(StreamingConnectionPoolManager.java:226)

                at com.cisco.ccbu.cuic.objectmodel.datasource.plugin.streaming.StreamingConnectionPoolManager$1.run(StreamingConnectionPoolManager.java:99)

][product_name=CUICJava][subsystem_exception_info=][tid=LD Service Validator][version_number=CUICJava_11_5_1_0_0_0_112]: Information associated with the following logged exception

 

Obviously there is a cred mismatch somewhere, but the LD datasource was working correctly prior to restoring the databases.

All of the commands above where it required credentials to connect to the AWDB  for validation were successful.  I also can log in directly with SQL authentication with that same username and password, and it works as well. 

 

#CUIC #LiveData #UCCE

 

4 Replies 4

Omar Deen
Collaborator
Collaborator

Run these commands and copy paste your findings...

show socketio status

show open ports regexp :4[0-5]03[45]

Are your ICM components and Live Data servers on different domains?

Hey Omar,  

 

Long time no talk...

 

ICM and LiveData servers are on the same domain.

 

Commands run from primary LD server: 

 

admin:show socketio status

Server Status: Active

JMS Brokers: tcp://localhost:61616,tcp://ADC01TCCECUICLDB:61616

Active Broker: Local

Client Count: 0 (polling: 0)

admin:show open ports regexp :4[0-5]03[45]

 

 

Executing.. please wait.

java      23441     mmca_user  150u  IPv4   207043      0t0  TCP 10.53.114.60:48514->10.53.115.10:40035 (ESTABLISHED)

java      23441     mmca_user  151u  IPv4   207047      0t0  TCP 10.53.114.60:60912->10.53.243.10:41035 (ESTABLISHED)

java      23441     mmca_user  152u  IPv4   207049      0t0  TCP 10.53.114.60:58413->10.53.242.20:43035 (ESTABLISHED)

java      23441     mmca_user  153u  IPv4   207053      0t0  TCP 10.53.114.60:48345->10.53.114.20:42035 (ESTABLISHED)

java      23441     mmca_user  154u  IPv4   207054      0t0  TCP 10.53.114.60:21409->10.53.114.21:42035 (ESTABLISHED)

java      23441     mmca_user  155u  IPv4   207057      0t0  TCP 10.53.114.60:43495->10.53.242.21:43035 (ESTABLISHED)

java      23441     mmca_user  158u  IPv4   226281      0t0  TCP 10.53.114.60:31626->10.53.243.10:41034 (ESTABLISHED)

java      23441     mmca_user  159u  IPv4   226287      0t0  TCP 10.53.114.60:25540->10.53.115.10:40034 (ESTABLISHED)

java      23441     mmca_user  160u  IPv4   226288      0t0  TCP 10.53.114.60:13990->10.53.114.21:42034 (ESTABLISHED)

java      23441     mmca_user  161u  IPv4   226284      0t0  TCP 10.53.114.60:20007->10.53.242.21:43034 (ESTABLISHED)

java      23441     mmca_user  162u  IPv4   226285      0t0  TCP 10.53.114.60:28844->10.53.114.20:42034 (ESTABLISHED)

java      23441     mmca_user  163u  IPv4   226289      0t0  TCP 10.53.114.60:36014->10.53.242.20:43034 (ESTABLISHED)

admin:

Did you ever resolve this issue? I am facing something similar... 

 

%CCBU_CUIC_DATA_PROCESSING-0-EXCEPTION_INFO: %[build_date=Jan 17, 1970 6:01 PM][build_type=rel][exception=java.lang.RuntimeException: UNAUTHORIZED - The realm denies access for the provided user-credentials.
at com.cisco.ccbu.cuic.objectmodel.datasource.plugin.streaming.StreamingConnectionPoolManager.getToken(StreamingConnectionPoolManager.java:178)
at com.cisco.ccbu.cuic.objectmodel.datasource.plugin.streaming.StreamingConnectionPoolManager.getToken(StreamingConnectionPoolManager.java:226)
at com.cisco.ccbu.cuic.objectmodel.datasource.plugin.streaming.StreamingConnectionPoolManager$1.run(StreamingConnectionPoolManager.java:99)

rieda
Beginner
Beginner

Hi,

 

I have the same issue, but more strange.  Using CUIC 11.6.1 ES20 and separate LiveData Servers (same version).

The CUIC A side is working fine. CUIC is connected to LiveData side A and B

Only the CUIC B side is not connected to LiveData stream. To no one of the LiveData servers.

 

What could I check to find the differences between both configurations?

 

 

Regards

Alex

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers