cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

161
Views
0
Helpful
2
Replies
Highlighted
Beginner

UCCE Compatibility Matrix Clarification (Gateway IOS)

With regards to Gateway Hardware/Software support on the UCCE compatibility Matrix, does anyone know if the Minimum software IOS versions apply to all Gateways in the call path or only the UCCE ingress/VXML Gateway (assuming you're still using hardware)?

 

For example, if the call path is:

Sip Carrier >> Cisco ASR Cube >> Cisco 3945 (Inress/VXML) >> CVP

 

Does the ASR Cube need to be at minimum compatibility spec (OS XE 16.6/16.9 for UCCE ver 12) as well as the 3945 (15.6(3)M1 / 15.7(3)M1 for UCCE ver 12)?

 

The question is relevant for the customer as they cannot upgrade their Cubes past 15.x code without upgrading hardware which they would prefer not to do at this time.  Their 3945's are capable of running the latest IOS.

 

Any insight is appreciated.  

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: UCCE Compatibility Matrix Clarification (Gateway IOS)

Hi,

As per cisco Version 12.x it should run below IOS.( 16.x)
isr4400-universalk9.16.06.07.SPA.bin

 

but we are running on below IOS without any issues (03.x)
isr4400-universalk9.03.16.02.S.155-3.S2-ext.SPA.bin

 

For Ingress and VXML should be CVP supports listed IOS. but best practice is to try to upgrade all the Hardware IOS ASAP.

 

 

View solution in original post

Rising star

Re: UCCE Compatibility Matrix Clarification (Gateway IOS)

Hi Mark,

@Ramamoorthy Shanmugampretty much answered this, but I'll go into a little bit more detail about it.

There's no minimum requirements per se when it comes to Cisco IOS. The versions that you see listed in the matrix are versions that have been tested and QA'd with that ISR or ASR hardware model. I like to think of that matrix as a list of what the maximum version you should go to rather than minimum. So for instance, in CCE 12, the matrix lists IOS XE 16.9 for the 4451 ISRs. Now, even though it says 16.9, that doesn't mean there isn't other versions. 16.9 was released in July 2018, mean while, Cisco released 16.12 in July 2019. So that should be interpreted as... do not go beyond IOS XE 16.9, but you're perfectly fine running a version like 16.3 so as long as it meets your business requirements (bandwidth, calls-per-second, DSP related stuff, etc...). It's similar to the virtualization stuff... on the virtualization page, the supported ESXi versions for CCE 12 are at most 6.5 Update 2, but 6.5 Update 3 has been out forever and ESXi 6.7 has been GA since April 2018, yet, it's not in the matrix. You would never run your hosts with ESXi 6.7 knowing that it's not listed as a supported version... same should apply for Cisco IOS.

Hope that helps

 

Please rate helpful posts

View solution in original post

2 REPLIES 2

Re: UCCE Compatibility Matrix Clarification (Gateway IOS)

Hi,

As per cisco Version 12.x it should run below IOS.( 16.x)
isr4400-universalk9.16.06.07.SPA.bin

 

but we are running on below IOS without any issues (03.x)
isr4400-universalk9.03.16.02.S.155-3.S2-ext.SPA.bin

 

For Ingress and VXML should be CVP supports listed IOS. but best practice is to try to upgrade all the Hardware IOS ASAP.

 

 

View solution in original post

Rising star

Re: UCCE Compatibility Matrix Clarification (Gateway IOS)

Hi Mark,

@Ramamoorthy Shanmugampretty much answered this, but I'll go into a little bit more detail about it.

There's no minimum requirements per se when it comes to Cisco IOS. The versions that you see listed in the matrix are versions that have been tested and QA'd with that ISR or ASR hardware model. I like to think of that matrix as a list of what the maximum version you should go to rather than minimum. So for instance, in CCE 12, the matrix lists IOS XE 16.9 for the 4451 ISRs. Now, even though it says 16.9, that doesn't mean there isn't other versions. 16.9 was released in July 2018, mean while, Cisco released 16.12 in July 2019. So that should be interpreted as... do not go beyond IOS XE 16.9, but you're perfectly fine running a version like 16.3 so as long as it meets your business requirements (bandwidth, calls-per-second, DSP related stuff, etc...). It's similar to the virtualization stuff... on the virtualization page, the supported ESXi versions for CCE 12 are at most 6.5 Update 2, but 6.5 Update 3 has been out forever and ESXi 6.7 has been GA since April 2018, yet, it's not in the matrix. You would never run your hosts with ESXi 6.7 knowing that it's not listed as a supported version... same should apply for Cisco IOS.

Hope that helps

 

Please rate helpful posts

View solution in original post

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here