cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

11874
Views
0
Helpful
47
Replies
Enthusiast

Re: UCCX email queues

Hi Richard

In the CAD installation guide for Exchange 2007 on page 92 is says:

IMAP Connections per User

By default, the maximum number of IMAP connections per user in MS Exchange 2007 is 10. Every agent and the E-mail Service uses the same user ID, so this number is far too low. It is recommended that the number of IMAP connections is increased to 2,000 (I'm quite sure this has been raised from 1000 to 2000 recently)

But we are running Exchange 2010 and have done this setting on exchange 2010 (maximun connections from a single user = 1000 ) but still experience errors where agent imtermittendly can't login on exchange. We can se the problem with a command promt and a telnet connection to the exchange; sometimes it works and sometimes it doesn't.

Will try to raise max to 2000 as I think this is new info.

Henrik

Beginner

Re: UCCX email queues

Hi Guys,

I’ve ensured the mac settings for imap has been configured, the main issue causing this now is the following error message:

2011-11-07 17:35:17,604 FATAL EEM1003 Cannot connect to IMAP service: javax.mail.MessagingException: Unrecognized SSL message, plaintext connection?;

nested exception is:

javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?

2011-11-07 17:35:17,604 WARN EEM3000 Could not make secure IMAP connection.

2011-11-07 17:35:17,665 INFO EEM0000 Trying non-secure connection IMAP server failed to connect to any service.

It is telling us that these credentials are incorrect, however we can create a mail profile in outlook and successfully login using CLI with the above credentials and username

We are digging deeper with CDA CCX logs now,

Will keep you posted

Regards,

Scott

Beginner

Re: UCCX email queues

@Henrik

I must have missed the imap info in the docs, apologies to Cisco for false accusation of missing content! Also pitty that my issue is not the same for you. Seems like you are hitting an Exchange issue as if you are having problems with imap over basic telnet. Might it be worth running up a new Client Access server to test a fresh imap config? Just an idea.

@Scott

I would suggest switching your imap authenication over to plaintext in exchange. This is done via a powershell command - not sure if it can be done via GUI. I am not even sure if UCCX supports encrypted IMAP sessions? However I would at least try and get it working unencrypted first, then switch over to encrypted if you need it.

Anyways good luck guys

Beginner

Re: UCCX email queues

Thanks Richard,

I’ll have our exchange guys to give that a go for me, seems error and what you describe seem to go hand in hand.

As always, will keep you posted.

Scott

Enthusiast

Re: UCCX email queues

Hi Scott,

Wanted to verify where the issue is, you wote the following

Scott Brien wrote:

The agent email tab in desktop administrator is stuck on loading.



Do you mean when you login to Cisco Desktop Administrator and try to configure the Global Settings? Or do you mean the actual CAD client is stuck loading the Agent Email Applet and no emails are being sent to the agents?

Depending on the exact problem you may want to try a couple of things out;

Be sure that the correct version of Java is installed on the agent PC, the best way to complete this is to uninstall all Java versions from the agent PC, then load CAD and allow CAD to download the version it needs to work correctly, Java 1.6.0 update 17. Then configure Java for CAD per the following guide, page 76

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_8_5/installation/guide/cad85ccxig-cm.pdf

If agents are still not able to receive emails, you may need to add "send as" permissions for the user that is configured in CDA under the Global Settings on Exchange, see page 93

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_8_5/troubleshooting/guide/cad85ccxtg-cm.pdf

Regards

Joe

Beginner

Re: UCCX email queues

Hi Joe,

The issue here lies with CAD and the user being places in email log out or email not ready and being unable to change between email not ready and email ready.

I will try removing java and CAD and re-installing as suggested and also add the send as permission on exchange side,

Will let you know how we get on.

Regards,

Scott

Enthusiast

Re: UCCX email queues

Hi Scott

Found this in CAD troubleshooting guide page 90:

Problem

I'm sure my login is correct, but I still can't get logged in to IMAP, even though it works in Outlook.

Solution If outlook works, but Telnet does not, it is probably because the account you are using to log in is an NT domain account. When logging into IMAP you need to specify the login as follows: NTDOMAIN/NTACCOUNT/ALIAS For example, if your e-mail address is "Jane.Doe@myserver.com", your Windows NT login name is "jdoe", your NT domain name is "mydomain", and your Exchange mailbox name is "Jane Doe", you would then need to use a username of "mydomain/jdoe/Jane.Doe" when logging in.

Henrik

Beginner

Re: UCCX email queues

Hi Henrik,

Unfortunately we are using the domain/username/alias for CDs configuration and it is working through outlook and telnet.

We will test the clear text authentication on exchange and see where that leads us.

Regards,

Scott

Enthusiast

Re: UCCX email queues

Hi Scott

I have same problems as you it seems.

With IMAP over 143 the login is rejected most of the times (even if done via telnet command from client PC) but when lucky and connection is OK agent is email ready and can answer mails. Though some agent gets stuck in E-mail logged out and other experience problems deleting a mail which then gets stuck in inbox even if it's deleted in Exchange.

With IMAP over 443 agents login seem ok in logfile, but agent cant get list of emails and icons are grayed out

EEMUI3002 The Applet could not load the list of assigned emails.

When asssgning IMAP server on port 443 I can't use hostname, only IP adresse is accepted.

So lots of fun :-)

Enthusiast

Re: UCCX email queues

Scott

Got it working now on port 993 vith help from an exchange specialist. Don't have the full solution yet (will post it when I do) but there were some issues with certificates.

Agents are now able to login when agent starts (email icons active) and e-mail handling is very much faster. When it was vworking before it took anywhere from 2-5 minuter between mail assignments to agents from the queue.

Setup with port 143 is dropped, just doesn't wok properly.

Henrik

Enthusiast

Re: UCCX email queues

Scott

Runs like a charm now I'm no exchange expert so below is cut from description i recieved.I'm sure your exchange guys knows what to do from this?

Before:

UnencryptedOrTLSBindings  :{0.0.0.0:143}

SSLBindings                       : {0.0.0.0:993}

InternalConnectionSettings   : {xx-EXCH.xxxxxxxxx.xx:993:SSL, xx-EXCH.xxxxxxxxx.xx:143:TLS}

X509CertificateName            : xx-EXCH.xxxxxxxxx.xx

LoginType                           : SecureLogin

Now:

Create new DNS A-Record "imap.xxxxxxxx.xx" to exchange server ip adress (y)

UnencryptedOrTLSBindings  :{y.y.y.y:143}

SSLBindings                       : {y.y.y.y:993}

InternalConnectionSettings   : {xx-EXCH.xxxxxxxxx.xx:993:SSL, xx-EXCH.xxxxxxxxx.xx:143:TLS}

X509CertificateName            : imap.xx-EXCH1.xxxxxxxxx.xx

LoginType                           : SecureLogin

Enthusiast

Re: UCCX email queues

Hi again

After these settings the existing wildcard certificate is attached to IMAP servicen and MSexchangeIMAP serveice is restarted.

Agents restart CAD application and then it runs (hopefully)

Let me know if it worked at your end...

Regards Henrik

Beginner

Re: UCCX email queues

Hi Henrik,

I have sent this info to our exchange team, I will advise once tested how this went.

Thanks for your help on this one.

Regards,

Scott

Enthusiast

Re: UCCX email queues

Hi again

Sorry to say that we still have issues with this. Agents keep going in loading or not beeing able to delete mails.

We have tried to remove all java from client and install only version 1.6.0_20, which according to compababillity matrix is the latest supported.

Did you manage to get your mail clients running ?

Henrik

Highlighted
Beginner

Re: UCCX email queues

Unfortunately not, we are having issues with the secure imap in our dev lab, we are waiting on a reply from TAC on this one and will go from there

Regards,

Scott

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here