Showing results for 
Search instead for 
Did you mean: 

UCCX Error

Level 1
Level 1

We have strange problem in UCCX 7.0(1)SR05. in admin page all menus work properly(update/delete/Add) but inapplication/ application management we have problem. When we update the existing application the following error resolved. (add new application is not possible either).

What is the source of this problem? and how can it be solved?

10 Replies 10

Michael Green
Cisco Employee
Cisco Employee

What is the error?

when I try to add new application or update existing applications I see blank page with following error on IE task bar: "document.forms.scriptappform.success is null or not an object". I check it both on IE and firefox and in different PCs. it worked correclty till yesterday. I do not change anything.



The error you are seeing is generated by your browser.  It doesn't like something it's being asked to execute in a browser based script.  Normally in web applications, the root cause of this has to do with either ASP/ .NET support issues (like a library not being loaded) or a Java Runtime Engine mismatch.  Not all JRE's are equal, and unfortunately what works with one Cisco application doesn't necessarily work with another.  Of course, this assumes that the error isn't actually with something you're doing wrong (like trying to load character data into a integer field).

Troubleshooting this problem, I would go about like this:

1.  Reboot the server.  This is to make sure you clear any issues that might be hanging out with the OS or the application itself in a flakey state.

2.  Log onto the UCCX server itself, either directly on the console or via Remote Desktop.  Try doing the same action from the server console that was failing and see if it works there.  If it works there, then the problem with with the JRE on the machine you were working with.  Generally, if you need to switch JRE versions, JRE version 6.0.12 is a pretty good one to use for the version you're on.

3.  If it also fails on the console, confirm the JRE version you're running there.  You should never allow the JRE to update itself outside a Cisco installed patch unless told to do so by TAC.  Open the Windows Control Panel, and find the Java icon.  Double click it to open, and select the Java tab.  Click the view button, and it will show you what versions you have set up on the machine. My lab machine reports 1.6.0_12.  If this isn't what you have, I'd suggest you download that version and install it.

4.  If everything matches up and you still have a problem, check and see if you can load a very simple script and then attach it to an application that simply has steps like start, accept, play a prompt, and hang up.  If this works, but you still have an error with your script, chances are something is wrong with the script you're trying to load.  Open it with the editor, and run the validator on it.  If it passes, but still won't load, try removing any time of day / day of the week steps, and then see if it will load.  If that works, make sure you're working with the version of the editor that is current for the patch level you're on, and remove those steps, and then rebuild them in the editor.  Those steps are problematic across versions.

This should get you started.  Let us know how it works out.


I did all the steps that you've mentioned.

1. Reboot the server and check the problem( add new application in application management and got the previous error). also updating the existing applications was encountered previous error

2. I checked the JRE version too. we have two JRE version:

1.5.0_14 & 1.6.0_12 which both of them are enable. disabling the old version was not help either.

3. We have this problem both in different browsers. I checked it in my own PC (ie , firefox) and also on the UCCX server. all of them are unsuccessful.

4. for more assurance, I wrote a very simple script(just play one prompt) and upload it to UCCX. It was uploaded successfully. but when I want to add new application I got the same error.

5.( The editor is compatible with UCCX7(we downloaded it from plugins UCCX7

By the way, If we upload the scripts which is written on older version of CRS and upload it to UCCX 7 will it make problem?

Hi Saeed,

Run the older script (previous version) in script editor for UCCX 7. This will update and covert the script files for your new version of CCX. Then upload the script to script management.



Ok.  Sounds like the problem is a bit deeper.

Try running a database resync on the system.  If the problem still persists after that, you're going to need to get TAC involved as something else is going on.

Ruslan Amrahov
Level 1
Level 1

Hi there, I've got the same error on the same version of UCCS. Did you managed to solve it somehow?

You are running UCCX 7.0(1)SR5? You should probably be aware that UCCX 7.0 is end of support at the end of this month:

I did a quick search on this and it looks like this error can be associated with underlying database issues. One of the most common which has contributed to this is running out of space. Check the state of your db_cra database, perform a manual purge if required. See if this helps at all as a starting point.

Ruslan Amrahov
Level 1
Level 1

Hi, thans for the update. I've opened the case with cisco, it was an issue in database replication. After the fixing the replication it worked great.

Cool, glad to hear you got it fixed!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: