cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1816
Views
9
Helpful
6
Replies
Highlighted

UCCX goes to License package None after demo license expires and system reboot

Hi,

I'm observing the following issue on UCCX (version 10.6.1.10000-39):

  1. UCCX has permanent Premium seats working fine;
  2. add a demo/temporary license (either additional Premium seats or Outbound IVR ports);
  3. let the demo license expire;
  4. restart the UCCX server;
  5. UCCX stops working and shows Cisco Unified CCX License package is None

It happened twice to me, even after a re-install and manual reconfiguration from scratch of the whole system.
The only workaround is remove the demo license file from CLI (utils uccx delete license <filename>) and restart.

Anyone ever hitting this one? Is this a known issue?

Thanks and regards.

6 REPLIES 6
Cisco Employee

It should not happen if there

It should not happen if there is a permanent license file installed on the server. Also, it is important to know that the downgrade of license type is not supported that can also cause this issue. What I mean by this is that if you applied the Demo/Temporary license with Premium feature and now you applied the Permanent license with Enhanced or Standard then the issue which you faced will happen.

Also, it is not supported to use a mix and match of license feature such as you have premium license for server and enhanced for agent seats. If all this is not the case on your side and still you are facing the issue then involve TAC so that they can collect logs and investigate it further.

Regards

Deepak

Hi Deepak,

Hi Deepak,

Thanks for your answer. I confirm no mix and match was done and also the permanent license was already installed in the server. Perhaps I'll open a TAC case, thanks.

Beginner

I had an expired temp WFM

I had an expired temp WFM license on my CCX server and CCX came up as "None" after a reboot.  We ended up deleting all the expired temp licenses from the CLI ("utils uccx delete license <licenseName>") on both nodes, rebooting the CCX cluster, and it came back up on the correct licensing.

The TAC engineer said he's seen it before where an expired license causes the whole system to come up without licensing.

-Mark

Frequent Contributor

Hi,

Hi,

This also happened to my customer, I had temp licenses and later I got real licenses. After the temp licenses expired, the UCCX came to a halt.

I contacted licenses from Cisco and they solved it. But it is really a big mistake!

JH

Beginner

Hi,

Hi,

We had this issue also today at a customer! Thanks to your post we were able to solve it quickly! :-) Many thanks for this info!! :-)

Cheers,
David

Beginner

hi,

hi,

is there a bug filed for this issue? i just had the same issue today and fixed by removing expired lics.

thanks,

John Nguyen

Peak IP Solutions, LLC

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards