cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3895
Views
25
Helpful
13
Replies
Beginner

UCCX "Error occurred while reading the Resource" no adding agents.

Hello i have UCCX 10.5.1.11001-49 and CUCM 10.0.1.12900-2. User's sync with Active Directory. When i adding Agent. Some people not adding to UCCX. I not see in RmCm  resources agent to configure. When i going to user managment on UCCX. I see that man have status is agent. If i try configure resource from page user, UCCX write "Error occurred while reading the Resource".  What i can fix that?

P.s. When bad agent in UCCX, i not see any changes on RmCm-resources.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Enthusiast

Dmitry, refer to the similar

13 REPLIES 13
Highlighted
Cisco Employee

Is it happening for all the

Is it happening for all the new resources that you are trying to add or only few of them. Are you using any special characters in their userid. Please check the Special Characters section of below document:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cust_contact/contact_center/crs/express_10_5/config/guides/UCCX_BK_U9F91527_00_unified-ccx-administration-guide-release-10-5.pdf

In case, if there are no Special Characters in the userid then

1) Please access the CCX serviceability page and go to tools >> Datastore Control Center >> Replication Servers and let me know the status of the replication and if the CDS & HDS is enabled or not.

2) Restart below services first on primary an then on secondary UCCX CLI:

utils uccx database dbserver integrity

utils service restart Cisco Tomcat

Regards

Deepak

- Rate Helpful Posts -

Highlighted
Beginner

Thank you for answer. All

Thank you for answer. All users id have pattern like "xxxx-xxx-xxx". Some users completly added to UCCX and work fine, but several i cant add to UCCX.

I have only one server UCCX, not in cluster mode. 

I will try restart services today in evening and write result.

Highlighted
Cisco Employee

Thanks for the information

Thanks for the information Dmitry. Yes, proceed with the restart of services and then update accordingly.

Regards

Deepak

Highlighted
Beginner

I do commands, this not help

I do commands, this not help

admin:utils uccx database dbserver integrity
This operation may take a few minutes to complete. Please wait...

Output is in file: uccx/cli/DbServerIntegrity_1453719266257.txt

Command successful.
Starting DB config integrity check
This operation may take a few minutes to complete. Please wait...

Output is in file: uccx/cli/DbConfigIntegrity_1453719290451.txt
Use "file view activelog uccx/cli/DbConfigIntegrity_1453719290451.txt" command to see output
Command successful.
admin:file view activelog uccx/cli/DbConfigIntegrity_1453719290451.txt

Starting DB config integrity check
Local node name = xxxx
Remote node name = null
Got password
Driver loaded
Getting DB connection to jdbc:informix-sqli://xxxxxx:/1504/db_cra:INFORMIXSERVER=xxxxx_uccx
Got DB connecion to jdbc:informix-sqli://xxxxxxx/1504/db_cra:INFORMIXSERVER=xxxxx_uccx
Verfying crsapplication
Verfying crstrigger
Verfying crsgroup
Verfying crsuser
Verfying spokenname
Verfying campaign
Verfying systemconfig
Local errors =
Completed DB config integrity check no errors were found

Highlighted
Cisco Employee

What about utils service

What about utils service restart Cisco Tomcat. If this also does not resolve the issue, send the Cisco Unified CCX Administration logs after doing the below:

1) Remove the IPCC exctension from the End User page, save the changes

2) Add the IPCC Extension back again from the End User page, save the changes

Check if you are able to configure the user now on UCCX, if not then go to Cisco Desktop Administrator >> Services Configuration >> Synchronize Directory Service >> Synchronize

If still issue persists, collect the above mentioned logs. Provide the userid, extension and approximate time stamp when you will reproduce the issue.

Regards

Deepak

Highlighted
Beginner

restart Tomcat not help.

restart Tomcat not help. Synchronize not help too.

Can prompt to me, how get Cisco Unified CCX Administration logs.

So i try debug problem and found on trouble user that message

UNK:Exception occurred No entity found for query

when i try open configure resource.

Highlighted
Cisco Employee

You will need to do it using

You will need to do it using Real Time Monitoring Tool. If you do not have that installed already, download the plugin from CCX Administration >> Tools >> Plug-Ins and then install the same on your machine

Regards

Deepak

Highlighted
Beginner

RTMT has many logs. What log

RTMT has many logs. What log do you need ?

Highlighted
Cisco Employee

Cisco Unified CCX

Cisco Unified CCX Administration and Cisco Unified CCX Engine logs after reproducing the issue. Do provide approximate time stamp, agent userid and extension.

Regards

Deepak

Highlighted
Beginner

Looks like i found problem.

Looks like i found problem. Problem is full name on cyrilic must be not more than 27 letters. 

This problem described this topic

 https://supportforums.cisco.com/ru/discussion/12564606

Thank you

special thanks to Valery Kuznetsov

Highlighted
Cisco Employee

Glad the issue had been

Glad the issue had been resolved. If I remember correctly, there was a defect filed for this issue as well sometime back. Will try to find that out and update the post so that it can help others facing the same issue.

Regards

Deepak

Highlighted
Enthusiast

Dmitry, refer to the similar

Highlighted
Beginner

I am aware that this is late

I am aware that this is late and this issue is already resolved however I would like to share one more reason this issue might occur or one more troubleshoot we can perform if it is not related to any bug.

I faced the same issue ""Error occurred while reading the Resource".

I faced this issue for every new agent added. Also I was not able to see these agents in resources tab.

for testing purpose I tried to check if i can make changes via configure resource for existing agents.

when i tried to change skill group and save it I received below error

Backup operation, which was started at Tue Jan 1719:58:11 IST 2017: Please try again after 'backup' is completed.

I immediately checked last backup status which was failed.

I re-initiated the backup and once this backup was completed I was able to see agents in resources and I was able to configure resource.

Hope it might help someone !

CreatePlease to create content