cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1220
Views
0
Helpful
3
Replies

UCCX - Recording g729 prompt within Script - Garbled playback

Hello All,

I have a 8.5(1) UCCX deployment thats being set up to only use the G729 voice codec (servers are hosted in a 'cloud' providing an IVR service to many remote sites - no agents).

Been playing around trying to get a 'prompt recording' script working. Managed to convert some prompts to G729 in the first instance to get the script up and going (and these prior converted prompts play fine over G729), but all the new prompts i try and record play back garbled (the person taking can just about be heard on playback, but there's lots of additional noise).

Any idea's ?

Cheers

Tris

3 REPLIES 3
Highlighted
VIP Advisor

UCCX - Recording g729 prompt within Script - Garbled playback

What does the call path look like?

It should look like this, since the IP Phone can do g729 (no MTP and no Transcoder needed):

  • IP Phone > UCCX

Can you call the UCCX from your IP Phone where you are doing the recordings, then double tap the ? button to see what IP Address your phone is sending to?  Also, can you do the same but from a call where you are hearing the poor audio quality.

Can you upload a recording that you feel is of poor quality to the forum, so I can take a look and see if it's the file itself which is bad, or if somehow it's the playback or network?

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.


Anthony Holloway
Highlighted

Re: UCCX - Recording g729 prompt within Script - Garbled playbac

Hello Anthony - firstly thanks for your reply.

Yes, there's no MTP's or Transcoders involved (there's none configured currently actually as the need has yet to arrise).

So, to confirm, i only hear poor voice quailty on the prompt that i have recorded when i play it back from the server - all the other prompts which have been recorded in G729 via other means and uploaded directly onto the server play fine. UCCX Server is set within enterprise para's to use G729 (in this instance the server will only ever see G729 calls). Solution is HA with calls initially hitting the Sub.

I will try and attach a short WAV file of the issue (its just someone saying '1,2,3'). It 'sounds' like when you try and listen to a G711 encoded audio file over G729 encoded audio link, but the file itself is not G711.

Cheers

Tris

Highlighted
VIP Advisor

Re: UCCX - Recording g729 prompt within Script - Garbled playbac

Since you mentioned HA...

Have you restarted the UCCX Engine on both nodes after you made the switch over to g729?  It's possible that one of the servers, the one that is currently Master, has not booted itself up in g729 mode.

Also, unless you are staying on top of it, you cannot elect a node to initially takes calls.  It doesn't work like CUC.  Which ever UCCX Engine comes up first becomes Master, and at any given point in time can fall to Slave.  Albeit for a problematic reason, but fall to Slave none the less.

I have yet to check out the audio file, but I'll do that here in a minute.

I just decoded and played back the wav file, and yeah, that file is the culprit.  The just rules out a good file, and a corrupt playback.  I would say go back and restart the engine on both nodes, just to be sure they picked up the codec selection from the system parameters.  Heck, if you have time, flip it back to g711 and try the recording solution then, to see if it works as g711.  Then flip it back to g729, all while restarting the engine on both nodes between changes.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.


Anthony Holloway
CreatePlease to create content