cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
945
Views
5
Helpful
7
Replies
Highlighted
Beginner

UCCX Select Resource - Selected issue

Hello,

After a call gets into "Select resource" and then in "Selected" (and I have a delay of one second and two prompts under "selected"), I observed that the agent selected's IP phone rings just when the prompts are finished, but the supervisor observes that this agent is in "reserved" state and the timer is running (even when he haven't received the call).

In my particular scenario (attached screenshot) the prompts take 7 seconds, and then the call is routed to the agent. Is there any way to NOT to change the agent state until the call is ringing in his IP Phone? Or do you recommend me to up prompt parameters just above of "Select resource"?

Kind regards.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Rising star

That is working as design. When you set the connect parameter of a Select Resource step to "no", then this step just reserved the agent, then you need to use the Connect step to transfer the call to the reserverd agent, that is why the supervisor see the agent in a reserved state. I don't know what those prompts say but I you want the agent to be in a reserved state just when it's phone is ringing then you need to move those prompts above the select resource step.

HTH

Gabriel

View solution in original post

7 REPLIES 7
Highlighted
Beginner

yes, move the prompts below the select resource and test if that works!

Regards

Devan. 

Highlighted
Participant

Check under the prompt properties, you have 'Interruptible' checked no.

Change that option to yes and your issue will be fixed.

Highlighted

Hello,

I did what you suggested, but I didn't fix the issue. I still observe that "reserved" time continues and the call doesn't arrive to the IP phone until the prompts finish.

I up the promps above of "select resource" and it worked. I was thinking in another solution, but I didn't find anything else.

Highlighted

Put a 1 second delay step before the prompts start. 

You shouldn't have to put the prompts before the select resource.

See attached of one of my production scripts. 

Highlighted

Also make sure the application is being updated after you upload the new script...

Highlighted
Rising star

That is working as design. When you set the connect parameter of a Select Resource step to "no", then this step just reserved the agent, then you need to use the Connect step to transfer the call to the reserverd agent, that is why the supervisor see the agent in a reserved state. I don't know what those prompts say but I you want the agent to be in a reserved state just when it's phone is ringing then you need to move those prompts above the select resource step.

HTH

Gabriel

View solution in original post

Highlighted

Or just set the connect parameter on select resource to yes.

Content for Community-Ad