cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1104
Views
2
Helpful
13
Replies

UCCX Uprade Path

mightyking
Level 6
Level 6

Hello Experts,

What is the path for upgrading UCCX 12.5.1.11001-348 to uccx_1251_su3_es_04_special?

Thanks,

MK

 

1 Accepted Solution

Accepted Solutions

First you'll need to upgrade CCX to SU2 and then to SU3, once you're there you'll be on version 12.5.1.11003-511, then you'll need to upgrade to SU03 ES04-18 as stated in the readme for SU03 ES04-Special that you yourself referenced, see the screenshot below, first then at that point you should be able to install the update file you asked about.

From your own reply.
image.png

To me this is quite clearly outlined, but maybe it isn't as you're asking about it.



Response Signature


View solution in original post

13 Replies 13

You’ll find that if you read the recommended reading material for an upgrade, ie release note, upgrade guide and readme for each update file. Likely I’m forgetting something, but in general this is what you’ll normally would review for any upgrade.



Response Signature


Hi,

Being a minor release Upgrade you can jump directly to it from 12.5.1

HTH

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"

This is what it says in the upgrade path 

 

Valid Upgrade Paths

 

Cisco Unified CCX 12.5(1) SU3 ES04 is delivered as a Cisco Option Package (COP) file. This COP file must be installed ONLY on systems that have following versions:

  • 12.5(1) SU3 FCS Build - 12.5.1.11003-511(ES04-18)

And this is what I receive when I try to initiate the upgrade:

02/26/2024 09:11:30 upgrade_get_file.sh|File authentication complete|<LVL::Debug>
02/26/2024 09:11:30 upgrade_get_file.sh|Download of iso file RTMTFinish|<LVL::Notice>
02/26/2024 09:11:30 upgrade_get_file.sh|Process preflight|<LVL::Info>
02/26/2024 09:11:30 upgrade_get_file.sh|Skipping preflight since file type is COP|<LVL::Debug>
02/26/2024 09:11:31 upgrade_get_file.sh|success|<LVL::Info>
02/26/2024 09:11:31 upgrade_get_file.sh|upgrade_get_file.sh complete (rc=0)|<LVL::Info>
02/26/2024 09:11:31 upgrade_get_file.sh|is_upgrade_lock_available: Upgrade lock is not available.|<LVL::Debug>
02/26/2024 09:11:31 upgrade_get_file.sh|is_upgrade_in_progress: Already locked by this process (pid: 22612).|<LVL::Debug>
02/26/2024 09:11:31 upgrade_get_file.sh|release_upgrade_lock: Releasing lock (pid: 22612)|<LVL::Debug>
02/26/2024 09:11:53 sd_cancelInstall.sh|Pre-upgrade cancel/clean-up initiated
02/26/2024 09:11:53 sd_cancelInstall.sh|Canceling active side processes
02/26/2024 09:11:54 sd_cancelInstall.sh|Canceling active side processes done
02/26/2024 09:11:54 sd_cancelInstall.sh|Canceling inactive side processes
02/26/2024 09:11:54 sd_cancelInstall.sh|Skipping IDS shared memory clean up since this is a COP
02/26/2024 09:11:54 sd_cancelInstall.sh|Canceling inactive side processes done
[24/02/26_09:12:01] locale_install.sh: Called with args: --taos-locale-op install --taos-rpm-file /common/download//ciscouccx.1251.su3.ES04.18.cop --taos-basepath /usr/local/bin --taos-logfile /var/log/install/install_log_2024-02-26.09.10.33.log --taos-resultfile /var/log/install/upgrade-results.xml --taos-optionsdir /var/log/active/installed_options/
[24/02/26_09:12:03] locale_install.sh: Successful untarring of ciscouccx.1251.su3.ES04.18.cop
[24/02/26_09:12:03] locale_install.sh: action.txt file exists
[24/02/26_09:12:03] locale_install.sh: reboot = yes, Reboot required
Validate the ES compatibility
Install Failed...The ES is not compatible with the Service Update Installed in the system
Install Failed...the uccx build number 11001-348 is not same as es base build 11003-511
[24/02/26_09:12:03] locale_install.sh: upgrade status is updated in /common/log/install/upgrade_status.xml file
[24/02/26_09:12:03] locale_install.sh: ERROR: Copstart script of ciscouccx.1251.su3.ES04.18.cop failed

Installation of ciscouccx.1251.su3.ES04.18.cop.sgn failed

Copstart script of ciscouccx.1251.su3.ES04.18.cop failed

A system reboot is required when the upgrade process completes or is canceled. This will ensure services affected by the upgrade process are functioning properly.
Note: system reboot may not be required for a COP file. Please follow the instructions seen at the end of the COP installation.

admin:show ver
admin:show version acti
admin:show version active
Active Master Version: 12.5.1.11001-348
Active Version Installed Software Options:
No Installed Software Options Found.

You’re not on the required version for installing the file as listed in the upgrade guide. You need to be on 12.5.1.11003-511(ES04-18) ie SU3 ES04. If I’m not mistaken you’re on SU01 and possibly some ES release, need to check the details on the releases to know for sure. All this information is readily available to anyone who puts in the effort to read the information Cisco publish. To be perfectly clear the community is not here to do that job for you.



Response Signature


Active Master Version: 12.5.1.11001-348 means that you're on the base (FCS) release of CCX 12.5. With this you'll need to do a stepped upgrade of all the SU0x releases, ie SU01, SU02 and SU03 before you can install any ES release for SU03.

image.png

Once you're on the SU0x release you can go directly to the next SU0x release without first installing any of the ES0x releases within that specific SU release.

That said what version of CM do you use? The special release of SU03 ES04 is only to be used with some older versions, 11.5 and 12 of CM as per the readme. If your using CM 12.5, 14 or 15 you should not install that update.



Response Signature


Thank you Rogers,

This is what we have in our cluster:

Active Master Version: 12.5.1.11001-348
Active Version Installed Software Options:
uccx-language-pack_26-12.5.1.10000-175.cop
ciscouccx.1251.SU1.ES03.63.cop

We are using CUCM version  11.5.1.22900-28

As you can see we have SU1.ES03.63 installed but I can't find this ES on Cisco software download page. 

I am still unable to find the right path to get to su3_es_04 from the version we are in. Could you please help to identify the correct path?

 

First you'll need to upgrade CCX to SU2 and then to SU3, once you're there you'll be on version 12.5.1.11003-511, then you'll need to upgrade to SU03 ES04-18 as stated in the readme for SU03 ES04-Special that you yourself referenced, see the screenshot below, first then at that point you should be able to install the update file you asked about.

From your own reply.
image.png

To me this is quite clearly outlined, but maybe it isn't as you're asking about it.



Response Signature


If you feel that you have been provided with an answer on your question please use the option to mark this as solved and also please give helpful votes on any responses that you feel deserve it.



Response Signature


Here're the exact steps:
1) Make a complete backup of the cluster
2) Install the ucos.keymanagement.v02.cop.sgn
3) Install the file ciscouccx.1251.SU1.1251SU3PREUPGRADE.59.cop.sgn
4) Install UCSInstall_UCCX_12_5_1_UCOS_12.5.1.11003-511.sgn.iso
5) Switch Version to SU3
6) Restart the server
7) Install the file ciscouccx.1251.su3.ES04.18.cop.sgn
Install ciscouccx.1251.su3.ES04_and_later-cucm_11_5_12_0_compatible.118.cop.sgn 
9) Restart the server
13) In case of HA, repeat the same steps for the subscriber server

MK

>First upgrade from 12.5.1 Su1 to 12.5.1 SU3.
>Install Pre-upgrade cop files on 12.5.1 SU1 ciscouccx.1251.SU1.1251SU3PREUPGRADE.59.cop.sgn nad ucos.keymanagement.v02.cop.sgn.
>After upgrade to 12.5.1 SU3 and install the ES04 cop file "ciscouccx.1251.su3.ES04.18.cop.sgn".
>As your current CUCM version is 11.5.1, UCCX 12.5(1) SU3 ES04 and later versions only support integration with Unified CM version 12.5 and later, to support Unified CM 11.5 and 12.0 versions ciscouccx.1251.su3.ES04_and_later-cucm_11_5_12_0_compatible.118.cop.sgn must be applied on top of SU3 ES04.

dandrools
Level 1
Level 1

The post marked as the solution is incorrect.  It is NOT necessary to install each SU in order.  You can upgrade from SU1 to SU3 without installing SU2.  Simply ensure that the appropriate pre-upgrade COP files are in place prior to attempting the upgrade to SU3.  The installation guide will tell you which pre-upgrade COPs are required based on the version from which you are upgrading.  The post from OP, mightyking, on 2-29-2024 at 4:35 AM is the correct solution.

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cust_contact/contact_center/crs/express_12_5_1_su3/install/guide/uccx_b_1251su3_install-and-upgrade-guide/uccx_m_1251su2_unified-ccx-upgrade.html

Thank you for pointing this out. Although not the only and for sure not the fastest or best method of upgrade it’s not really an incorrect answer as such.



Response Signature


sahils2
Cisco Employee
Cisco Employee

"uccx_1251_su3_es_04_special" this is a cop file that needs to be installed only after upgrading the version from 12.5.1 Su1 to 12.5.1 SU3.

  1. It's a direct upgrade from 12.5.1 SU1 to UCCX 12.5.1 SU3.
  2. Install the Pre-upgrade cop files to set the system parameters before upgrade need below cops to be installed:
    ciscouccx.1251.SU1.1251SU3PREUPGRADE.59.cop.sgn
    ucos.keymanagement.v02.cop.sgn
  3. Below link has both pre-upgrade cop files: Make sure to install cop files only from CLI.
    https://software.cisco.com/download/home/286325233/type/286314116/release/12.5(1)SU3
  4. Upgrade the UCCX 12.5.1 SU3 here is the link for ISO
    https://software.cisco.com/download/home/286325233/type/286314116/release/12.5(1)SU3
  5. After the upgrade when the CCX is on 12..5.1 SU4 version then you can install the ES04 cop file:
    ciscouccx.1251.su3.ES04.18.cop.sgn
    https://software.cisco.com/download/home/286325233/type/286314176/release/12.5(1)_SU03_ES04
  6. As your current CUCM version is 11.5.1, UCCX 12.5(1) SU3 ES04 and later versions only support integration with Unified CM version 12.5 and later, to support Unified CM 11.5 and 12.0 versions ciscouccx.1251.su3.ES04_and_later-cucm_11_5_12_0_compatible.118.cop.sgn must be applied on top of SU3 ES04.
    Here is the link for the cop file:
    ciscouccx.1251.su3.ES04_and_later-cucm_11_5_12_0_compatible.118.cop.sgn
    https://software.cisco.com/download/home/286325233/type/286314176/release/12.5(1)_SU03_ES04