cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
401
Views
0
Helpful
4
Replies

UCCX Workflow Admin - how do I add variables for external use?

fbrown
Beginner
Beginner

I'm configuring a UCCX 10.5 workflow in the Workflow Admin tool.

I want to create an HTTP trigger that opens a URL based on data collected in the IVR (data that is already stored in Peripheral/ECC variables through the script). When I open the HTTP Action Setup window, and try to configure the Request Data parameters (opens the HTTP Request Data Dialog window), the Value field is pre-populated with system-defined variables but none of the ones I've defined. How do I associate the existing variables that I've defined in the Desktop Admin pages with this?

Everything else is working with the user-defined variables - published to CAD using layouts, shown in the historical reports etc. 

Thanks!

Felix

4 Replies 4

Deepak Rawat
Cisco Employee
Cisco Employee

Felix,

Post the screenshot from web based CDA showing the ECC variable that you have created along with the screenshot of drop down menu for the HTTP action. Is it happening for all the ECC variables that you have created in CDA or specific ones.

Try creating a new test ECC variable and see if that appears in the drop down or not. Send the screenshot of Cisco Unified CCX Serviceability >> Tools >> Control Center  - Network SErvices showing the status of your UCCX services.

Regards

Deepak

Hi Deepak.

Now the system is behaving as I expected, with the variables turning up in the Workflow Administrator. This is a single-node lab environment, so I expected things to turn up immediately (i.e. no delay for replication between nodes etc.).  I had tried synchronizing the directory services under the main menu for the Call Center, but that had not done anything.

What I found was that if I closed the Workflow Admin application and re-opened it, that all the data was refreshed.

Thanks for your attention to this, and your quick response!

Felix

Felix, I am glad that it worked for you and it was just a simple refresh case of CDA. Please remember to rate all helpful posts so that they can stay on top and help others with similar kind of issues.

Regards

Deepak

Hi, I have  a similar question, I am trying to send a variable ( calling number ), through to a .php script, I have the variable, it collects the calling number, I have created the HTTP action with the ip address of the php script location, I believe I have programmed the Workflow correctly, but the calling number will not populate the php script variable

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers