cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1135
Views
0
Helpful
13
Replies
ram
Beginner
Beginner

UCCX8.5 nuance SWIrecRecognizerCompute returned with incomplete status 2

Hi,

I am trying to debug a simple script. Here are the steps -

1. SimpleRecognition step  -- Executes succesfully with grxml

2. Voicebrowser step - result no-input with grxml.

When I see the Nuance server logs this is what I found

Apr 13 13:17:26.72|5504|0|6001|OSR Plugin|SWIrecRecognizerCompute returned with incomplete status \= 2|UCPU=15|SCPU=0

Apr 13 13:17:26.83|5504|0|6001|OSR Plugin|SWIrecRecognizerCompute returned with incomplete status \= 2|UCPU=15|SCPU=0

Apr 13 13:17:26.94|5504|0|6001|OSR Plugin|SWIrecRecognizerCompute returned with incomplete status \= 2|UCPU=15|SCPU=0

Apr 13 13:17:27.05|5504|0|6001|OSR Plugin|SWIrecRecognizerCompute returned with incomplete status \= 2|UCPU=15|SCPU=0

I am attaching the OSServer.cfg and the nuance server logs.

Do I need to change any configuration ?

Thanks for the help.

Ram

13 REPLIES 13
ram
Beginner
Beginner

Missed to mention a point.

When I skip step 1 then the voice browser step executes successfully without any problem.

Seems like there is a problem after the first invoke of MRCP.

Hi Ram,

Did you create MRCP ASR Dialogue Groups? (Under UCCX Admin->Subsystems->MRCP ASR)

And also did you associate  this MRCP Dialouge group under Advance trigger Information for the Route point created for this UCCX application.

Click on the UCCX Admin->Application->access the aove application-.Click on the Trigger->Advance Trigger Information->Override Media Termination, say yes here->And select the MRCP dailouge group crated above and associate, deassociate the default CMT here.

Save the above settings, refresh the applications \ scripts page and test again.

Hope it helps.

Anand

Please rate helpful posts !!

Hi Anand. I'm working with Ram on this project.

Yes, we have set up the MRCP ASR Dialog Group and set it on the trigger previously. So, unfortuntely no luck there.

I'm open though to other ideas! I see a request below to post the relevant part of the script. I'll do that momentarily.

Hi,

what step 1? (Of the Voice Browser step).

Can you just post the whole script (or at least a screenshot of relevant parts).

Thanks

G.

Unfortunately since it's a customer script I can't post the whole thing. But, attached is a screenshot of the bit that has the Simple Recognition then Voice Browser steps. Let me know what else might be helpful and I'll see what I can do!

Ok, and what happens if the script executes the voice browser step only, using the same VXML document?

Are you sure you are using a logically valid grammar there? Can you perhaps post it?

G.

Sent from Cisco Technical Support iPad App

Yes, if I run the Voice Browser step first (or alone), it works just fine. So, grammar is valid.

Ok to make the steps simple. I have copied the previous voicebrowser element which executed successfully and pasted.

Here is the scenario :

step 1. voice browser - executes successfully

step 2. copied the above voice browser - no-input occurs.

The MIVR logs shows

8787355: Apr 16 07:31:28.245 MDT %MIVR-SS_MRCP_ASR-7-EXCEPTION:com.cisco.wf.media.driver.DriverException: ERROR Stream::injectDtmf - failed with appId=1, confId=57259, partyId=4

the above error is shown for each input at step 2. Please find the attached mivr logs.

Thanks

Ram

Hi,

I've got a strange feeling that even though the IVR script continues, the Nuance server somehow expects more input within/after the first step.

Or it might be a nasty bug as well (either UCCX or Nuance).

Well, I am sorry but I cannot help you here - the only workaround I would definitely consider is to wrap all necessary actions into a single VoiceXML browser step (yes, I can hear you laughing).

G .

I really appreciate you and anand for looking into my issue and helping me.

Unfortunately I am confused here to contact Cisco or Nuance.

Let me see what happens to this.

Thanks

Ram

Hi, I am really sorry about that.

What I know there was a bug in UCCX 8.02 and they made me to install a patch. But you seem to have quite a different version.

I would talk to Cisco first.

G.

Hi Ram,

Could you please let me know the exact versions of UCCX and CUCM here.

Thanks,

Anand

Hi Anand,

Currently I dont have the exact version of CUCM. But the

UCCX version is

active UCCX version: 8.5.1.11002-22

inactive UCCX version: 8.5.1.10000-37

Thank you

Ram

Create
Recognize Your Peers
Content for Community-Ad