Showing results for 
Search instead for 
Did you mean: 

Connection lines are missing in Topology Map

Level 1
Level 1

I installed APIC-EM When I perform network discovery using CDP and seed device all devices are properly discovered but some links are missing. I've tried it several times but there were always some link missing. In one case there was dispayed link which doesn't exist.

I attach screenshot of APIC-EM topology. Missing links are red hand-drawn.

Do you have any idea what I'm doing wrong or how to fix it?


18 Replies 18

Cisco Employee
Cisco Employee


a couple of quick questions. 

  1. For the links in question (and mainly the one at the top of your diagram), can you do a "show cdp ne" on both devices to make sure they can see each other via CDP.
  2. The devices at the bottom of the screen look like they are in pairs.  Are those vss pairs?


Hi Adam,

I checked cdp entries on affected switches and it seems to me correct.

Switches at the bottom are N5K's with synchronized configuration.

In the meantime I tried the same with and the result was similar

(other links were not displayed). Then I deleted all devices and performed

rescan but the result was even worse. Lot of lines missing ...

I allocated for this test instalation 150 GB only and the disk performance

is slower that minimum recommended but I don't think this could cause such

issue ...

$ dd if=/dev/zero of=/tmp/foo bs=1M count=512 conv=fdatasync

512+0 records in

512+0 records out

536870912 bytes (537 MB) copied, 2.95471 s, 182 MB/s


Given the small number of devices and the Disk IO, i do not think that has anything to do with this issue.

The 5k issue might be related to VPC.

The 3k at the top should be able to see each other... that should just work.  Is there anything different in how the 3k are connected?


Hi Adam,

the 3k are connected by one 1Gb link.

CDP from one side:

Gig 0/3 129 S I WS-C3560- Gig 0/1

CDP from the opposite one:

Gig 0/1 133 R S I WS-C3560- Gig 0/3

Today I've performed new fresh installation of APIC-EM 1.4. Even more links

are missing after CDP based discovery ...


2017-03-05 0:24 GMT+01:00 aradford <>:

Cisco Communities <>

Connection lines are missing in Topology Map

reply from aradford <> in *DevNet

APIC EM* - View the full discussion


are the red lines showing the missing links?  It looks like there is a connection underneath the red line?

Also, it can take a few minutes for discovery to fully add the device to inventory and hence update topology?  I assume the device is completely added in inventory?

The red lines are the missing links. I used screenshot from previous

discovery, that's why connections are visible underneath some lines. Sorry

for confusion.

Today I performed rediscovery. Nothing has changed.

All devices are in inventory with status "managed". Only one device has

status "UNKNOWN", but this device has correctly displayed all links to it's


2017-03-07 9:16 GMT+01:00 aradford <>:

Cisco Communities <>

Connection lines are missing in Topology Map

reply from aradford <> in *DevNet

APIC EM* - View the full discussion


Level 1
Level 1

Any update on that one? I have the same issue with the same version of APIC-EM. Some sites are ok while other sites are missing the links. I even tried to delete the devices and add them back manually at the device inventory tab.

Level 5
Level 5

Same issue. mainly the links between device. Links from switch/AP to hosts are all fine.

CDP and other information are correct.

Level 1
Level 1

I also have this issue, any update for this topic??

Do you have nexus5k and FEX in your topology?

No, the link problem happened between switch and ap,

the switch model "WS-C3650-48PS-S", soft version: cat3k_caa-universalk9.SPA.03.07.03.E.152-3.E3.bin

the ap model "2702I or 2702E", soft version: 15.3(3)JN11,  WLC is CT-5508/ version 7.6

So, anybody can have an ideal?

Many Thanks.

Yes I know of one issue.

Do you have a domain-name for the AP?

No, many aps have no set domain-name, so , you mean i need to set domain-name for all of them?

Above pictures just have two correct ap, others have some link problem, and the two correct ap have no set domain-name!!!

Issue Ap:

there is a known issue when domain-name is set.

Do you have domain-name set on the ones that are causing the problem?  You can tell if you do a "show cdp nei" on the switch they are connected to..  CDP will show if there is a domainname or not.