cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

ACE: client lost session when application in real server down

23
Views
0
Helpful
0
Comments

Hello,

I have a problem with a loadbalace. My ACE balance OK, but when i am connected to application in a real server that i am connected, the connection is not response, so i have to init the new session. the idea is that session be persistent, but the ACE sent the session id to the other real server. how i can solved that?

Regards

The running-config

access-list anyone line 8 extended permit ip any any


probe tcp WEBLOGIC-TCP
  port 7293
  interval 4
  faildetect 2
  passdetect interval 10
  passdetect count 2
  receive 2
  open 2
probe http http-get-index
  interval 4
  faildetect 2
  passdetect interval 10
  receive 2
  expect status 200 200
  open 2

rserver host intra1
  ip address 10.200.254.3
  inservice
rserver host intra2
  ip address 10.200.254.4
  inservice

serverfarm host intrafarm
  rserver intra1
    probe WEBLOGIC-TCP
    inservice
  rserver intra2
    probe WEBLOGIC-TCP
    inservice

sticky ip-netmask 255.255.255.255 address source src-ip-sticky
  timeout 6
  timeout activeconns
  serverfarm intrafarm

class-map type management match-any Mgt
  2 match protocol http any
  3 match protocol telnet any
  4 match protocol ssh any
  5 match protocol icmp any
class-map match-any VIP-srvintranet
  2 match virtual-address 172.10.254.3 any

policy-map type management first-match Management
  class Mgt
    permit

policy-map type loadbalance first-match lb-vip
  class class-default
    sticky-serverfarm src-ip-sticky

policy-map multi-match client-vips
  class VIP-srvintranet
    loadbalance vip inservice
    loadbalance policy lb-vip
    loadbalance vip icmp-reply

interface vlan 501
  description SIDE-SERVERS
  ip address 10.200.254.1 255.255.255.248
  access-group input anyone
  access-group output anyone
  service-policy input Management
  no shutdown
interface vlan 502
  description SIDE-CLIENTS
  ip address 172.10.254.2 255.255.255.248
  access-group input anyone
  access-group output anyone
  service-policy input Management
  service-policy input client-vips
  no shutdown

ip route 0.0.0.0 0.0.0.0 172.10.254.1

This widget could not be displayed.