Showing results for 
Search instead for 
Did you mean: 

HOW TO - iSCSI boot with Intel i350 adapters on UCS servers





UCS C-series 220 M3 and 240 M3 rack servers have  embedded Intel i350 LOMs and support PCI-E based Intel i350 NICs that  are capable of iSCSI boot functionality. However, the problem is option  ROM on Intel NICs are shipped with PXE as the default boot protocol and  hence user does not have an hot key option to enter iSCSI boot  configuration.Also, Intel does not allow to switch boot protocol in the  option rom ( CSCtx85320 ) .


We need to use Intel tool BOOTUTIL to make  changes to option ROM which allows to add iSCSI boot configuration  parameters in the adapter.



The CIMC CLI is a command-line management interface for Cisco UCS C-Series servers. You can launch the CIMC CLI and manage the server by the serial port or over the network by SSH or Telnet. By default, Telnet access is disabled.


Changing to iSCSI

Instructions on how to configure the adapter and change boot protocol from PXE to iSCSI


1) Download BOOTUTIL app from Cisco site.


C-Series server > Utilities >  EFI >  Image (Example :- ucs-cxxx-utils-efi.1.4.6.iso )


2) Mount ISO image and Copy BOOTUTIL64E.EFI app to USB drive. App is available under Utils\EFI\Network\Intel\I350\BootUtil directory.

3) Attach the USB drive to server


4) Boot the server, press F6 and select UEFI shell from Boot manager selection menu.


5) USB drive should be mapped as " fs0 " . Type " fs0 " at the EFI shell to change the directory to USB root folder.

6) Navigate directories in USB with cd,dir commands and change to folder that has BOOTUTIL64E.EFI tool.


7) Following command lists Intel NICs








8) Execute following command to change the boot protocol


BOOTUTIL64E.EFI -NIC=<port-ID> -bootenable=<iscsiprimary|iscsisecondary>




NOTE   It changes from PXE Enabled to iSCSI Primary / iSCSI Secondary

9) Type " exit " to logout of EFI shell.


10) As server boots, we now the get hot keys ( CTRL+D ) to configure iSCSI boot parameters











Submitted defect CSCub87094 to update official docs.





This worked perfectly. Thanks a lot for this useful post.

But after installing ESXi on our C220M3 we run into another problem.

The iSCSI Boot installation worked fine, but after rebooting the UCS C220M3 we realized, that

the server looses the ESXi configuration (Management IP, VLAN, Hostname, ...).

We tried different installation, all through iSCSI boot. As the server don't have local

disk we can't install EXSi locally.

We tried different Versions, all having the same result

- ESXi 5.1

- Cisco Custom Image for ESXi 5.0 U1

- Customized ISO Image for ESXi 4.1 Update 2

With all the same problem -> lost of ESXi configuration.

Also during the installation of the OS we always had the following error message ""expecting 2

boot bank, found 0". But as mentioned within the release notes after reboot the host

properly started from SAN.

We also found the following KB article from VMware. UCS Blade loses configuration after

reboot in VMware ESXi 5.0.x

Cause: The FCoE device discovery may take longer than expected, and when the

restore-bootbank jumpstart plug-in starts, the bootbank partition on the FCoE LUN is still

not available. We're not sure if this is what we are experiencing and if this is also the case for 4.1.

We updated the C220 M3 (LOM, BIOS, ...) to the latest relase with no luck.

Anyone out there has iSCSI Boot working on C220M3? If yes, with what versions?

regards, dani

Cisco Employee

Hello Dani,

I noticed that you have opened TAC SR for this issue. I have not read the details but does ESXi boot after the error message ?

Engineer will provide more details on her investigation.


Community Member


After an Upgrade of the Firmware from 1.4(6d) to 1.4(7a) - booting from iscsi is no longer working.

I receive the following message during the boot of the C220 M3:


Attempting to connect to target disk using MAC address(xy)

ERROR: Could not establish TCP/IP connection with iSCSI target.

No disk found!


I still receive the message after a downgrade to 1.4(6d) with restoring the BIOS-settings. The network is fine and there was no change in the iscsi-target-settings (the settings displayed during the boot are correct). The problem exists on two servers. Why could this problem exist? A bug in the new firmware?

Best Regards,



What did you have to do to ESXi to even install on Boot from iSCSI on the i350's? I have the network cards seeing my 8gb LUN. I was able to install windows on it, but ESXi won't even see it during the install.

Community Member

     This is probably a little late, but I hope that I may help other people who read this post. For your set up to work correctly use network adapter other than the "first" one since it is the one that ESXi is attempting to use for management interface and brakes your iSCSI, as a result host is unable to save changes you make to your management network, and settings aren't retained.

     As for the other part of your question, configure native VLAN to that of your iSCSI network from which you are booting and don't set “no-negotiate” on that trunk since there is no VLAN configuration on Intel I350 cards. This way trunk is treated as regular connection during boot and negotiates trunk once ESXi is up.

Good luck.

Community Member

I am facing the same issue, Dennis how were you able to install windows ?

I can't get my OS to see the storage for installation.




Content for Community-Ad