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Akiyoshi Kawaguchi
Cisco Employee
Cisco Employee

Symptoms

RBAC users like administrator@vsphere.local may fail HX Connect login. At that time, "Incorrect user name or password(100005)" is shown as a failure reason.

 

Diagnosis

  • RBAC users can login to vCenter server. So, RBAC username and password is not incorrect.
  • pre-defined users (local/admin, local/root) can login to HX Connect. So, HX Connect seems to work.
  • "date" command shows quite different time between Storage Controller VMs and vCenter server. Time is not syncted.

 

Solution

By syncing time between Storage Controller VMs and vCenter server, RBAC users can login to HX Connect.

 

This notice is mentioned in the following HX Connect document:

https://www.cisco.com/c/en/us/td/docs/hyperconverged_systems/HyperFlex_HX_DataPlatformSoftware/AdminGuide/2_5/b_HyperFlexSystems_AdministrationGuide_2_5/b_HyperFlexSystems_AdministrationGuide_2_5_chapter_010001.html

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Ensure that the time on the vCenter and the controller VMs are in sync or near sync. If there is too large of a time skew between the vCenter time and the cluster time, AAA authentication will fail.

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Comments
Rick1776
Level 5
Level 5

Thanks for sharing. I just ran into this last week.

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