cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Unable to properly install ACI/APIC vCenter plugin

229
Views
0
Helpful
0
Comments

APIC 4.1(2u)

vCenter appliance 6.7.0.42000

 

I followed the instructions at "https://[APIC FQDN]/vcplugin/", using PowerCLI to install the plugin. It seemed to work - "[x] Installed vCenter plugin version 4.1.2000.21". However, on logging into vCenter (whether using the HTML5 or the Flash client), the plugin doesn't appear.

 

In the vCenter event viewer it says, "The deployment of plug-in Cisco ACI Fabric 4.1.2000.21 has failed: Download of package: com.cisco.aciPlugin:4.1.2000.21 failed. See the logs for more details."

 

In "vsphere_client_virgo.log" it says, "Package com.cisco.aciPlugin was not installed. Error downloading https://[APIC FQDN]/vcplugin/vcenter-plugin-4.1.2000.21.zip. Make sure that the URL is reachable then logout/login to force another download."

 

If I do "curl -v https://[APIC FQDN]" from vCenter I get a certificate error, which is expected since APIC does not have a signed cert. If I do "curl -vk https://[APIC FQDN]" to allow an insecure connection it works fine.

 

Is the cert issue the problem here? Something else? I'm stumped!