cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1251
Views
0
Helpful
7
Replies
satish.txt1
Beginner

BFD issue with BGP support on Cisco 9396PX

I have following BGP configuration and trying to reduce my convergence time with help of BFD but having hard time.

router bgp 1111
  log-neighbor-changes
  address-family ipv4 unicast
    network 22.22.22.0/24
  neighbor 11.11.11.1
    bfd
    remote-as 2222
    update-source loopback160
    ebgp-multihop 2
    address-family ipv4 unicast
      send-community

This is what i did to enable BFD

feature bfd
bfd interval 500 min_rx 500 multiplier 5
bfd echo-interface loopback160
!
router bgp 1111
  neighbor 11.11.11.1
    bfd

Now when i run (no output), that means BGP isn't registered to BFD, if i enable OSFP then i can see some output in show bfd neighbors command. I tried debug and no output in debug logs. trying to understand why BGP not getting registered. (My peer ISP did enabled BDF their side) my nxos version is 7.0(3)I4(7)

# show bfd neighbors
#
1 ACCEPTED SOLUTION

Accepted Solutions

Hi Satish,

 


I can see on cisco website Cisco Nexus 9396PX is support for nxos-9.x release, Does cisco has any ETA when they are going to make it 9.x official recommended code version?


Unfortunately I cannot provide any peaks behind the curtain on this one.  I can tell you that both 7.0(3)I7(x) and 9.3(x) are often recommended to customers depending on their needs.

 

Question: If i upgrade my current nxos-7.x with nxos-9.x in that case can i downgrade easily if hit any bug or any unknown issue?


Yes, it is relatively straightforward downgrading from 9.x to 7.x.  ISSU and cold-boot methods are supported in upgrading a system while cold-boot is the only supported method to downgrade a switch.

Reference: https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/93x/upgrade/guide/b-cisco-nexus-9000-nx-os-software-upgrade-downgrade-guide-93x/b-cisco-nexus-9000-nx-os-software-upgrade-downgrade-guide-93x_chapter_0111.html#id_74096

 

Hth,

Alex

 

View solution in original post

7 REPLIES 7
Alex.M
Cisco Employee

Hi Satish,

 

Looking over the configuration output I noticed that your ebgp peer is utilizing multihop (Loopback > egress interface > neighbor).  BFD does not support multi-hop.  I suggest altering your BGP neighborship configuration so that physical interfaces are utilized for neighborship peering.

 

This guide below references the limitation mentioned above as well as provides configuration examples for BFD on your code version:
https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/7-x/interfaces/configuration/guide/b_Cisco_Nexus_9000_Series_NX-OS_Interfaces_Configuration_Guide_7x/b_Cisco_Nexus_9000_Series_NX-OS_Interfaces_Configuration_Guide_7x_chapter_0110...

 

Hth,

Alex

Just wanted to add a single note on top of what @Alex.M  already mentioned:

BFD multi-hop is supported, but not for the platform you have:

 

  • BFD multihop is supported on Cisco Nexus 9200 and 9300-EX platform switches and Cisco Nexus 9500 platform switches with N9K-X9700-EX line cards.

 

Reference: https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/92x/interfaces/configuration/guide/b-cisco-nexus-9000-nx-os-interfaces-configuration-guide-92x/b-cisco-nexus-9000-nx-os-interfaces-configuration-guide-92x_chapter_0110.html#id_734... 

 

Stay safe,

Sergiu

Thanks Alex,

 

I have couple of question on your reply, Lets say ebgp multihop isn't supported in this hardware or software but my question is when you enable bfd configuration it should show something in "show bfd neighbours" command output and tells BGP is registered but links will be down.. blah..blah.. something like that. in my case its not giving me any output (that means BGP not getting registered in BFD) 

 

Am i missing something to understand BFD here? 

This is what i did in my lab to understand behavior, yes multi-hop not working that i can see with following TEST which i did in lab.

 

Following configuration works with BFD but if i set update-source loopback0 then it failed and no output in "show bfd neighbours"  that means multi-hop is not supported but i hate when it won't say anything and stay silent. 

router bgp 65001
  log-neighbor-changes
  address-family ipv4 unicast
  neighbor 10.1.2.1
    bfd
    remote-as 65001
    update-source Ethernet1/2
    address-family ipv4 unicast

Cisco saying multi-hop supported in NX-OS 9.2.x version (do you think it's recommended for production not sure how many folks are running that version)

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/92x/interfaces/configuration/guide/b-cisco-nexus-9000-nx-os-interfaces-configuration-guide-92x/b-cisco-nexus-9000-nx-os-interfaces-configuration-guide-92x_chapter_0110.html#id_734... 

 

Hi Satish,

Yes, you and msdaniluk are correct multihop bfd was added in 9.2.x code.

Each network is different and may require fine-tuning in code versioning.  That being said, currently there are two major code releases for the Nexus 9000 platform: 7.0(3)I7(x) and 9.3(x).  These two "code trains" are known as long-lived releases, meaning that support will last much longer on these code trains than other code trains. 

9.2(x) for example is a short-lived release.  These are utilized when there are new features needed within a network but are currently not implemented in a long-lived release.

Both 7.0(3)I7(x) and 9.3(x) have their caveats but what I can tell you is at some point 7.0(3)I7(x) will become unsupported sooner than 9.3(x) code train.  This will be a long ways away though.  Since both decently far within their minor release, 7.0(3)I7(8) and 9.3(4), it would be hard to go wrong with either.  In your case, since you are requiring a feature found in 9.2(x) and above, I would suggest researching into 9.3(4) as a viable code version. 

Research here will be critical.  Here are documentation and tools that will help you:
https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/93x/interfaces/configuration/guide/b-cisco-nexus-9000-nx-os-interfaces-configuration-guide-93x/b-cisco-nexus-9000-nx-os-interfaces-configuration-guide-93x_chapter_01111.html

https://bst.cloudapps.cisco.com/bugsearch/

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/93x/release/notes/cisco-nexus-9000-nxos-release-notes-934.html

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/recommended_release/b_Minimum_and_Recommended_Cisco_NX-OS_Releases_for_Cisco_Nexus_9000_Series_Switches.html

 

Hth,

Alex

 

Thank you for reply,

 

I can see on cisco website Cisco Nexus 9396PX is support for nxos-9.x release, Does cisco has any ETA when they are going to make it 9.x official recommended code version?

 

Question: If i upgrade my current nxos-7.x with nxos-9.x in that case can i downgrade easily if hit any bug or any unknown issue?

Hi Satish,

 


I can see on cisco website Cisco Nexus 9396PX is support for nxos-9.x release, Does cisco has any ETA when they are going to make it 9.x official recommended code version?


Unfortunately I cannot provide any peaks behind the curtain on this one.  I can tell you that both 7.0(3)I7(x) and 9.3(x) are often recommended to customers depending on their needs.

 

Question: If i upgrade my current nxos-7.x with nxos-9.x in that case can i downgrade easily if hit any bug or any unknown issue?


Yes, it is relatively straightforward downgrading from 9.x to 7.x.  ISSU and cold-boot methods are supported in upgrading a system while cold-boot is the only supported method to downgrade a switch.

Reference: https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/93x/upgrade/guide/b-cisco-nexus-9000-nx-os-software-upgrade-downgrade-guide-93x/b-cisco-nexus-9000-nx-os-software-upgrade-downgrade-guide-93x_chapter_0111.html#id_74096

 

Hth,

Alex