cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

206
Views
0
Helpful
8
Replies
Highlighted

can anyone help me out ?? how can i create portchannel(lacp) b/w nexus 9k and cisco 3750

 
8 REPLIES 8
VIP Advisor

Re: can anyone help me out ?? how can i create portchannel(lacp) b/w nexus 9k and cisco 3750

Hello
You don’t mention how is this 9k connected - Is it in a vpc domain or stand-alone, are you suing single/multiple VDC's-do you have any fex attached etc...?

If its in a vpc with default vdc then after you've created the vpc domain you just then create the PCs as you would do any other LACP PC on both 9k switches and append a vpc index to each PC to tie them together 

 

Both 9ks

feature lacp

feature vpc

int port x

switchport mode trunk

vpc x

if it’s a standalone 9k then no need for any vpc

On the 3750 just a normal PC is required 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Re: can anyone help me out ?? how can i create portchannel(lacp) b/w nexus 9k and cisco 3750

it is a standalone device which is connected to a non cisco device

Re: can anyone help me out ?? how can i create portchannel(lacp) b/w nexus 9k and cisco 3750

L3 switch config-
interface GigabitEthernet1/1
media-type rj45
no negotiation auto
channel-group 10 mode active
!
interface GigabitEthernet1/2
media-type rj45
no negotiation auto
channel-group 10 mode active

 


Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
10 Po10(SN) LACP Gi1/1(w) Gi1/2(w)

 

Nexus 9k config

 

interface port-channel10

interface Ethernet1/1
channel-group 10 mode active

interface Ethernet1/2
channel-group 10 mode active

 

-
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
10 Po10(SD) Eth LACP Eth1/1(s) Eth1/2(s)

 

 

still the issue is not resolved

VIP Advisor

Re: can anyone help me out ?? how can i create portchannel(lacp) b/w nexus 9k and cisco 3750

Hello

Well then it will just be a normal L2 PC config.

Have you enabled lacp on the 9k?

 

example: 9k

feature lacp

default interface x/x -x

interface x/x-x

switchport 

channel-group x mode active

 

int port x

swithport mode trunk 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Re: can anyone help me out ?? how can i create portchannel(lacp) b/w nexus 9k and cisco 3750

Hi

 

As you can see in nexus config the protocol is LACP

VIP Advisor

Re: can anyone help me out ?? how can i create portchannel(lacp) b/w nexus 9k and cisco 3750

Hello

i understand that but to use lacp in nxos you need to enable it so did you enable?

show feature 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Re: can anyone help me out ?? how can i create portchannel(lacp) b/w nexus 9k and cisco 3750

switch(config)# show feature

Feature name  Instance    State
l2vpn              1              disabled
lacp                1              enabled
ldap                1              disabled
ldp                  1              disabled

VIP Advisor

Re: can anyone help me out ?? how can i create portchannel(lacp) b/w nexus 9k and cisco 3750

So you need to decide what type pf PC this is going to be - L2 or L3

As you have not stated this but it seems the 9K is connecting to a 3750 switch I would assume its going to be a trunk?

Now providing the physical connections are compatiable with each other, (meaning you have the correct copper or SFP modes, cabling etc..) the configuration should be as follows:

3750
show interface x/x capabilities < need to be compatible with the 9K interfaces)


no int port 10
default interface range gig1/1 -2

interface range gig1/1 -2
shut
switchport
channel-group 10 mode active

int port 10
swutchport trunk dot1q encap
switchport mode trunk

interface range gig1/1 -2
no shut
exit


9k
show interface x/x capabilities < need to be compatible with the 3750 interfaces)

feature lacp

default interface et1/1 -2
interface et1/1 -2
shut
swithport
channel-group 10 mode active
exit

int port 10
switchport mode trunk

interface et1/1 -2
no shut



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here