cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
271
Views
0
Helpful
7
Replies
Highlighted
Enthusiast

CSCth76131 - PIM should not choose PIM-disabled interface as RPF

Hi Everyone,

 

I have occurred a issue just like this bug,but the difference is :

When a NX-OS(Nexus 5672UP in my scene) has two equal cost routes to use via RPF the nexus will use two
ip address,even if that device is not a PIM neighbor.

we can resloved this issue by configure "ip mroute x.x.x.x 255.255.255.0 next-hop”

I think this is a bug,do you think?

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: CSCth76131 - PIM should not choose PIM-disabled interface as RPF

If you are seeing that interface without PIM being used for RPF, then absolutely, that's your bug.

View solution in original post

7 REPLIES 7
Highlighted
Cisco Employee

Re: CSCth76131 - PIM should not choose PIM-disabled interface as RPF

Hi Moments,

 

Not sure I understood the question, you did provide a bug ID and then asked if that is a bug?

Would you please elaborate a little more on what your concern is?

Highlighted
Enthusiast

Re: CSCth76131 - PIM should not choose PIM-disabled interface as RPF

Hi,

I just want to confirm another issue if hit this bug.That issue is the interface without pim as a RPF interface,just like i explain it as before.
Cisco Employee

Re: CSCth76131 - PIM should not choose PIM-disabled interface as RPF

I am sorry, but it is still not clear to me.

If I understood correctly, you mentioned that you had ECMP and your device was checking RPF based on both IPs?

If that's what you are facing, the answer is "it depends". By default the switch would hash on the highest IP, but if you have "ip multicast multipath" configured, the behavior changes.

Everyone's tags (1)
Highlighted
Enthusiast

Re: CSCth76131 - PIM should not choose PIM-disabled interface as RPF

Yes,that is correct.But one interface of them does not have pim configure,but still as a RPF interface.In my mind,the RPF interface need “ip pim sparse-mode...”
Highlighted
Cisco Employee

Re: CSCth76131 - PIM should not choose PIM-disabled interface as RPF

If you are seeing that interface without PIM being used for RPF, then absolutely, that's your bug.

View solution in original post

Highlighted
Enthusiast

Re: CSCth76131 - PIM should not choose PIM-disabled interface as RPF

maybe,but there is a difference with this bug ,those interface in ECMP all as RPF interfaces.including interface with pim and without pim.
Highlighted
Enthusiast

Re: CSCth76131 - PIM should not choose PIM-disabled interface as RPF

Anyway, thank you for your response.