cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1143
Views
0
Helpful
8
Replies

N5k VPC peer-keep alive

MoulaAli480
Beginner
Beginner

Hello,

This is Moula Ali, I have an query that N5K-C5548UP, running VPC peer links and VPC peer keep alive links. The peer keep alive links are using the dedicated mgmt ports for peer keep alive traffic. I want to change this so the VPC peer keep alive links are using dedicated ports, and this will also make the mgmt ports dedicated for management traffic only. I do not have a way to test this in a non-production environment. I wanted to make sure my procedure will not cause an outage. After the peer keep alive change, I plan to re-IP the mgmt port to a different network. Switches are running version 7.3(3)N1(1).

 

Note: Do we require Daughter card to create L3 port-channel for vpc peer-keepalive. If not can have daughter card can we create or not.

8 Replies 8

balaji.bandi
Hall of Fame
Hall of Fame

You can change the vpc peer-link no issue, but 1 question to ask, is the end device dual Homed with both nexus 5K, do you have any small diagram.

 

It all depends on config you have, If you are using port-channel, you can remove and join the new interface, if they are same speeds ? i do not see any issue.

 

Make sure you always perform any task in maintenance window for better outcome, no pressure it is effecting Live traffic to save your self.

 

 

Note: Do we require Daughter card to create L3 port-channel for vpc peer-keepalive. If not can have daughter card can we create or not.

 

you can use different Asic if you do not have any other option for safe and best practice.

 

You must configure peer-keepalive link before peer-link in order for vPC system to come up.

 

check out some best practice for reference :

 

https://www.cisco.com/c/dam/en/us/td/docs/switches/datacenter/sw/design/vpc_design/vpc_best_practices_design_guide.pdf

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hello, 

 

I don't have the sample diagram but my clear question is with out daughter card can we create L3 port-channel for vpc peer-keepalive and just to confirm that  there is no impact while changing the keepalive from mgmt port to L3 port-channel. Please find the below sample config.

FYI: Its already vpc configured but changing only vpc peer-keepalive from mgnt port to L3 port-channel. will it not cuase not impact during the peer link up and running.

 

Config:

#default new ports used for PKA
default interface eth1/3-4

#create new VRF for PKA
vrf context pka1

#create port channel for PKA
interface port-channel1
description VPC Peer Keepalive link to edcns5kcore02
vrf member pka1
service-policy type qos input ingresspolicy
ip address 192.168.255.1/30

#configure physical port for PKA
interface Ethernet1/3
description VPC Peer Keepalive Link
channel-group 1 mode active

#configure physical port for PKA
interface Ethernet1/4
description VPC Peer Keepalive Link
channel-group 1 mode active

#change VPC domain to use new PKA ports
vpc domain 11
peer-keepalive destination 192.168.255.2 source 192.168.255.1 vrf pka1

#change IP of mgmt port
interface mgmt0
ip address 172.30.83.81/24

#change default gateway for mgmt port
vrf context management
ip route 0.0.0.0/0 172.30.83.1

MoulaAli480
Beginner
Beginner

Hello, 

 

I don't have the sample diagram but my clear question is with out daughter card can we create L3 port-channel for vpc peer-keepalive and just to confirm that  there is no impact while changing the keepalive from mgmt port to L3 port-channel. Please find the below sample config.

FYI: Its already vpc configured but changing only vpc peer-keepalive from mgnt port to L3 port-channel. will it not cuase not impact during the peer link up and running.

 

Config:

#default new ports used for PKA
default interface eth1/3-4

#create new VRF for PKA
vrf context pka1

#create port channel for PKA
interface port-channel1
description VPC Peer Keepalive link to edcns5kcore02
vrf member pka1
service-policy type qos input ingresspolicy
ip address 192.168.255.1/30

#configure physical port for PKA
interface Ethernet1/3
description VPC Peer Keepalive Link
channel-group 1 mode active

#configure physical port for PKA
interface Ethernet1/4
description VPC Peer Keepalive Link
channel-group 1 mode active

#change VPC domain to use new PKA ports
vpc domain 11
peer-keepalive destination 192.168.255.2 source 192.168.255.1 vrf pka1

#change IP of mgmt port
interface mgmt0
ip address 172.30.83.81/24

#change default gateway for mgmt port
vrf context management
ip route 0.0.0.0/0 172.30.83.1

shreyakith
Beginner
Beginner

Before we dive into vPC it is important to quickly review Port-Channels.

A Port-Channel is a technology that provides a way to aggregate (bond) multiple interfaces together. Traffic is then load balanced across each of the connections. Port-Channels provides 3 key benefits,

  • Redundancy - Should one of the interfaces fail traffic is sent over the remaining links.
  • Bandwidth - Increase in bandwidth due to bundling multiple interfaces together. Traffic is then load balanced across each of the links within the 'bundle'.
  • Spanning Tree - Port-Channels are seen as a single switch port by Spanning-Tree protocols

Let’s look at each of the VPC components,

  • vPC Domain - Includes the vPC Peers, KeepAlive Links, and the Port-Channels that use the vPC technology.
  • vPC Peer Switch - The other switch within the vPC domain. Each switch is connected via the vPC peer link. It's also worth noting that one device is selected as primary and the other secondary.
  • vPC Member Port - Ports included within the VPCs.
  • vPC Peer-Keepalive Link - Connects both vPC peer switches and carries monitoring traffic to/from each peer switch. Monitoring is performed to ensure the switches are both operational and running vPC.
  • vPC Peer Link - Connects both vPC peer switches and carries BPDUs, HSRPs, and MAC addresses to its vPC peer. In the event of vPC member port failure, it also carries unicast traffic to the peer switch.
  • Orphan Port - An orphan port is a port that is configured with a vPC VLAN (i.e a VLAN that is carried over the vPC peer link) and is not configured as a vPC member port

Actually this is not my query which am seeking. My straight point is will
N5K is required daughter card to create L3 port-channel. In my case N5K
don't have daughter card can I create L3 port- channel for vpc
peer-keepalive without daughter card or not ?

Regards,
Moula Ali

Hope I have addressed before it can done (check if you can use different asic, Not that i have seen any document which need to Daughter card, or i may be missed anywhere ? - if you do not have any other cards, not sure what mode is this ?), If you Looking more  than this ( contact TAC)

 

here is the reference guide :

 

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5000/sw/interfaces/521_N11/b_5k_Interfaces_Config_Guide_Release_521N11/b_5k_Interfaces_Config_Guide_Release_521N11_chapter_0101.html

 

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5000/sw/layer2/b_Cisco_Nexus_5000_Series_NX-OS_/Cisco_Nexus_5000_Series_NX-OS__chapter8.html#concept_47F7274E5FDA489884D0488BC491B066

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hi Moula,

 

No,

 

If you want to use any physical interface as L3(routed port), you would need the L3 daughter card. Considering the port-channel is L3, you would need it.

 

Regards,

Prasann

Thank you ....

Regards,
Moula Ali
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: