cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1356
Views
0
Helpful
3
Replies
helenio
Beginner

Nexus 1000V 4.0 to 4.2 upgrade

Hello, I'm getting ready to ugrade from 4.0(4)SV1(3) to 4.2(1)SV1(4a).

I read that first we have to upgrade VEMs and afterword VSMs.

Let say that I'm upgrade only the first VEM module for some days to see if everythings is working fine.

What can be the drawback to have in production VSM 4.0(4)SV1(3)  and only one VEM with 4.2(1)SV1(4a), al others VEM with 4.0(4)SV1(3).

New configuration will be pushed from VSM to VEM ?

Does anyone as experience with ver 4.2(1)SV1(4a) ? stability ?

3 REPLIES 3
Robert Burns
Cisco Employee

Helenio,

Technically you can operate a 1000v system in a mixed configuration (VEM at 1.4 while VSM at 1.3) but this is not recommended or supported for a lengthy amount of time, nor for testing.  Many of the "new" features are enabled with the VSM.  The new bells & whistles aren't turned on until the VSM is upgraded.  By upgrading the VEM, you're just running an updated VEM agent that is compatible with the new VSM. 

For proper testing, we'd suggest you run up a lab with everything at the desired version(1.4a) and do testing in this controlled environment.

From a overall stance, I can say that 1.4a has been extremely stable.  From 1.4 -> 1.4a there are some bug fixes so if you were looking for a recommendation on a version I'd push you towards 1.4a. 

Regards,

Robert

First thank's for the reply ...

just for my understanding, Nexus version is called 4.2(1)SV1(4a) what does mean 4.2(1), I guess that SV1(4a) is the VEM version. Since I'm running 4.0(4)SV1(3), you said that I haven't to worry about upgrade to 1.4a but what about upgrade from 4.0(4) to 4.2(1). what I'm upgrading there ?

onother thing, I downloaded N1K SW from CCO and there I found VEM folder where i suppose that VEM SW is stored, is that correct ?

If I'm installing, for exemple, VEM410-201107407.zip with vihostupdate command I'm going to patching ESX and install the VEM  1.4a or just install the VEM ?

And, just for understanding, if I'm going to update VEM with VEM500-201108271.zip vihostupdate I'll do also upgrade ESX to 5.0 version ? isn't ?

Don't worry about the versioning, the difference in 1.4 compared to other builds is the updated underlying NXOS software.

Ex.

The common name vs. the full software version is below

1,1 = 4.0(4)SV1(1)

1.2 = 4.0(4)SV1(2)

1.3 = 4.0(4)SV1(3)

1.4 = 4.2(1)SV1(4)

Yes, the full 1000v image will have sub folders containing all the VEM VIB files (used for manual installations).

If you have VUM (Update Manager) you can automate the upgrade, however if you want to do it manually in a controlled manner.  IF you want to update the VEM to the latest release (1.4a) you can just pull the appropriate VEM update, and run it against the hosts you wish to upgrade, using either VI Host or esxupdate.

VEM500-xxxx = ESX 5.

Regards,

Rob