cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
206
Views
5
Helpful
6
Replies
Highlighted
Beginner

Nexus 7000 monitor session state error

on our N7K - running version 8.1(2) - we have some monitor sessions in error state.

Shutting down these sessions, deleting and reconfigure them did not help. What's the cause for this state and how can we resolve it?

 

N7K-1-CSW01# sh ver | sec Software|Hardware
Cisco Nexus Operating System (NX-OS) Software
Software
BIOS: version 3.1.0
kickstart: version 8.1(2)
system: version 8.1(2)
BIOS compile time: 02/27/2013
kickstart image file is: bootflash:///n7700-s2-kickstart.8.1.2.bin
kickstart compile time: 11/20/2017 20:00:00 [01/31/2018 17:22:07]
system image file is: bootflash:///n7700-s2-dk9.8.1.2.bin
system compile time: 11/20/2017 20:00:00 [01/31/2018 19:14:23]
Hardware
cisco Nexus7700 C7706 (6 Slot) Chassis ("Supervisor Module-2")
Intel(R) Xeon(R) CPU with 32939336 kB of memory.
Processor Board ID XXXXXXXX
N7K-1-CSW01#
N7K-1-CSW01#
N7K-1-CSW01# sh monitor
Ssn# State Reason Description Type
----- ----- ---------------------- -------------------------------- ----------
1 error Generic error MonServ004 local
2 error Generic error MonServ301 local
3 down Session admin shut ERSPAN for N7K-2-CSW01 erspan-dst
4 up The session is up NTF301-SL8-1 local
13 down Session admin shut nss-sess-moni erspan-src

Total configured session(s): 5, active session(s): 1

N7K-1-CSW01#
N7K-1-CSW01# sh monitor session 2
session 2
---------------
description : MonServ301
type : local
ssn direction : both
state : error
source intf :
rx : Po2 Po9 Po40
tx : Po2 Po9 Po40
both : Po2 Po9 Po40
source VLANs :
rx :
tx :
both :
source exception :
filter VLANs : filter not specified
destination ports : Eth6/43

N7K-1-CSW01#
N7K-1-CSW01# sh run int Eth6/43

!Command: show running-config interface Ethernet6/43
!Time: Wed Jan  6 10:19:47 2021

version 8.1(2)

interface Ethernet6/43
  description MonServ301-Slot1-1
  no lldp transmit
  switchport monitor
  speed 10000
  no shutdown

N7K-1-CSW01#
N7K-1-CSW01# sh int Eth6/43 status

--------------------------------------------------------------------------------
Port             Name            Status    Vlan      Duplex  Speed   Type
--------------------------------------------------------------------------------
Eth6/43       MonServ301   connected 1         full    10G     10Gbase-SR
N7K-1-CSW01#

 

Thank you for any advice

 

 

6 REPLIES 6
Highlighted
VIP Engager

Hi @nssnas189 

Can you share the following:

 

show logging log 
show accounting log
show module
show run monitor show run int Po2, Po9, Po40

Notes:

1. Leave the full run monitor output

2. For the logging and accounting logs, please share only the times when you reconfigured the span

3. if you have any sensitive data (names, descriptions, IP addresses, users etc), delete them or change them to a generic value

 

Stay safe,

Sergiu

 

Highlighted

Hi @sergiu ,

 

thank you for reply. Following you find outputs requested.

 

N7K-1-CSW01 # sh logging log
2021 Jan  4 16:40:29 N7K-1-CSW01 %MONITOR-3-ETH_SPAN_SESSION_ERROR: Session 2 is having error. Reason "Generic error"
2021 Jan  4 16:40:33 N7K-1-CSW01 %VSHD-5-VSHD_SYSLOG_CONFIG_I: Configured from vty by yyyyy on x.x.x.x@pts/8
2021 Jan  4 16:42:34 N7K-1-CSW01 %MONITOR-3-ETH_SPAN_SESSION_ERROR: Session 1 is having error. Reason "Generic error"
2021 Jan  4 16:42:43 N7K-1-CSW01 %MONITOR-3-ETH_SPAN_SESSION_ERROR: Session 2 is having error. Reason "Generic error"
2021 Jan  4 16:43:54 N7K-1-CSW01 %MONITOR-3-ETH_SPAN_SESSION_ERROR: Session 2 is having error. Reason "Generic error"
2021 Jan  4 16:46:05 N7K-1-CSW01 %ETHPORT-5-IF_DOWN_CFG_CHANGE: Interface Ethernet6/43 is down(Config change)
2021 Jan  4 16:46:05 N7K-1-CSW01 %ETHPORT-5-IF_DOWN_CFG_CHANGE: Interface Ethernet1/43 is down(Config change)
2021 Jan  4 16:46:06 N7K-1-CSW01 %ETHPORT-5-IF_DOWN_ADMIN_DOWN: Interface Ethernet6/43 is down (Administratively down)
2021 Jan  4 16:46:06 N7K-1-CSW01 %ETHPORT-5-IF_DOWN_ADMIN_DOWN: Interface Ethernet1/43 is down (Administratively down)
2021 Jan  4 16:47:45 N7K-1-CSW01 %ETHPORT-5-IF_ADMIN_UP: Interface Ethernet6/43 is admin up .
2021 Jan  4 16:47:45 N7K-1-CSW01 %ETHPORT-5-IF_ADMIN_UP: Interface Ethernet1/43 is admin up .
2021 Jan  4 16:47:46 N7K-1-CSW01 %ETHPORT-5-SPEED: Interface Ethernet1/43, operational speed changed to 10 Gbps
2021 Jan  4 16:47:46 N7K-1-CSW01 %ETHPORT-5-IF_DUPLEX: Interface Ethernet1/43, operational duplex mode changed to Full
2021 Jan  4 16:47:46 N7K-1-CSW01 %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface Ethernet1/43, operational Receive Flow Control state changed to off
2021 Jan  4 16:47:46 N7K-1-CSW01 %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface Ethernet1/43, operational Transmit Flow Control state changed to off
2021 Jan  4 16:47:46 N7K-1-CSW01 %ETHPORT-5-IF_UP: Interface Ethernet1/43 is up in mode monitor
2021 Jan  4 16:47:46 N7K-1-CSW01 %ETHPORT-5-SPEED: Interface Ethernet6/43, operational speed changed to 10 Gbps
2021 Jan  4 16:47:46 N7K-1-CSW01 %ETHPORT-5-IF_DUPLEX: Interface Ethernet6/43, operational duplex mode changed to Full
2021 Jan  4 16:47:46 N7K-1-CSW01 %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface Ethernet6/43, operational Receive Flow Control state changed to off
2021 Jan  4 16:47:46 N7K-1-CSW01 %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface Ethernet6/43, operational Transmit Flow Control state changed to off
2021 Jan  4 16:47:46 N7K-1-CSW01 %ETHPORT-5-IF_UP: Interface Ethernet6/43 is up in mode monitor
2021 Jan  4 16:48:13 N7K-1-CSW01 %MONITOR-3-ETH_SPAN_SESSION_ERROR: Session 1 is having error. Reason "Generic error"
2021 Jan  4 16:48:21 N7K-1-CSW01 %MONITOR-3-ETH_SPAN_SESSION_ERROR: Session 2 is having error. Reason "Generic error"
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-IF_DOWN_CFG_CHANGE: Interface Ethernet6/43 is down(Config change)
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-IF_DOWN_CFG_CHANGE: Interface Ethernet1/43 is down(Config change)
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-SPEED: Interface Ethernet1/43, operational speed changed to 10 Gbps
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-IF_DUPLEX: Interface Ethernet1/43, operational duplex mode changed to Full
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface Ethernet1/43, operational Receive Flow Control state changed to off
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface Ethernet1/43, operational Transmit Flow Control state changed to off
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-IF_UP: Interface Ethernet1/43 is up in mode monitor
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-SPEED: Interface Ethernet6/43, operational speed changed to 10 Gbps
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-IF_DUPLEX: Interface Ethernet6/43, operational duplex mode changed to Full
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface Ethernet6/43, operational Receive Flow Control state changed to off
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface Ethernet6/43, operational Transmit Flow Control state changed to off
2021 Jan  4 16:48:55 N7K-1-CSW01 %ETHPORT-5-IF_UP: Interface Ethernet6/43 is up in mode monitor
Mon Jan  4 16:18:56 2021:type=start:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=
Mon Jan  4 16:39:50 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 (SUCCESS)
Mon Jan  4 16:39:54 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; shut (SUCCESS)
Mon Jan  4 16:40:11 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; no monitor session 2 (SUCCESS)
Mon Jan  4 16:40:28 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 (SUCCESS)
Mon Jan  4 16:40:28 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; description MonServ301 (SUCCESS)
Mon Jan  4 16:40:29 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; source interface port-channel2 both (SUCCESS)
Mon Jan  4 16:40:29 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; source interface port-channel9 both (SUCCESS)
Mon Jan  4 16:40:29 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; source interface port-channel40 both (SUCCESS)
Mon Jan  4 16:40:29 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; no rate-limit (SUCCESS)
Mon Jan  4 16:40:29 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; destination interface Ethernet6/43 (SUCCESS)
Mon Jan  4 16:40:29 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; no shut (SUCCESS)
Mon Jan  4 16:41:03 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 (SUCCESS)
Mon Jan  4 16:41:09 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; shut (SUCCESS)
Mon Jan  4 16:41:26 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 (SUCCESS)
Mon Jan  4 16:41:29 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 ; shut (SUCCESS)
Mon Jan  4 16:41:41 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; no monitor session 1 (SUCCESS)
Mon Jan  4 16:41:47 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; no monitor session 2 (SUCCESS)
Mon Jan  4 16:42:07 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 (SUCCESS)
Mon Jan  4 16:42:08 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 ; description MonServ004 (SUCCESS)
Mon Jan  4 16:42:08 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 ; source interface port-channel2 both (SUCCESS)
Mon Jan  4 16:42:08 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 ; source interface port-channel9 both (SUCCESS)
Mon Jan  4 16:42:08 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 ; source interface port-channel40 both (SUCCESS)
Mon Jan  4 16:42:08 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 ; no rate-limit (SUCCESS)
Mon Jan  4 16:42:08 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 ; destination interface Ethernet1/43 (SUCCESS)
Mon Jan  4 16:42:21 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 (SUCCESS)
Mon Jan  4 16:42:21 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; description MonServ301 (SUCCESS)
Mon Jan  4 16:42:21 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; source interface port-channel2 both (SUCCESS)
Mon Jan  4 16:42:21 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; source interface port-channel9 both (SUCCESS)
Mon Jan  4 16:42:21 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; source interface port-channel40 both (SUCCESS)
Mon Jan  4 16:42:21 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; no rate-limit (SUCCESS)
Mon Jan  4 16:42:21 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; destination interface Ethernet6/43 (SUCCESS)
Mon Jan  4 16:42:29 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 (SUCCESS)
Mon Jan  4 16:42:34 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 ; no shut (SUCCESS)
Mon Jan  4 16:42:41 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 (SUCCESS)
Mon Jan  4 16:42:43 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; no shut (SUCCESS)
Mon Jan  4 16:43:17 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 (SUCCESS)
Mon Jan  4 16:43:21 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; shut (SUCCESS)
Mon Jan  4 16:43:30 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; no monitor session 2 (SUCCESS)
Mon Jan  4 16:43:35 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 (SUCCESS)
Mon Jan  4 16:43:54 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; description MonServ301 (SUCCESS)
Mon Jan  4 16:43:54 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; source interface port-channel2 both (SUCCESS)
Mon Jan  4 16:43:54 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; source interface port-channel9 both (SUCCESS)
Mon Jan  4 16:43:54 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; source interface port-channel40 both (SUCCESS)
Mon Jan  4 16:43:54 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; no rate-limit (SUCCESS)
Mon Jan  4 16:43:54 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; destination interface Ethernet6/43 (SUCCESS)
Mon Jan  4 16:43:54 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; no shut (SUCCESS)
Mon Jan  4 16:46:01 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; interface Ethernet1/43, Ethernet6/43 (REDIRECT)
Mon Jan  4 16:46:01 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; interface Ethernet1/43, Ethernet6/43 (SUCCESS)
Mon Jan  4 16:46:05 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; interface Ethernet1/43, Ethernet6/43 ; shutdown (REDIRECT)
Mon Jan  4 16:46:06 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; interface Ethernet1/43, Ethernet6/43 ; shutdown (SUCCESS)
Mon Jan  4 16:46:13 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; interface Ethernet1/43, Ethernet6/43 ; switchport mode access (REDIRECT)
Mon Jan  4 16:46:13 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; interface Ethernet1/43, Ethernet6/43 ; switchport mode access (SUCCESS)
Mon Jan 4 16:46:32 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 (SUCCESS) Mon Jan 4 16:46:34 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 1 ; shut (SUCCESS) Mon Jan 4 16:46:39 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 (SUCCESS) Mon Jan 4 16:46:40 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; monitor session 2 ; shut (SUCCESS) Mon Jan 4 16:46:54 2021:type=update:id=x.x.x.x@pts/8:user=yyyyyyy:cmd=configure terminal ; interface Ethernet1/43, Ethernet6/43 (REDIRECT)
N7K-1-CSW01# sh module
Mod  Ports  Module-Type                         Model              Status
---  -----  ----------------------------------- ------------------ ----------
1    48     1/10 Gbps Ethernet Module           N77-F348XP-23      ok
2    12     100 Gbps Ethernet Module            N77-F312CK-26      ok
3    0      Supervisor Module-2                 N77-SUP2E          active *
4    0      Supervisor Module-2                 N77-SUP2E          ha-standby
6    48     1/10 Gbps Ethernet Module           N77-F348XP-23      ok

Mod  Sw               Hw
---  ---------------  ------
1    8.1(2)           1.1
2    8.1(2)           1.5
3    8.1(2)           1.1
4    8.1(2)           1.1
6    8.1(2)           1.1


Mod  MAC-Address(es)                         Serial-Num
---  --------------------------------------  ----------
1    28-c7-ce-5c-30-00 to 28-c7-ce-5c-30-3b  SNSNSNSNSN
2    a0-f8-49-5f-16-32 to a0-f8-49-5f-16-a3  SNSNSNSNSN
3    3c-0e-23-c4-eb-8a to 3c-0e-23-c4-eb-9c  SNSNSNSNSN
4    54-4a-00-ad-c8-32 to 54-4a-00-ad-c8-44  SNSNSNSNSN
6    28-c7-ce-5c-2c-04 to 28-c7-ce-5c-2c-3f  SNSNSNSNSN

Mod  Online Diag Status
---  ------------------
1    Pass
2    Pass
3    Pass
4    Pass
6    Pass

Xbar Ports  Module-Type                         Model              Status
---  -----  ----------------------------------- ------------------ ----------
1    0      Fabric Module 2                     N77-C7706-FAB-2    ok
2    0      Fabric Module 2                     N77-C7706-FAB-2    ok
3    0      Fabric Module 2                     N77-C7706-FAB-2    ok
4    0      Fabric Module 2                     N77-C7706-FAB-2    ok

Xbar Sw               Hw
---  ---------------  ------
1    NA               1.0
2    NA               1.0
3    NA               1.0
4    NA               1.0


Xbar MAC-Address(es)                         Serial-Num
---  --------------------------------------  ----------
1    NA                                      SNSNSNSNSN
2    NA                                      SNSNSNSNSN
3    NA                                      SNSNSNSNSN
4    NA                                      SNSNSNSNSN

* this terminal session
N7K-1-CSW01#
N7K-1-CSW01#  sh run mon

!Command: show running-config monitor
!Time: Wed Jan  6 12:37:27 2021

version 8.1(2)
monitor session 1
  description MonServ004
  source interface port-channel2 both
  source interface port-channel9 both
  source interface port-channel40 both
  no rate-limit
  destination interface Ethernet1/43
  no shut
monitor session 2
  description MonServ301
  source interface port-channel2 both
  source interface port-channel9 both
  source interface port-channel40 both
  no rate-limit
  destination interface Ethernet6/43
  no shut
monitor session 3 type erspan-destination
  description ERSPAN for N7K-2-CSW01
  erspan-id 421
  vrf default
  source ip x.x.x.x
  destination interface Ethernet1/43
monitor session 4
  description NTF301-SL8-1
  source vlan 1038 both
  no rate-limit
  destination interface Ethernet1/30
  filter vlan 1038
  no shut
monitor session 13 type erspan-source
  description nss-sess-moni
  header-type 3
  erspan-id 301
  vrf default
  destination ip x.x.x.x
  source vlan 3 both
  mtu 1500
  no rate-limit
  filter dest-mac 0050.56be.2308 0000.0000.0000
N7K-1-CSW01# show run int Po2, Po9, Po40

!Command: show running-config interface port-channel2, port-channel9, port-channel40
!Time: Wed Jan  6 12:40:43 2021

version 8.1(2)

interface port-channel2
  description vPC 2 XXXXXXX2
  switchport mode private-vlan trunk promiscuous
  switchport trunk allowed vlan none
  spanning-tree port type edge trunk
  spanning-tree guard root
  switchport private-vlan trunk allowed vlan 128,153,211-212,220,228,402,602,1002,1004,1006,1136,1144-1146,1152,1300-1399,1501-1594,1601-1699,1701-1794,1901-1994,2141-2144,2146-2149,2915,2931,2989,3122,3
229,3330,3801,3941,3943-3944
  switchport private-vlan mapping trunk 1400 1401-1404,1499
  switchport private-vlan mapping trunk 300 301-307
  vpc 2

interface port-channel9
  description vPC 9 XXXXXXX9
  switchport mode trunk
  switchport trunk allowed vlan 1002
  spanning-tree port type edge trunk
  spanning-tree guard root
  vpc 9

interface port-channel40
  description vPC 40 XXXXXXX40
  switchport mode trunk
  switchport trunk allowed vlan 1003
  spanning-tree port type edge trunk
  vpc 40

N7K-1-CSW01#

 

Thanky you

 

Highlighted

Usually generic error is generated by some unsupported config, but I do not see any problem.

Was the SPAN session working before?

When is the first time the error was generated?

What logs were generated at that time and what actions have you performed?

If you delete one of the two problematic spans, is the other one working?

 

Cheers,

Sergiu

 

Highlighted

yes the 1st SPAN was working. the 2nd SPAN should replace the 1st one (we got a new Monitor Server Appliance and should be tested at first)

 

Problem occured after a Reboot during maintenance windows "2020 Sep 26". There was no config change, only because the N7Ks have an uptime of 2 years. 3 of our 4 N7Ks have no issue with SPAN after reboot (Loggs after this reboot is attached).

 

When i delete the 2nd SPAN, still the 1st one in error state

 

Many thanks

Highlighted

Yep, It looks like the error appeared right after the reload:

"2020 Sep 26 15:04:24 N7K-1-CSW01 %MONITOR-3-ETH_SPAN_SESSION_ERROR: Session 1 is having error. Reason "Generic error""

There might be some config changes since last reload which conflicts with the SPAN. What exactly, hard to say.

 

You have two options to move further:

1/ the "finding what the hell is happening" way: collect tac-pac, show tech monitor etc, and open a case with TAC

2/ the "fix it, I don't care why is not working" way: try to delete monitor session 1 and 2, and reconfigure it, reload module etc.

 

If you go for option one, there is a possibility that when you reconfigure it to either work or get some messages why is not working.

Myself, I always go for option 1, but you know best if/how important is for you about this. 

If you decide to go for second option, I would still recommend to collect at least "show tech monitor" or better tac-pac, to have it as a backup.

show tech monitor > show_tech_monitor.txt
tac-pac bootflash:tac-pac.txt.gz

Stay safe,

Sergiu

Highlighted

thank you @sergiu 

i'll go on option 1 and keep this discussion updated

 

Stay safe you too

 

Best regards

Content for Community-Ad