cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1473
Views
0
Helpful
6
Replies
Highlighted
Beginner

Physical Uplink Dropping InPktDrops

Hi all,

We have a fresh installation working fine on HA mode and with 1 single VEM running on a Hyper-V 2012 host.

We are testing connectivity by ping and there is in some cases 1.5% up to 3.5% aprox.

While we are running ping to 4 VMs created on this VEM Host, at the same we are running ping to VSM and to every VM default gateway subnet.

ACANWXN1KV01# show int eth3/1 | egrep -i "ethernet|drop"

Ethernet3/1 is up

  Hardware: Ethernet, address: 24b6.fda7.6778 (bia 24b6.fda7.6778)

    1966 Input Packet Drops 0 Output Packet Drops

We don´t see any discard on the physical blade switch interface.

1966 Input Packet Drops 0 Output Packet Drops

ACANWXN1KV01# show int | egrep -i "ethernet|drop"

  Hardware: Ethernet, address: 001d.d8b7.1c08 (bia 001d.d8b7.1c08)

Ethernet3/1 is up

  Hardware: Ethernet, address: 24b6.fda7.6778 (bia 24b6.fda7.6778)

1972 Input Packet Drops 0 Output Packet Drops

Vethernet1 is up

0 Input Packet Drops 0 Output Packet Drops

Vethernet2 is up

0 Input Packet Drops 0 Output Packet Drops

Vethernet3 is up

0 Input Packet Drops 0 Output Packet Drops

Vethernet4 is up

0 Input Packet Drops 0 Output Packet Drops

Vethernet5 is up

0 Input Packet Drops 0 Output Packet Drops

  Hardware: Ethernet, address: 001d.d8b7.1c07 (bia 001d.d8b7.1c07)

It´s weird to be dropping input packets. Any idea about what I should look for?

Regards

6 REPLIES 6
Highlighted
Cisco Employee

IF you're using MAC Pinning its likely expected behavior.  One uplink will be used as the designated receiver for Mcast/Bcast traffic for that VEM, the rest of the uplinks will drop it - incrementing the drop counter.

Regards,

Robert

Highlighted

As we are using only 1 physical adapter on the VEM, I didn´t configure a port-channel so It shouldn´t be MAC pinning. Am I wrong?

We are just testing the scenario, so VMs have not real load.

I understand what you say, but it´s not my scenario I think. I´m a beginner on Nexus´s world

Regards

Highlighted
Cisco Employee

You shouldn't see ping drop packets. Something might not be right.

Can you give us some more information about your configuration?

What type of server? What type of nic card?

Is the VSM on the same server as the VMs?

Where is the VSM? is it on the VEM or on a MS native/logical switch?

Do the VMs drop packets when you ping another VM on the same VEM?

A quick picture of your architecture would help.

louis

Highlighted

Hi Iouis,

The SCVMM (2012 SP1 UR3) is a physical blade with 2 interfaces and just 1 connected.

The HYV204 is another blade (M710HD) with 4 interfaces connected to the same stacked switches DELL M6348 and it has 1 physical interface for mgmt purpose (without virtualizing), 1 physical interface for Hyper-V purpose with MS Native virtual switch, 1 is not in use and the lastone for VEM Module.

Here is the switch interface configuration:

switchport mode trunk

switchport trunk allowed vlan 610,612-613,616

I made this sort of diagram to clarify you a bit what we have here.

We don´t see ping drop packets between VMs in the same VEM Module and same VLAN, but yes in VMs in same VEM but different VLAN. It seems that when packets needs to be routed we see ping drop packets.

I tried to run vempkt capture on VEM Module but it didn´t work, I don´t know if it´s an unsupported feature for hyper-v nexus 1000v version or what I'm doing wrong but no packet were captured.

If you need any further information, please let me know.

Regards

Highlighted

Hi all,

I found an stp issue on DELL switches. It had a port-channel blocked by stp but it wasn´t really true. So I found myself looped when I started to follow my own diagram in every case to figure it out what was happening. We will fix this issue with dell guys next week but now we wanted to keep testing infra with real load.

I suspended that port-channel and everything started to work fine. InDrops on N1K physical uplinks still dropping packets but no ping drop packets.

Just for knowledge, how can I capture those packets to see what is being dropped?

Regards and thanks for your help I really appreciate that.

Highlighted

Glad to hear you sorted it Javier.

You can run a "vempkt" capture on that VEM - This utility will capture traffic at various stages (Ingress,Egress, Both) and you can filter on various types such as DROP, VLAN, LTL etc.  It's especially useful for what you need which is to help identify "what" traffic is being dropped.  By simply SPANing the port, you wouldn't catch this traffic.

VEMPKT is very well documented how to use online.  Just search for it.

Robert

This widget could not be displayed.