cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

603
Views
0
Helpful
3
Replies
abimadaro4462
Beginner

vPC & OSPF

Hello,

I have the following scenario, two nexus 9K are configured as vPC peers with HSRP, the upstream is connected to active/standby firewall with OSPF configured.

below is the configuration;

SW1 & SW2

----

router ospf 1
bfd
router-id 10.10.10.4
area 0.0.0.4 nssa no-summary

interface Vlan20
ip ospf dead-interval 3
ip ospf hello-interval 1
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.4
ip ospf bfd

 

interface Vlan20
hsrp 20
ip 20.20.20.1

 

vpc domain 10
peer-switch
role priority 100
peer-keepalive destination 10.10.10.2 source 10.10.10.1 vrf vpcvrf
peer-gateway
layer3 peer-router
auto-recovery
ip arp synchronize

interface port-channel1
vpc peer-link

 

Switch one neighbor is flapping between EXSTART and EXCHANG

Neighbor ID Pri State Up Time Address Interface
10.10.10.5 1 FULL/ - 00:25:17 20.20.20.3 Vlan20
10.20.10.10 1 EXCHANGE/ - 0.065025 20.20.20.6 Vlan20

 

Please advice if the above configuration is correct.

 

Regards,

 

3 REPLIES 3
balaji.bandi
VIP Master

To understand the problem better, can you post the HLD and how interface connected and full config of both the switches ?

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Hello,

Here's the HLD

 

Capture.PNG

Here's the configuration;

SW 1

------

vpc domain 10
peer-switch
peer-keepalive destination 10.10.10.2 source 10.10.10.1 vrf vpcvrf
peer-gateway
layer3 peer-router

interface Vlan1
no ip redirects
no ipv6 redirects

interface Vlan172
no shutdown
no ip redirects
ip address 172.16.8.5/29
no ipv6 redirects
ip ospf dead-interval 40
ip router ospf 1 area 0.0.0.0

interface port-channel1
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 172
vpc 10

interface Ethernet1/1
no switchport
vrf member vpcvrf
ip address 10.10.10.1/30
no shutdown

interface Ethernet1/2
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/3
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/4
switchport mode trunk
switchport trunk allowed vlan 172
channel-group 10


router ospf 1
router-id 10.10.10.1

 

SW2

-----

vpc domain 10
peer-switch
peer-keepalive destination 10.10.10.1 source 10.10.10.2 vrf vpcvrf
peer-gateway
layer3 peer-router

interface Vlan1
no ip redirects
no ipv6 redirects

interface Vlan172
no shutdown
no ip redirects
ip address 172.16.8.4/29
no ipv6 redirects
ip ospf dead-interval 40
ip router ospf 1 area 0.0.0.0

interface port-channel1
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 172
vpc 10

interface Ethernet1/1
no switchport
vrf member vpcvrf
ip address 10.10.10.2/30
no shutdown

interface Ethernet1/2
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/3
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/4
switchport mode trunk
switchport trunk allowed vlan 172
channel-group 10

router ospf 1
router-id 10.10.10.2

 

Here's the output of show ip ospf neighbor

Neighbor ID Pri State Up Time Address Interface
10.10.10.1 1 FULL/DR 08:49:38 172.16.8.5 Vlan172
10.20.10.10 1 EXSTART/DROTHER 00:00:01 172.16.8.1 Vlan172

 

I have deleted the HSRP configuration for testing but same results.

 

 

paul driver
VIP Mentor

Duplicate post  - here



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future