cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
235
Views
0
Helpful
4
Replies
Highlighted
Beginner

VRF Default Route not being advertised into OSPF on Nexus 9k

Got an issue trying to point traffic to a firewall.

Default route not being advertised to ospf on a pair of Nexus 9k's using VPC

Part of config

 

vrf context PUBLIC
ip route 0.0.0.0/0 10.249.9.2 name PUBLIC_VRF

 

router ospf 11
default-information originate always
vrf PUBLIC
bfd
router-id 10.248.65.1
log-adjacency-changes detail
auto-cost reference-bandwidth 100000 Mbps
passive-interface default

 

interface Vlan2131
description +++PUBLIC VRF to Sonicwall+++
no shutdown
vrf member PUBLIC
no ip redirects
ip address 10.249.9.5/28
no ipv6 redirects
no ip ospf passive-interface
ip router ospf 11 area 0.0.0.0
ip proxy-arp
no ip arp gratuitous hsrp duplicate
hsrp version 2
hsrp 2131
authentication md5 key-chain *****
preempt
priority 110
ip 10.249.9.1

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Collaborator

Yes, but it is configured in default vrf. You have to move it under "vrf PUBLIC".

Change your config from this:

router ospf 11
  default-information originate always
  vrf PUBLIC
    bfd
    router-id 10.248.65.1
    log-adjacency-changes detail
    auto-cost reference-bandwidth 100000 Mbps
    passive-interface default

to this:

router ospf 11
  vrf PUBLIC
    default-information originate always
    bfd
    router-id 10.248.65.1
    log-adjacency-changes detail
    auto-cost reference-bandwidth 100000 Mbps
    passive-interface default

Cheers,

Sergiu

View solution in original post

4 REPLIES 4
Highlighted
Collaborator

Hi @Garry Cooper 

You need to configure the "default-information originate" command under the VRF settings in OSPF config mode:

router ospf 11
default-information originate always vrf PUBLIC default-information originate always bfd router-id 10.248.65.1 log-adjacency-changes detail auto-cost reference-bandwidth 100000 Mbps passive-interface default

Stay safe,

Sergiu

Highlighted

Sergiu.

Thanks for the reply....

But its in my config..

 

Here is same as above.

router ospf 11
default-information originate always
vrf PUBLIC
bfd
router-id 10.248.65.1
log-adjacency-changes detail
auto-cost reference-bandwidth 100000 Mbps
passive-interface default

Highlighted
Collaborator

Yes, but it is configured in default vrf. You have to move it under "vrf PUBLIC".

Change your config from this:

router ospf 11
  default-information originate always
  vrf PUBLIC
    bfd
    router-id 10.248.65.1
    log-adjacency-changes detail
    auto-cost reference-bandwidth 100000 Mbps
    passive-interface default

to this:

router ospf 11
  vrf PUBLIC
    default-information originate always
    bfd
    router-id 10.248.65.1
    log-adjacency-changes detail
    auto-cost reference-bandwidth 100000 Mbps
    passive-interface default

Cheers,

Sergiu

View solution in original post

Highlighted

Sergiu

Thanks for the reply, this does make more sense now looking at it.

Will test this week.

 

Awesome Cheers