cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
8923
Views
0
Helpful
9
Replies
Beginner

VXLAN 1000v

Hi,

I am trying to use the nexus1000v with VXLAN as part of a vCloud Director setup, when i come to use the network pool for a VM i receive the following error on the 1000v switch.

2013 Mar 25 14:47:17.720 blob %NSMGR-3-NETWORK_CREATE_FAILED: Network 'vxw-dvs-49                                                                                      -virtualwire-4-sid-10000-dvs.VCDVSVXLAN-042f31b1-f3d4-40e3-9fdd-34bebd' creation failed with error "Failed to create bridge domain" (Additional information: Syntax error while parsing 'bridge-domain "vxw-dvs-49-virtualwire-4-sid-1

the configuration i have is aswell follows,

show feature

network-segmentation  1         enabled

port-profile type vethernet -VXLAN-A

  vmware port-group VXLAN-A

  switchport access vlan 10

  capability vxlan

  no shutdown

  state enabled

port-profile type ethernet VXLAN

  vmware port-group vxlan-uplink

  switchport mode trunk

  switchport trunk allowed vlan 10

  mtu 1660

  channel-group auto mode on sub-group cdp

  no shutdown

  system vlan 10

  state enabled

all traffic this then passed to the upstream Cisco UCS

anyone got any ideas on the error?

thanks

9 REPLIES 9
Cisco Employee

Re: VXLAN 1000v

You config is deffinitely wrong above.

For port-profile VXLAN-A add "system vlan 10"

For the uplink port-profile if you are using Cisco UCS Blades change the channel-group to

channel-group auto mode on mac-pinning

You are allowing vlan 10 on the trunk port but your system vlan is 3085 which is not allowed. You need to add vlan 3085 to the trunk allowed list and add vlan 10 to the system vlan settings.

There are some other configs on the vCloud side that you need to make sure work. First check the compatibility. Make sure the N1KV version you have is correct for the vCloud version you are trying to run. This is listed in the compatibility matrix.

On the vcloud side you need to make sure the segments are setup on the vShield Edge Manager.

Make the fixes to the above port-profiles, verify your vShield Edge and let us know what you get after that.

louis

Beginner

Re: VXLAN 1000v

yeah i have modified the vlan its all vlan 10 now.

is there a reason i cannot use channel-group auto mode on sub-group cdp with the Cisco UCS?

i am using version 4.2(1)SV2(1.1), let me check that out

Cisco Employee

Re: VXLAN 1000v

You can use it but it's not recommended. As long as you stick to just two nics one each fabric and you enable CDP on the adapters it will work, but again mac-pinning mode is recommended.

Cisco Employee

Re: VXLAN 1000v

Just to add, using "sub-group cdp" has a reliance on CDP timers... MAC pinning has no such dependecy so there's never any delay during bring up or a failover event.

Regards,

Robert

Beginner

Re: VXLAN 1000v

okay no problem, i have sorted that out, looks like my version is supported and i have followed the correct paths to enable VXLAN but i still get the same errors. not sure what is wrong at the moment

Cisco Employee

Re: VXLAN 1000v

What guide are you using to set it up?

Beginner

Re: VXLAN 1000v

hi

i am using http://www.punchingclouds.com/2012/09/09/vcloud-director-5-1-vxlan-configuration/

my nexus 1000v version is version 4.2(1)SV2(1.1) but i can see that : 4.2(1)SV1(5.2) is also out, is that the latest version of nexus 1000v

Cisco Employee

Re: VXLAN 1000v

Yeah that guide is missing some N1KV specific detail.

Look here

http://www.cisco.com/en/US/prod/collateral/switches/ps9441/ps9902/deployment_guide_c07-703595.html

and send me an email at lwatta@cisco.com and I can email you another guide as well.

louis

Highlighted
Cisco Employee

Re: VXLAN 1000v

Hi Chris,

You need to enable segmentation feature to use segment bridge domains. Please use "feature segmentation" command to enable it.

Thanks,

Naren

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards