cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
456
Views
0
Helpful
5
Replies

ApplicationPerTunnel resource properties are missing in response

shahid_jambagi
Beginner
Beginner

Hi team,

 

We were getting following properties for the ApplicationPerTunnel resource,

  1. local_system_ip  
  2. local_color 
  3. remote_system_ip
  4. remote_color 

but after the system refresh, these properties are replaced with the following,

  1. local_system_ip   à now we are getting in response as source_ip
  2. local_color à now we are getting null
  3. remote_system_ip à now we are getting in response as dest_ip
  4. remote_color à now we are getting null

are there any changes in the response or we need to take care of some settings?

 

The  API request is for your reference https://10.10.20.90:8443/dataservice/statistics/dpi

 

Please if you could help us on priority, would be really appreciated on this

5 Replies 5

bigevilbeard
Collaborator
Collaborator

@shahid_jambagi I am not following your comment "system refresh", was there an update from one version to another in that refresh?

I think there might have been some API changes on the labels, but I do not also get the null part that is breaking backwards compatibility behaviour. You did not mention the SD-WAN version here, i have presumed given the IP address this is the devnet sandbox, is this the 19.2 or 20.4 version of the sandbox and are you comparing a devnet sandbox version to one which you have in another environment?

Thanks for reply,

We are using devnet sandbox (Cisco SD-WAN)19.2 version.

 

>>>>"system refresh", was there an update from one version to another in that refresh?

No, the version was same 19.2.

In October 2021 timeframe the system was not working for couple of days and later it was restored, since then we are  facing this.

 

The  API request is for your reference https://10.10.20.90:8443/dataservice/statistics/dpi

is this api request changed or it is same ?

 

Also if you could help us to know how to get for ApplicationPerTunnel resource the following properties ?

 

  1. local_system_ip  
  2. local_color 
  3. remote_system_ip
  4. remote_color 

Thanks once again for your help.

@shahid_jambagi i am not aware of any change to the 19.2 SD-WAN sandbox, which would cause the issue you have reported. I would suggest to tests your code on the newer 20.4 version  here --> https://devnetsandbox.cisco.com/RM/Diagram/Index/4a0f4308-1fc4-4f4c-ae8c-2734f705bd21?diagramType=Topology

 

 

I see in the API documentation for 20.4 https://developer.cisco.com/docs/sdwan/#!sd-wan-vmanage-v20-4 that the API call is supported /dataservice/statistics/dpi and the following results from this (if the correct policy are set up) should yield the following details from a GET request

 

{
  "data": [
    {
      "remote_color": "3g",
      "fec_re": 0,
      "vqoe_score": 10,
      "device_model": "vedge-cloud",
      "latency": 1,
      "tx_octets": 0,
      "dst_ip": "10.0.101.2",
      "local_color": "lte",
      "src_ip": "10.1.14.14",
      "sla_class_names": "None",
      "loss": 0,
      "total": 600,
      "tx_pkts": 0,
      "fec_tx": 0,
      "rx_octets": 0,
      "statcycletime": 1589075400056,
      "state": "Up",
      "local_system_ip": "172.16.255.14",
      "tenant": "default",
      "entry_time": 1589073792008,
      "loss_percentage": 0,
      "rx_pkts": 0,
      "vmanage_system_ip": "172.16.255.14",
      "fec_rx": 0,
      "src_port": 12380,
      "jitter": 1,
      "remote_system_ip": "172.16.255.11",
      "vdevice_name": "172.16.255.14",
      "proto": "IPSEC",
      "vip_idx": 190,
      "dst_port": 12366,
      "name": "172.16.255.14:lte-172.16.255.11:3g",
      "sla_class_list": "0",
      "tunnel_color": "3g:lte",
      "host_name": "vm4",
      "id": "4OBG_HEB_JLsavezVUfr"
    }
  ]
}
Example Description

 

 

Thanks for your update.

 The properties/fileds/parameter we are looking for,

  1. local_system_ip  
  2. local_color 
  3. remote_system_ip
  4. remote_color 

how to enable the application data in response or in Cisco dash ?

what we have done to enable the application data, apart from these do anything else need to be taken care off ? please suggest.

  1. logged in to cisco, 
  2. navigate to Configuration -Template - select the devices
  3. enabled the app visibility under policies 

after 30 mins the data was listed.

 

 Using the API call /dataservice/statistics/dpi able to get the response following response, 

 SD-WAN 19.2

No fields are listed in the response, we were getting the values in previous SD-WAN 19.2 version.

{"ip_proto":17,"device_model":"vedge-CSR-1000v","pkt_dup_r_pkts":0,"device_family":"network-service","fec_d_pkts":0,"packets":106,"source_ip":"0.0.0.0","flow_id":9223372036854776000,"statcycletime":1644565200066,"source_port":68,"octets":34768,"tenant":"default","dest_port":67,"entry_time":1644564420058,"create_time":1644564359451,"device_application":"dhcp","vip_time":1644564420058,"end_time":1644564419517,"expire_time":1644564419517,"vmanage_system_ip":"10.10.1.13","start_time":1644564359451,"application":"dhcp","vdevice_name":"10.10.1.13","dest_ip":"255.255.255.255","vip_idx":65,"family":"network-service","fec_r_pkts":0,"host_name":"site1-cedge01","vpn_id":1,"id":"AX7nuXzDGQ-SzMBrUhFr"}


SD-WAN 20.4

the said properties were listed but with blank values except local_color

{"ip_proto":17,"tunnel_id":507,"remote_color":"-","device_model":"vedge-cloud","pkt_dup_r_pkts":0,"device_family":"Network Service","fec_d_pkts":0,"tcp_opt":"-","packets":4,"source_ip":"10.10.24.11","local_color":"dia","ssl_de":0,"flow_id":507,"statcycletime":1644565200278,"source_port":33750,"octets":284,"local_system_ip":"-","tunnel_type":"Local","tenant":"default","dest_port":53,"entry_time":1644564476215,"tunnel_encap":"-","create_time":1644564383000,"pkt_dup_tunnel":"-","device_application":"dns","vip_time":1644564476215,"end_time":1644564468000,"expire_time":1644564468000,"vmanage_system_ip":"10.10.1.17","appqoe_type":"-","ssl_pkt":0,"start_time":1644564383000,"application":"dns","remote_system_ip":"-","vdevice_name":"10.10.1.17","dest_ip":"10.17.248.11","vip_idx":507,"ssl_en":0,"family":"network-service","fec_r_pkts":0,"pkt_dup_d_pkts":0,"host_name":"site3-vedge01","vpn_id":1,"id":"AX7nuX4eITAI5xezsOyC"}

 

 why these fields are blank? "local_system_ip":"- , "remote_system_ip":"-, "remote_color":"-",.

Please, if you could suggest how to get values for these fields.

 

@shahid_jambagithank you for an update in the dissimilarity between versions, there is no changelog

for this version, the SD-WAN API team have committed to creating an API Changelog starting with vManage 20.9.

.

Here is the CVD: https://www.cisco.com/c/dam/en/us/td/docs/solutions/CVD/SDWAN/CVD-SD-WAN-Design-2018OCT.pdf

 

I did find this guide for you

 

https://www.cisco.com/c/en/us/td/docs/solutions/CVD/SDWAN/cisco-sdwan-application-aware-routing-deploy-guide.html

 

For support in the configuration of SD-WAN suggest posting the question to the following forum/location https://community.cisco.com/t5/sd-wan-and-cloud-networking/bd-p/discussions-sd-wan 

 

Hope this helps!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers