ANNOUNCEMENT - The community will be down for maintenace this Thursday August 13 from 12:00 AM PT to 02:00 AM PT. As a precaution save your work.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Updates to Sandbox Reservation Internet Access Policy

Due to changes in our networking policies, we are updating the internet access policy within our sandbox reservation instances.
Hosts will no longer have internet access outbound.
This should not affect the overall functionality or access to the resources within the sandbox instances, connecting via VPN.

Keep Innovating!

DevNet Sandbox Team

600
Views
0
Helpful
7
Replies
Highlighted
Beginner

INTERNET is not working while VPN is ON

Hi

 

I just installed Cisco AnyConnnect Mobile Secure Client. I successfully connected to my reserved sandbox lab using VPN. While connected to the VIRL sandbox, I can not connect to the internet or to any device in my home LAN. I can only connect to the internet after stopping the VPN connection to the sandbox.

 

I am using a wireless laptop with windows 10.

 

Can anybody help with this?

 

 

 

 

Everyone's tags (1)
7 REPLIES 7
Highlighted
VIP Advisor

Re: INTERNET is not working while VPN is ON

Hi there,

Sounds like the VPN is not using a split-tunnel configuration, ie all traffic is being sent down the VPN. It is however unusually that you cannot reach your local subnet....how does your device reach the local gateway to maintain the tunnel??!

 

Can you share your routing table whilst connected?>

route -n PRINT

 

cheers,

Seb.

Highlighted
Beginner

Re: INTERNET is not working while VPN is ON


@Seb Rupik wrote:

Hi there,

Sounds like the VPN is not using a split-tunnel configuration, ie all traffic is being sent down the VPN. It is however unusually that you cannot reach your local subnet....how does your device reach the local gateway to maintain the tunnel??!

 

Can you share your routing table whilst connected?>

route -n PRINT

 

cheers,

Seb.


Thanks Seb,

 

I actually can connect to devices on my home lan but not to the internet. Below is the information you requested:

 

C:\>route PRINT
===========================================================================
Interface List
12...00 05 9a 3c 7a 00 ......Cisco AnyConnect Secure Mobility Client Virtual Miniport Adapter for Windows x64
18...3c 97 0e a7 72 62 ......Intel(R) 82579LM Gigabit Network Connection
21...6c 88 14 bc be 45 ......Microsoft Wi-Fi Direct Virtual Adapter
10...6e 88 14 bc be 44 ......Microsoft Wi-Fi Direct Virtual Adapter #2
11...00 50 56 c0 00 01 ......VMware Virtual Ethernet Adapter for VMnet1
3...00 50 56 c0 00 08 ......VMware Virtual Ethernet Adapter for VMnet8
13...6c 88 14 bc be 44 ......Intel(R) Centrino(R) Advanced-N 6205
20...f8 2f a8 e3 4b 14 ......Bluetooth Device (Personal Area Network)
1...........................Software Loopback Interface 1
===========================================================================

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 192.168.0.1 192.168.0.51 40
10.10.10.0 255.255.255.0 192.168.128.2 192.168.128.1 2
10.10.20.0 255.255.255.0 192.168.128.2 192.168.128.1 2
10.10.20.100 255.255.255.255 192.168.128.2 192.168.128.1 2
127.0.0.0 255.0.0.0 On-link 127.0.0.1 331
127.0.0.1 255.255.255.255 On-link 127.0.0.1 331
127.255.255.255 255.255.255.255 On-link 127.0.0.1 331
128.107.93.228 255.255.255.255 192.168.0.1 192.168.0.51 41
172.16.30.0 255.255.255.0 192.168.128.2 192.168.128.1 2
192.168.0.0 255.255.255.0 On-link 192.168.0.51 296
192.168.0.1 255.255.255.255 On-link 192.168.0.51 41
192.168.0.51 255.255.255.255 On-link 192.168.0.51 296
192.168.0.255 255.255.255.255 On-link 192.168.0.51 296
192.168.28.0 255.255.255.0 On-link 192.168.28.1 291
192.168.28.1 255.255.255.255 On-link 192.168.28.1 291
192.168.28.255 255.255.255.255 On-link 192.168.28.1 291
192.168.116.0 255.255.255.0 On-link 192.168.116.1 291
192.168.116.1 255.255.255.255 On-link 192.168.116.1 291
192.168.116.255 255.255.255.255 On-link 192.168.116.1 291
192.168.128.0 255.255.255.0 On-link 192.168.128.1 257
192.168.128.0 255.255.255.0 192.168.128.2 192.168.128.1 2
192.168.128.1 255.255.255.255 On-link 192.168.128.1 257
192.168.128.255 255.255.255.255 On-link 192.168.128.1 257
224.0.0.0 240.0.0.0 On-link 127.0.0.1 331
224.0.0.0 240.0.0.0 On-link 192.168.28.1 291
224.0.0.0 240.0.0.0 On-link 192.168.116.1 291
224.0.0.0 240.0.0.0 On-link 192.168.0.51 296
224.0.0.0 240.0.0.0 On-link 192.168.128.1 10000
255.255.255.255 255.255.255.255 On-link 127.0.0.1 331
255.255.255.255 255.255.255.255 On-link 192.168.28.1 291
255.255.255.255 255.255.255.255 On-link 192.168.116.1 291
255.255.255.255 255.255.255.255 On-link 192.168.0.51 296
255.255.255.255 255.255.255.255 On-link 192.168.128.1 10000
===========================================================================
Persistent Routes:
None

IPv6 Route Table
===========================================================================
Active Routes:
If Metric Network Destination Gateway
13 296 ::/0 fe80::4eed:fbff:fe7b:5250
12 26 ::/0 On-link
1 331 ::1/128 On-link
13 296 2601:241:301:689a::/64 On-link
12 26 2601:241:301:689a::/64 On-link
13 296 2601:241:301:689a:2819:5cee:ecbe:44eb/128
On-link
13 296 2601:241:301:689a:7532:a003:d59f:6ff7/128
On-link
11 291 fe80::/64 On-link
3 291 fe80::/64 On-link
13 296 fe80::/64 On-link
12 26 fe80::/64 On-link
11 291 fe80::1d7a:22c9:1a7b:2618/128
On-link
12 281 fe80::2bd5:3f19:252c:8de5/128
On-link
3 291 fe80::5cba:d88a:eabc:155/128
On-link
13 296 fe80::7532:a003:d59f:6ff7/128
On-link
12 281 fe80::b42a:17a5:c35e:5179/128
On-link
1 331 ff00::/8 On-link
11 291 ff00::/8 On-link
3 291 ff00::/8 On-link
13 296 ff00::/8 On-link
===========================================================================
Persistent Routes:
None

C:\>

Highlighted
Beginner

Re: INTERNET is not working while VPN is ON

BTW,

My laptop ip address is 192.168.0.51 and my home router's ip address (the default gateway) is 192.168.0.1. The first entry in the ipv4 section of output of the "route print" command.

 

Highlighted
VIP Advisor

Re: INTERNET is not working while VPN is ON

Is the AnyConnect VPN connected when you gathered that output?

I would have expected to see two default routes, the one going via the VPN would have a lower metric.

 

cheers,

Seb.

Highlighted
Beginner

Re: INTERNET is not working while VPN is ON

Yes. And I checked it again. Me too was looking for another default route. Is there a solution for this? both for ipv4 and ipv6?
Highlighted
VIP Advisor

Re: INTERNET is not working while VPN is ON

Double click on the AnyConnect icon in the system tray. Click the 'cog' bottom left, select 'VPN' and then the 'Route details' tab.  What does it show?

Highlighted
Beginner

Re: INTERNET is not working while VPN is ON

cisco-anyconnect-route-details.PNG

Content for Community-Ad
Cisco Community July 2020 Spotlight Award Winners