i have a Cisco 4451 with 2 isp, i have setup the static routes the main one tracking the the ip sla , the main connection its fiber optic based, but when we have a broken link the traffic doesnt go to the backup route, only if we disconnect the ethernet cable it goes to the back up link this is the main lines for the config
track 1 ip sla 1 reachability
interface GigabitEthernet0/0/0
description ISP Telmex
ip address 192.168.10.5 255.255.255.0
ip nat outside
negotiation auto
ip virtual-reassembly
!
interface GigabitEthernet0/0/1
description ISP Starlink
ip address 100.115.4.32 255.192.0.0
ip nat outside
media-type rj45
negotiation auto
no cdp enable
ip virtual-reassembly
!
interface GigabitEthernet0/0/3
description LAN
no ip address
media-type sfp
negotiation auto
!
interface GigabitEthernet0/0/3.1
description Data
encapsulation dot1Q 1 native
ip address 10.0.1.1 255.255.255.0
ip nat inside
no cdp enable
!
ip nat inside source route-map Starlink interface GigabitEthernet0/0/1 overload
ip nat inside source route-map Telmex interface GigabitEthernet0/0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.10.254 track 1
ip route 0.0.0.0 0.0.0.0 100.64.0.1 10
ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet0/0/0
frequency 5
ip sla schedule 1 life forever start-time now
access-list 10 permit any
!
!
route-map Telmex permit 10
match ip address 10
match interface GigabitEthernet0/0/0
!
route-map Starlink permit 10
match ip address 10
match interface GigabitEthernet0/0/1
!