cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
3093
Visitas
10
ÚTIL
9
Respuestas

Internet Protocol (IP) Multicast: Fundamentos y mejores prácticas. Pregunte al experto

Cisco Moderador
Community Manager
Community Manager

con Enrique Dávila

Lea la biografía

Durante este evento en vivo, el experto Enrique Dávila explicará porqué es necesario utilizar multicast, fundamentos de multicast, multicast en la red (PIM dense mode, sparse mode, Bidirectional PIM, static RP, auto RP, bootsrap router y SSM), multicast en capa 2 (IGMP y IGMP snooping).

Enrique actualmente colabora en Cisco como Technical Leader en el  grupo de Technical Services soportando a clientes de Latinoamérica en  TAC y HTTS, lleva laborando 7 años en Cisco iniciando como ingeniero de  TAC, su experiencia ha sido con proveedores de servicio utilizando  tecnologías de Routing/Switching y MPLS. Dávila estudió ingeniería  electrónica y comunicaciones en el Tecnológico de Monterrey Campus  Estado de México y cuenta con la certificación de CCIE en Routing y  Switching, Service Provider y Seguridad #17448, así como la  certificación en ITIL.

Por favor use las estrellas para calificar las respuestas e indique si la respuesta que ha recibido es la corrrecta.

Puede ser que Enrique no pueda  responder cada una de las preguntas debido la cantidad que     anticipamos  para este evento. Recuerde que usted puede preguntar o     seguir haciendo  preguntas en la comunidad de Routing & Switching

Este evento estará disponible del martes 24 de Septiembre al viernes 4 de octubre del 2013.

9 RESPUESTAS 9

Rolf Fischer
Engager
Engager

Hola, Enrique:

No soy hablante nativo pero me gustaría aprovechar esa oportunidad.

Tengo una pregunta sobre IGMP snooping y las pataformas Catalyst y Nexus:

Por defecto IGMP snooping está encendido, pero para su funcionamiento es obligario tener al menos un mrouter puerto, que requiere configuración adicional.

Parece que sin un mrouter puerto, tráfico destinado a la dirección IEEE-multicast (01:00:5e) se desborde hacia todos los puertos, así como broadcast o non-IEEE multicast (por lo menos con las plataformas 2k/3k).

En otras palabras: Sin un mrouter puerto, IGMP snooping no afecta al switch local?

Respecto de esto, hay diferencias entre los plataformas/sístemas operativos?

Muchas gracias,

Rolf

Que tal Rolf,

Si nosotros tenemos una topología de capa 2 con más de un switch definitivamente vamos a necesitar un mrouter, la razón es la siguiente:

Imaginemos que tenemos esta topología:

Fuente224.1.1.1

     |

   SW1---Trunk----SW2

     |                          |

Receptor1          Receptor2

En este escenario ambos recepetores quieren escuchar tráfico de multicast del grupo 224.1.1.1, por lo tanto enviarían un join "membership report" para unirse al grupo 224.1.1.1 y veríamos los siguientes pasos:

1. Recpetor 1 envía el membership report y el SW1 con IGMP snooping indentifica que el host quiere escuchar el grupo 224.1.1.1, hace el mapeo a la dirección MAC de multicast y la instala de esta manera comienza a recibir el tráfico de multicast.

2. Recpetor 2 envía el membership report y el SW2 con IGMP snooping identifica que quiere escuchar el grupo y de la misma manera hace el mapeo a la dirección MAC multicast, sin embargo, ese IGMP report lo absorbe el SW2 y no lo recibe SW1 por el trunk, por lo tanto jamás sabe que hay un receptor interesado en escuchar el tráfico para instalarlo en la tronca y conmutar el tráfico correspondiente a la dirección MAC multicast de ese grupo.

Es por esta razón que el mrouter port es sumamente importante, igmp snooping hará el Relay de los IGMP reports en los mrouter ports, por lo tanto, en esta topología nuestro mrouter port debe de ser la troncal para que propagara el igmp membership report y por igmp snooping el SW1 haga el mismo mapeo.

Lo switches escuchan silenciosamente mensajes de PIM para declarar sus mrouter ports, existen opciones para tener workarounds cuando no se tiene un router que haga esta notiifación, como puede ser con "igmp snooping querier", hacer el mapeo estático, etc, la operación correcta será siempre teniendo el mrouter. En el siguiente link vienen estos escenarios si tienes dudas avísame y podemos aclarar culquier pregunta que tengas.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a008059a9df.shtml

Saludos,

Enrique

brauliocifuentes
Beginner
Beginner

Hola Enrique,

Quiero preguntar y plantear lo siguiente: tengo una red IP/MPLS TE con túneles creados reservando un ancho de banda para datos y otros para telefonía, ahora bien quiero pasar TV digital (Multicast) por el túnel de datos y a su vez aplicar QoS para este multicast diferenciandolo del resto (Internet), es posible lograr hacer esta diferenciación del multicast? Qué documentación puede ayudarme para evaluar las alternativas q tengo?

Saludos

Buenas tardes Braulio,

Para poder dar más detalles sobre tu pregunta, es  importante entender que la solución que tienes actualmente con base a la  descripción es MPLS TE el cual únicamente está implementado para  conmutar paquetes Unicast, en este caso no podrías utilizar esos túneles  para conmutar tráfico de multicast.

Existen algunas opciones para hacerlo en una red MPLS que podrían ser las siguientes:

1.  MVPN (Multicast VPN) - Esto es si tu tráfico de multicast está en una  VRF en particular, en este escenario, el tráfico no es etiquetado por  MPLS, viaja dentro del CORE con IP puro y creas un árbol de default MDT  para señalizar y después se crea un árbol para datos, aquí pueden  existir sus excepciones pero en términos generales así funcionaría.

http://www.cisco.com/en/US/partner/docs/ios-xml/ios/ipmulti_mvpn/configuration/12-2sy/imc_cfg_mc_vpn.html

2.  MLDP BASED MVPN habilitando MLDP, aquí el tráfico de multicast ya sería  etiquetado y MLDP permite crear LSPs punto multipunto o  multipunto-multipunto.

http://www.cisco.com/en/US/partner/products/ps11505/products_ios_protocol_group_home.html

http://www.cisco.com/en/US/partner/docs/ios-xml/ios/ipmulti_lsm/configuration/15-s/imc_mldp-based_mvpn.html

3.  Crear túneles de Traffic Engineering punto-multipunto, si lo que buscas  es mantener las ventajas que te da TE en MPLS, esta sería tu opción,

http://www.cisco.com/en/US/partner/docs/ios/mpls/configuration/guide/mp_te_p2mp.html

Dependinedo el diseño en particular que busques deberás considerar las restricciones que existen en cada una de las soluciones.

Incluí algunos links que pueden ser de ayuda y si hay algo más en lo que pueda ayduarte házmelo saber.

Saludos,

Enrique

nefer_junior
Beginner
Beginner

buenas

tengo  problemas para darle haceso a internet a unas vlan, tengo un switch sg  300 layer 3 (capa3) esta es la configuracion que estoy haciendo

Switch#configure terminalEnter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface Vlan 20
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#no shutdown

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z. Switch(config)#interface Vlan 10
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#no shutdown
configure la interface 1 para que tuviera haceso al router
Switch(config)#interface GigabitEthernet 1
Switch(config-if)#no switchport access vlan
Switch(config-if)#ip address 192.168.80.100 255.255.255.0 <- ip que da el router Switch(config-if)#no shutdown

Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.80.1 <- ip del router
como le pongo internet a las vlan ?


le agradeseria la ayuda 

Hola Nefer

Una consultar en el router colocaste la ruta estatica hacia las redes

192.168.20.0/24 y 192.168.10.0 
¿Como has hecho el NAT en el router?

Rudy Carlos

Rudy carlos gracias por responder

pues es que cuando ingreso al pc a la vlan 10 no puedo hacer le ping al router y cuando entro al router no puedo hacer ping a la vlan

Rob_informatica
Beginner
Beginner

Buenos dias tengo una consulta.

Resetee mi consola ASA 5510, ahora no tengo acceso a mi consola, ni pregunta es la siguiente.

Como puedo acceder al ASA 5510 si no me asigna una ip para poder configurarla.

Este Ask the expert fue creado para Multicast entonces tratemos de crear estas preguntas en otra área.

Ahora con respecto a tu ASA:

Si el ASA esta configurado por defecto, conectate a la interface managment 0/0 y asigna a tu PC una IP en el rango 192.168.1.0/24.

Posteriormente trata de conectarte via ASDM (HTTPS) al ASA a la IP192.168.1.1

https://192.168.1.1/admin

Saludos desde Costa Rica

Recuerda subscribirte a mi website para  recibir información semanal de networking en http://laguiadelnetworking.com

Any question contact me at jcarvaja@laguiadelnetworking.com

Cheers,

Julio Carvajal Segura

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
Vamos a comenzar

¡Conecte con otros expertos de Cisco y del mundo! Encuentre soluciones a sus problemas técnicos o comerciales, y aprenda compartiendo experiencias.

Queremos que su experiencia sea grata, le compartimos algunos links que le ayudarán a familiarizarse con la Comunidad de Cisco:

Reconozca a un colega