cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
331
Visitas
20
ÚTIL
8
Respuestas

Perdida de comunicacion entre switch catalys y Meraki

Ivan Garcia
Beginner
Beginner

Buenas tardes comunidad:

Recientemente ha surgido un problema en una LAN el cual ha sido cambiado de equipamiento de cisco catalyst a meraki, sin embargo aun quedan algunos switches catalyst en algunos ambientes, el problema es que el switch catalys pierde comunicacion constantemente, ocasionando lentitud e intermitencia a los usuarios que se encuentran conectados. Revisando los logs aprecio lo siguiente:

Imagen.jpg

 como se observa se visualiza un problema de flapping por mac entre el Fa0/20 , Fa0/47 y el Gi0/1

fa0/47 puerto de acceso (conectado un hub, se visualiza 6 macs)
fa0/20 puerto de acceso (conectado un hub, se visualiza 4 macs)
Gi0/1 puerto trunk (conectado al switch core meraki)

Agradeceria me puedan brindar ideas de como poder mitigar este problema.

Gracias de antemano.

Saludos,

Ivan

 

8 RESPUESTAS 8

Mauricio Martinez
Cisco Employee
Cisco Employee

Hola! Recomendaría marcar por teléfono a soporte Meraki para que te auxilien. Es válido pedir apoyo con este tipo de configuración. La cosas sencillamente deben de funcionar bien. Meraki con catalyst, o cualquier otro switch.

Puede que sea un tema de protocolos de spanning tree y su interoperabilidad. Primero, vería eso a fondo. En Meraki switches (todos excepto MS390) corren RTSP, puertos en troncal, todas las vlan, nativa 1. Se sugiere que sí exista la van 1 en todos los otros switches, y que la van nativa sea la misma en todos lados. En el mejor de los casos, hacer que todo esté en MSTP, zona 0. Los BPDU's viajan en VLAN1, y luego hay temas cuando eso no está bien emparejado.

https://documentation.meraki.com/MS/Deployment_Guides/Advanced_MS_Setup_Guide 

https://documentation.meraki.com/MS/Port_and_VLAN_Configuration/Recommended_Configuration_for_Trunk_Link_to_Non-Meraki_Switches 

PD....para los exploradores: Cómo subir a la nube de meraki algunos modelos de catalyst, para monitoreo: https://documentation.meraki.com/Cloud_Monitoring_for_Catalyst 

Gracias por aclarar la duda, por compartir pasos y contenido relevante Mauricio 

Esperamos la información sea de ayuda Ivan 

Muchas gracias por la respues @Mauricio Martinez  actualmente ya no han vuelto aparecer los logs por STP ni por MACFLAP, sin embargo aun pierdo comunicacion en el switch Catalyst, podria ser un problema a nivel de capa fisica?. El enlace entre dichos switches es por FO.

Gracias Iván! No dudes en hablar a Meraki soporte para que te apoyen en el momento.

Por otro lado, asegúrate de eso que te comento y que viene en nuestras guías: que exista la VLAN 1 en todos lados, y por otro lado que la que sea la VLAN nativa sea la misma en todos lados en esa LAN. Claro que también ayuda el saber cuál de los switches en esa LAN es el root, para no dejar eso al algoritmo de STP, que lo mejor es determinismo por diseño. los BPDU's, que es la info que se usa para correr el SPT, corre en la VLAN1 en los catalyst.

 

stp.jpg

Javier Acuña
VIP Advocate VIP Advocate
VIP Advocate

Saludos @Ivan Garcia Gracias por comunicarte con la comunidad de cisco a continuación la siguiente interrogante:

  1. Anteriormente funcionaba sin problemas.

Al parecer tienes un bloqueo de spaningtree por inconsistencia en tipo de puerto, se recomienda revisar la configuración de los puertos  y verificar los root de la vlan y tener presente el bloque de la vlan uno y los posibles camino de bloqueos.

comienza validando su hubo un cambio de camino. 

 

recuerda es importante que apoyes a los expertos con un like.

Hola @Javier Acuña  muchas gracias por la respuesta, ya no me han vuelto aparecer logs de STP o de flapping en los logs, sin embargo aun sigo perdiendo comunicacion del lado del switch catalyst. Por lo que podria ser un problema a nivel de capa fisica?. El enlace entre el switch catalyst y el Meraki es por FO.

Puede estar en los caminos de Spaningtree. valida los cambios a nivel del sw 

Julio E. Moisa
VIP Mentor VIP Mentor
VIP Mentor

Hola,

Revisa bien si mantienes las mismas instancias de spanning tree, por ahi puede andar el problema. Por lo general son compatibles sin problemas. Revisa la configuracion. 

Saludos 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Vamos a comenzar

¡Conecte con otros expertos de Cisco y del mundo! Encuentre soluciones a sus problemas técnicos o comerciales, y aprenda compartiendo experiencias.

Queremos que su experiencia sea grata, le compartimos algunos links que le ayudarán a familiarizarse con la Comunidad de Cisco: