cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
1174
Visitas
15
ÚTIL
7
Respuestas
camilonieto19116
Beginner

PROBLEMA MENSAJE CONSTANTE SWITCH CISCO CATALYST 3750G

Hola que tal estimado, esta es mi primera pregunta dentro del foro, tengo un SWICHT modelo Catalys 3750G que en todo momento lanza un mensaje MACFLAP_NOTIF: host xxxx.xxxx.xxxx in vlan 20 is flapping between port Gi1/0/8 and port Gi1/0/7, les comento que tengo dos servidores abajo de este Switch y cada servidor tiene cuatro entradas de red con la misma entrada de red (como un balanceo de carga) agradeceria su ayuda en este problema.

7 RESPUESTAS 7
luis_cordova
VIP Advisor

Hola @camilonieto19116 ,

 

El flapeo de mac es síntoma de problemas de loop de capa 2.

Por ello, te sugiero verificar las configuraciones de STP y de los PortChannel que conecta tu switch con los servidores.

 

Saludos

Hola @luis_cordova 

Gracias por el consejo para @camilonieto19116 

Edwin Portillo
Collaborator

Bienvenido @camilonieto19116,

que mejor iniciar con pie derecho uniendote a la comunidad. La notificación se debe a que existe un comportamiento anormal probablemente con el uso del Spanning-Tree Protocol en temas de redundacia con los equipos que tienes, verifica que tengas correctamente las interfaces de acceso y troncales en el switch, cables conectados donde se debe y de eso dependera los dispositivos que conectes, puedes revisar cada una de las instancias que maneja el protocolo de expansion relacionada a cada VLAN y verificar cual es la direccion MAC que esta haciendo Flapping.

Podrias compartir la topologia como la tienes distribuida y los errores generados para hacer más transparente el apoyo.

Saludos.

Esta es la configuracion que tengo en el Switch:

 

Current configuration : 4682 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sw-core
!
boot-start-marker
boot-end-marker
!
!
username apreser privilege 15 password 0 apreser
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ps
system mtu routing 1500
ip domain-name apreser.cl

!
crypto pki trustpoint TP-self-signed-717453568
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-717453568
revocation-check none
rsakeypair TP-self-signed-717453568
!
!
crypto pki certificate chain TP-self-signed-717453568
certificate self-signed 01
30820248 308201B1 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 37313734 35333536 38301E17 0D393330 33303130 30303234
305A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3731 37343533
35363830 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
D9C57095 A77DF613 8FF3C16C 4C4F418D B6C58A55 F25FB4C8 5E2D84A8 9A48EC0C
26321AB2 FA91F09D 12FC72FA 316ED7F9 4743DC83 94CCC82E 90837D66 FE7F5501
00F694F6 456D4A36 5A430B97 AACC4BBC ED913FD1 16E05C61 DE7EA036 0ACED2F2
4F8406A4 978FEED2 91513E66 53C6BF55 D2B455B7 6B3AC659 CC9F0A5E E4139641
02030100 01A37230 70300F06 03551D13 0101FF04 05300301 01FF301D 0603551D
11041630 14821273 772D636F 72652E61 70726573 65722E63 6C301F06 03551D23
04183016 80148B47 142CF385 7BFF45B8 15806B0E EB59D403 6E8A301D 0603551D
0E041604 148B4714 2CF3857B FF45B815 806B0EEB 59D4036E 8A300D06 092A8648
86F70D01 01040500 03818100 49F64737 F56106FC 877BDAFB 0CDE0060 306A5EFA
0F1559FF C09DD1A7 ABAD53DB E8914723 55F3253E C64EB5EB 21787698 43837855
0801B175 22272477 E3EB465F D09CCF3C 3B6EE7B3 7F683720 0A453344 B5EF1402
EBD54AEA E4DAA415 CDC59C2D 2B00D154 6D9212F6 C549F443 07B0884F E74C19AD
38F71390 F47A76F8 6AC94135
quit
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip ssh time-out 30
ip ssh version 2
!
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-4000
switchport mode trunk
!
interface GigabitEthernet1/0/2
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/3
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/4
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/5
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/6
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/7
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/8
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/9
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/10
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/11
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/12
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/13
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/14
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/15
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/16
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/17
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/18
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/19
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/20
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/21
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/22
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet1/0/23
switchport access vlan 21
switchport mode access
!
interface GigabitEthernet1/0/24
switchport access vlan 21
switchport mode access
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.10.3 255.255.255.0
!
ip default-gateway 192.168.10.1
ip classless
ip http server
ip http secure-server
!
ip sla enable reaction-alerts
!
!
line con 0
line vty 0 4
login local
transport input ssh
line vty 5 15
login
!
end

 

Hola @camilonieto19116 


Podrías indicar que está conectado a los puertos que indican problemas(g1/0/7 y g1/0/8)?

A qué dispositivo corresponde la mac con problemas?

Solo estas puertas presentan problemas?

Como están conectados los servidores al switch?

Como están configurados los puertos de los servidores?

Posiblemente, puedas encontrar la solución en la verificación de estas configuraciones.

 

Saludos

Hola @camilonieto19116 

 

No creo que sea un tema de SPT como comentan, debes de revisar la configuración de su servidor, pareciera que la misma MAC estuviera en dos VLANs diferentes, no sé si tu servidor crea una mac address por entrada. pero me suena a que el problema puede ser por ahí.

Espero que la información haya sido útil y si no tienes más preguntas recuerda cerrar el topic, seleccionando la respuesta como "Respuesta correcta"

**Please rate the answer if this information was useful***

**Por favor si la información fue util marca esta respuesta como correcta**

*Tu reconocimiento nos alienta a seguir participando en los foros *

 
Espero que la información haya sido útil y si no tienes más preguntas recuerda cerrar el topic, seleccionando la respuesta como "Respuesta correcta"
**Please rate the answer if this information was useful***
**Por favor si la información fue util marca esta respuesta como correcta**
Alfredo Elias
Beginner

@camilonieto19116 

 

Por lo que entiendo el mensaje que te aparece es el siguiente

%SW_MATM-4-MACFLAP_NOTIF: Host 0015.2bd6.2020 in vlan 20 is flapping between port Gi1/0/8 and port Gi1/0/7 efectivamente tienes un loop de capa 2 

Una de las primeras cosas que debes identificar es la mac address que ocasiona el loop en google puedes colocar mac vendor y allí buscar cual dispositivo asociado a la mac address es.

Una vez identificado el origen del loop puedes tomar la desicion de apagar el puerto o verificar la configuración de los puertos 

Si lo que colocas en los puertos Gi1/0/8 and port Gi1/0/7 son servidores te recomiendo que los configures de la siguiente manera ya que no necesitan realizar el procedo de descubrimiento si es un switch o pc que se conecta.

 

 

interface GigabitEthernet1/0/7
switchport access vlan 20
switchport mode access

spanning-tree portfast

 

interface GigabitEthernet1/0/8

switchport access vlan 20
switchport mode access

spanning-tree portfast

 

Espero que mi respuesta se ha de utilidad.

 

 

Crear
Reconozca a un colega
Content for Community-Ad