cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
1186
Visitas
25
ÚTIL
14
Respuestas

Qos en 3850

QoS en 3850

Switch Ports Model SW Version SW Image Mode
------ ----- ----- ---------- ---------- ----
* 1 32 WS-C3850-24T 16.9.2 CAT3K_CAA-UNIVERSALK9 BUNDLE


Estoy configurando QoS para distintos servicios, entre ellos ftp, mi configuracion es la siguiente, luego de aplicarla me aparece el siguiente mensaje:
Invalid queuing class-map!!! Queuing actions supported only with dscp/cos/qos-group/precedence/exp based classification!!!

 

Esta es mi configuración inicial:

 

ip access-list extended 2101
permit tcp any any eq 21
permit tcp any any range 65000 65300

class-map match-any FTP
match access-group 2101
match protocol ftp
match ip dscp cs3

policy-map QoS-rise
class FTP
bandwidth percent 30
set dscp cs3

interface gigabitethernet 1/0/9
service-policy output QoS-rise

 

Alguna idea? alguien que me pueda ayudar?

14 RESPUESTAS 14
luis_cordova
VIP Advisor
Julio E. Moisa
VIP Mentor

Hola,

Consulta, podria ser un typo, pero porque deseas que el trafico que coincida con CS3 (class-map) le sea aplicado CS3 (policy-map). 

Intenta separar la clasificacion en diferentes clases, no todo en una solo class-map. O agrupar en una sola clase los valores de CoS y/o DSCP. 

 

Saludos 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Por un lado creo la lista de acceso asociada a los puertos ocupados por el servicio FTP, luego creo la clase para hacer match con la ACL y marcar el trafico con dscp cs3 como critico (ya que es sumamente importante este servicio), luego la política y dentro la clase FTP asignar un porcentaje del 30% del AB...asigno un set para el dscp cs3 para finalmente asignar la política a la interfaz...

Favor si me puedas ayudar o corregir en algo.

Intenta con:

ip access-list extended FTP
permit tcp any any eq 21

permit tcp any any eq 20 

 

ip access-list extended RANDOM-PORTS
permit tcp any any range 65000 65300

 

class-map match-any FTP
match access-group FTP

o
match protocol ftp



class-map match-any RANDOM-PORTS

match access-group RANDOM-PORTS

class-map match-any CALL-SIGNALLING

match dscp cs3

 

 

policy-map QoS-rise
      class FTP
      bandwidth percent 30
      set dscp cs3

 

      class RANDOM-PORTS

      bandwidth percent 30

      set dscp cs3

 

      class CALL-SIGNALING

      bandwidth percent 30

 

interface gigabitethernet 1/0/9
service-policy output QoS-rise




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

intente tal cual me lo indicaste y me sigue apareciendo el mensaje...

Switch(config-if)#ip access-list extended FTP
Switch(config-ext-nacl)#permit tcp any any eq 21
Switch(config-ext-nacl)#permit tcp any any eq 20
Switch(config-ext-nacl)#
Switch(config-ext-nacl)#ip access-list extended RANDOM-PORTS
Switch(config-ext-nacl)#permit tcp any any range 65000 65300
Switch(config-ext-nacl)#
Switch(config-ext-nacl)#
Switch(config-ext-nacl)#class-map match-any FTP
Switch(config-cmap)#match access-group name FTP
Switch(config-cmap)#match protocol ftp
Switch(config-cmap)#
Switch(config-cmap)#class-map match-any RANDOM-PORTS
Switch(config-cmap)#match access-group name RANDOM-PORTS
Switch(config-cmap)#
Switch(config-cmap)#policy-map QoS-rise
Switch(config-pmap)# class FTP
Switch(config-pmap-c)# bandwidth percent 30
Switch(config-pmap-c)# set dscp cs3
Switch(config-pmap-c)#
Switch(config-pmap-c)# class RANDOM-PORTS
Switch(config-pmap-c)# bandwidth percent 30
Switch(config-pmap-c)# set dscp cs3
Switch(config-pmap-c)#
Switch(config-pmap-c)#interface gigabitethernet 1/0/9
Switch(config-if)#service-policy output QoS-rise
Invalid queuing class-map!!! Queuing actions supported only with dscp/cos/qos-group/precedence/exp based classification!!!
Switch(config-if)#

Dejame por favor revisar esa restricion de MQC.




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hola @luis_cordova y @Julio E. Moisa gracias por asistir a gsepulveda@policenter.cl con esta consulta 

Hola,

He aplicado la configuración en un 3750 y no me ha mostrado ningún error, por favor déjame ver si puedo aplicar la configuración en un 3850.

 

Saludos. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Quizás influye en que haya actualizado la IOS que tenia?
Antes: 03.07.03E, licencia IPBASE

Ahora: 16.09.02, licencia LANBASE y le active la licencia a IPBASE

Con todos los cambios no funciona la implementación, volví a la 03.07.03E con IPBASE y tampoco funciona, tengo otro equipo con la misma versión  y licencia, pero tampoco funciona, debo hacer algo anteriormente para implementarlo?

Rafael Carvallo
Beginner

Hola,

 

Es una restricción que tienen los 3850s, el error que te da te dice de cual exactamente. Tengo varios 3850 con varias versiones (hasta 16.3.5b) y en todos da este error, faltaría probar si la restricción es en software (viendo las notas de versión posteriores a esta) o es una restricción del hardware en cuyo caso no hay nada que hacer. 

 

Específicamente lo que sucede es que no puedes utilizar colas si intentas clasificar el trafico mediante otra cosa que no sea DSCP/COS/EXP/PRECEDENCE o el QoS-GROUP (en tu configuración estas clasificando por puertos y aplicación), este ultimo lo dejo aparte porque es el que mas flexibilidad te dará si quieres realizar la clasificación por DSCP, puerto y aplicación en este caso en particular. 

 

El QoS-Group clasifica en la entrada (input), coloca una marca local en el router (es decir, no es algo que sea apreciable una vez sale del router) y luego en la salida (output) puedes utilizar esta marca para clasificar nuevamente el trafico. 

 

Esto debería de servirte:

 

ip access-list extended 2101
permit tcp any any eq 21
permit tcp any any range 65000 65300

class-map match-any FTP
match access-group 2101
match protocol ftp
match ip dscp cs3

policy-map PRE-CLASSIFY
class FTP
set qos-group 1

class-map FTP_OUT
match qos-group 1

policy-map QoS-rise
class FTP_OUT
set dscp cs3
bandwidth percent 30

 

 

Asegúrate de aplicar el policy-map PRE-CLASSIFY en INPUT en todas las interfaces donde pretendas recibir ese trafico:

 

interface X
 service-policy input PRE-CLASSIFY

 

Y ya si luego en las salidas aplicas el policy-map QoS-rise como hacías 

Retomando el proyecto aplique la configuración tal cual la mencionas y me aparece lo siguiente al aplicarla en la interface:

3850(config-if)#service-policy input PRE-CLASSIFY
Match NBAR protocol is not supported for this interface

Hola,

 

Que extraño, ¿tal cual la he colocado acá o editaste algo?

 

Esto lo probé antes de enviártelo en interfaces físicas tanto en L2/L3 así como en un SVI, estas aplicando eso acá o en otro tipo de interfaz? 

 

La versión de IOS era 16.3.5b

Hola @Rafael Carvallo 

Que bueno es leerte en la comunidad de nuevo, gracias por asistir con esta duda 

Leonardo  Pena Davila
Rising star

Hola, en el siguiente documento podras encontrar los errores mas comunes cuando aplicas QoS en los switches 3850, es importante conocerlos cuando se trabaja con esta plataforma.

 

 

https://www.cisco.com/c/en/us/support/docs/switches/catalyst-3850-series-switches/200729-Common-QoS-error-messages-on-Catalyst-38.pdf

 

Espero sea util

Saludos 

Leonardo

Crear
Reconozca a un colega
Content for Community-Ad