cancelar
Mostrar resultados para 
Pesquisar em vez de 
Queria dizer: 
cancel
11002
Apresentações
139
Útil
16
Respostas

Redirecionamento de WAN para LAN

Boa noite!

Instalei um roteador Cisco 1841 em miha rede, configurei para acesso ADSL "speed", meu DC e desktops estão saindo para WAN normamente.                  

Gostaria de configurar um NAT para redirecionar de WAN para LAN é possivel?

Exemplo: tenho um servidor de imagem interno com DDNS rodando para amarar meu ip a um host, preciso criar a rota para quando eu digitar o host exemplo.ddns.com.br:9090 ele redirecinar para um dos ip's da minha LAN.

LAN - 10.32.1.1/24

WAN - dinamica

Desde já agradeço.

Alexandre

16 RESPOSTAS 16

Bruno Rangel
Spotlight
Spotlight

Ola Eduardo

Não sei se é exatamente o que voce esta querendo fazer ou se é possivel fazer isso, porem voce pode utilizar um NAT estatico da seguinte forma:

interface FastEthernet0/1

description *** LINK  SPEED ADSL ***

ip nat outside

ip nat inside source static tcp 10.32.1.1 3389 interface FastEthernet0/1 3389

Assumindo que sua interface da WAN seja F0/1, Depois tenta entrar no seu seu servidor via Terminal Service utilizando seu endereço DDNS.

Por favor avaliar os comentarios usando as estrelas

Cheers
Bruno Rangel

"Se você quiser alguém em quem confiar, confie em si mesmo. Quem acredita sempre alcança"
Renato Russo

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

Boa noite!

Mesmo assim não deu certo. O que eu preciso fazer é a mesma configuração de um router simples da CISCO WRT120N. Aquela configuração de servidor virtual onde você coloca o IP da LAN + Porta + Protocolo.

Obrigado!

Olá Eduardo

A configuração que voce fez foi qual? Teria como postar para darmos uma olhada?

Passa tambem o ip de destino, protocolo (UDP, TCP) e porta

Cheers
Bruno Rangel

"Se você quiser alguém em quem confiar, confie em si mesmo. Quem acredita sempre alcança"
Renato Russo

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

Boa noite, Bruno!

Segue abaixo script ativo no meu router.

!

interface FastEthernet0/0

description Porta WAN

no ip address

ip nat outside

ip virtual-reassembly

ip tcp adjust-mss 1452

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

no cdp enable

!

interface FastEthernet0/1

description Porta LAN$FW_INSIDE$

ip address 10.32.1.1 255.255.255.0

ip nat inside

ip nat enable

ip virtual-reassembly

ip tcp adjust-mss 1452

duplex auto

speed auto

!

interface Dialer0

description Connect Internet$FW_OUTSIDE$

ip address negotiated

ip mtu 1454

ip nat outside

ip nat enable

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username meuprovedor@aaa.com.br password 0 xxxxxx

!

interface Dialer1

no ip address

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

!

ip nat pool adsl 10.32.1.1 10.32.1.254 netmask 255.255.255.0

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source list 99 interface Dialer0 overload

ip nat inside source static tcp 10.32.1.1 9090 interface FastEthernet0/0 9090

!

O ip da minha LAN que preciso de redirecionamento é 10.32.1.50 porta 9090 protocolo TCP e UDP

Obrigado.

Olá Eduardo

Vejo que voce está utilizando algumas ACLs tambem, tenta fazer o redirecionamento através da sua interface Dialer e veja se funciona

Lembre-se de Avaliar todas as Respostas  utilizando as Estrelas e identifique as Respostas Corretas para marcar Discussão como Respondida

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

Boa noite, Bruno!

Tentei criar o redirecionamento da Dialer0, porem não funcionou também...

Se souber mais alguma dica, agradeço!

Att,Alexandre

Ola Eduardo

Não tem muito segredo nesse tipo de configuração, verifica se voce não tem nenhuma ACL bloqueando esse tipo de trafego.

Tenta fazer assim:

interface Dialer0

ip mtu 1492

no ip virtual-reassembly

no ip tcp adjust-mss 1452

!

!

!

interface FastEthernet0/1

ip virtual-reassembly in

ip tcp adjust-mss 1452

duplex auto

speed auto

!

!

no ip nat inside source static tcp 10.32.1.1 9090 interface FastEthernet0/0 9090

ip nat inside source static tcp 10.32.1.1 9090 interface Dialer0 9090

ip nat inside source static udp 10.32.1.1 9090 interface Dialer0 9090

Cheers
Bruno Rangel

"Se você quiser alguém em quem confiar, confie em si mesmo. Quem acredita sempre alcança"
Renato Russo

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

Boa noite, Bruno!

Realizei as alterações conforme você informou, mas também não deu certo.....

Você sabe porque eu não consigo obter o ip Outside Local e Outside Global?

Se você olhar no comando abaixo poderá perceber que o comando que você pediu para realizar na Dialer0 deu certo, inclusive obtive o retorno do meu ip de WAN....

EAS#show ip nat translations

Pro Inside global                Inside local          Outside local         Outside global

tcp 200.231.135.60:49708 10.32.1.10:49708   201.20.244.18:80   201.20.244.18:80

tcp 200.231.135.60:9090   10.32.1.50:9090             ---                         ---

udp 200.231.135.60:80      10.32.1.50:9090             ---                         ---

Alexandre Souza

Olá Alexandre

Poderia por favor postar a configuração completa do seu Roteador?

Faça um telnet para sua rede apartir de um computador que esteja na Internet (Ex: telnet myrouter.dyndns.org 9090; 200.X.X.X 9090) Tenta tambem acessar através do seu IP Publico, utilize um site que te mostre qual seu ip atual.

Lembre-se de Avaliar todas as Respostas  utilizando as Estrelas e identifique as Respostas Corretas para marcar Discussão como Respondida

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

Boa noite, Bruno!

Os testes informados acima já realizei todos.....

Segue a configuração do Router:

Building configuration...

Current configuration : 5185 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname EAS
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 $1$7BEq$IlP3AiVgklluphgxXcqS7.
!
no aaa new-model
clock timezone SaPaulo -3
dot11 syslog
ip source-route
!
!
!
!
ip port-map user-protocol--1 port tcp 9090
ip cef
ip domain name eas.com.br
ip name-server 10.32.1.10
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
!
crypto pki trustpoint test_trustpoint_config_created_for_sdm
subject-name e=sdmtest@sdmtest.com
revocation-check crl
!
crypto pki trustpoint TP-self-signed-1042267991
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1042267991
revocation-check none
rsakeypair TP-self-signed-1042267991
!
!
crypto pki certificate chain test_trustpoint_config_created_for_sdm
crypto pki certificate chain TP-self-signed-1042267991
certificate self-signed 01
  30820246 308201AF A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31303432 32363739 3931301E 170D3133 30343031 30303336
  35315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 30343232
  36373939 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BA2D 24488D80 4B7DE39E BF446F9D 8B6330E3 E97FE90F ECEF54FB FCBC3C61
  60644E66 C7797A29 5BB05AF9 7A260967 D2F2F2E1 5CE6D4A5 8AEF47D8 4EF2CCAC
  72728965 560A3DE1 943E9BB0 1BDA427B FB646196 13E073EE 1F055631 35931F46
  A43D751F 3FBBDAC4 77C4AEFD E30ABCAF 866908AA D37CF5B3 3F285AB1 E0730E46
  ACE70203 010001A3 6E306C30 0F060355 1D130101 FF040530 030101FF 30190603
  551D1104 12301082 0E454153 2E656173 2E636F6D 2E627230 1F060355 1D230418
  30168014 516186F0 0A93D876 C0224DAA 621D7E8E D3C520F6 301D0603 551D0E04
  16041451 6186F00A 93D876C0 224DAA62 1D7E8ED3 C520F630 0D06092A 864886F7
  0D010104 05000381 81005FC5 C28F7923 5A220A15 00A59E3A 5B04F7E1 A5F9265C
  39E9B928 45F707EF F0D621E9 8BF5B74E EB0F87E7 0BE75635 9D96684F 925FE8C8
  FD6C8141 313CC105 5783FF03 D28421B5 360A5BBF 99672AFE EEA249AC 66AAD456
  62CD9BA2 315CD735 63659F46 5D61EB1F 5628FE6A 670684B1 BF3940C5 E6D363C6
  406B139B 76BFA4B3 6246
        quit
!
!
username eas privilege 15 secret 5 $1$8qKq$s9TI0d2abeqyhHrZYEXMQ0
archive
log config
  hidekeys
!
!
!
crypto ipsec transform-set SDM_TRANSFORMSET_1 esp-3des esp-sha-hmac
!
!
!
class-map type inspect match-any SDM_SSH
match access-group name SDM_SSH
class-map type inspect match-any SDM_HTTPS
match access-group name SDM_HTTPS
class-map type inspect match-any SDM_SHELL
match access-group name SDM_SHELL
!
!
!
!
interface FastEthernet0/0
description Porta WAN
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/1
description Porta LAN$FW_INSIDE$
ip address 10.32.1.1 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
!
interface Dialer0
description Connect Internet$FW_OUTSIDE$
ip address negotiated
ip mtu 1454
ip nat outside
ip nat enable
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username xxxxxxx@meuprovedor.com password 0 xxxxxxx
!
interface Dialer1
no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
!
ip nat pool adsl 10.32.1.1 10.32.1.254 netmask 255.255.255.0
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static udp 10.32.1.50 9090 interface Dialer0 9090
ip nat inside source static tcp 10.32.1.50 9090 interface Dialer0 9090
ip nat inside source route-map SDM_RMAP_1 interface Dialer0 overload
!
ip access-list standard nat
permit 10.32.0.0 0.0.0.255
!
ip access-list extended Padrao
remark Acesso VPN
remark SDM_ACL Category=16
remark CCP_ACL Category=4
permit ip any host 10.32.1.50
ip access-list extended SDM_HTTPS
remark SDM_ACL Category=1
permit tcp any any eq 443
ip access-list extended SDM_SHELL
remark SDM_ACL Category=1
permit tcp any any eq cmd
ip access-list extended SDM_SSH
remark SDM_ACL Category=1
permit tcp any any eq 22
!
access-list 1 remark CCP_ACL Category=1
access-list 1 permit 10.32.1.51
access-list 1 permit any
access-list 2 remark CCP_ACL Category=1
access-list 2 permit 10.32.1.51
access-list 99 remark SDM_ACL Category=16
access-list 99 permit 10.32.1.0 0.0.0.255
access-list 100 remark SDM_ACL Category=2
access-list 100 permit ip 10.32.1.0 0.0.0.255 any
!
!
!
route-map SDM_RMAP_1 permit 1
match ip address 100
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

Boa noite, Bruno!

Tentei realizar o telnet no ip e no host conforme você informou, mas ambas tentativas retornaram que não foi possivel abrir uma conexão (conexão falhou).

Obrigado!

Podemos tentar criar um Route map para ver se funciona...

Porem como teste tente retirar o Nat Outside da sua Fast0/0 ... Porem evite fazer isso durante horario de produção.

Lembre-se de Avaliar todas as Respostas  utilizando as Estrelas e identifique as Respostas Corretas para marcar Discussão como Respondida

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers

Bruno,

Retirei meu nat outside da interface fast 0/0, mas caiu minha conexão WAN....

Você quer me add no Skype esouza.alexandre

abs.

Por isso falei para não fazer durante o horario de Produção!!

Enfim....

Seu serviço de DDNS esta funcionando?

O Server em questao esta com a porta liberada?

Lembrando que os testes não podem ser feitos através da rede interna do Router, e tambem confirme se sua operadora permite o trafego dessa porta...

Cheers
Bruno Rangel
Please remember to rate helpful responses using the star bellow and identify helpful or correct answers