annuler
Affichage des résultats de 
Rechercher plutôt 
Vouliez-vous dire : 
cancel
Annonces
Cisco Loive 13, 14 et 15 Juin 2022
322
Visites
0
Compliment
1
Réponses
joris.jeannelle
Beginner

EVPL contrôle des entrées pour VOIP / Input policing for VOIP

Salut la communauté,

J'ai un petit problème. Je dois relier les sites par un EVPL de 300 Mbps. Des deux côtés de l'EVPL j'ai un 9300 et un 3750. Tout le trafic est mélangé dans le lien inter-sites données et voix.
Je souhaite utiliser le traffic shaping/policing pour réserver de la bande passante (disons 10 Mbps) pour la voix.
Sur le 9300 j'ai fait quelque chose comme ça:

class-map match-any VOICE_CLASS
match dscp ef

policy-map WAN_Child
  class VOICE_CLASS
    bandwidth 10000
  class class-default
    bandwidth 290000

policy-map WAN_Parent
  class class-default
    shape average 300000000
    service-policy WAN_Child

Cela devrait faire l'affaire pour le output.
Mais je ne peux pas utiliser le shape average ou de bande passante en entrée (pas de queue).
Je ne peux pas définir la même configuration sur le 3750 de l'autre côté du lien car il ne prend pas en charge le policing/shaping de sortie.
Existe-t-il un moyen de contrôler mon input link pour limiter tout le trafic non VOIP à 290 Mbps et ainsi réserver 10 Mbps pour la VOIP ? Je ne peux pas imaginer comment faire un class-map qui correspondrait au trafic non VOIP. Quelque chose comme ça:

class-map match-any NON_VOICE_CLASS
match NOT dscp ef

policy-map WAN_Input
  class class-NON_VOICE_CLASS

   police 290000000 conform-action transmit exceed-action drop

Une autre question est que si j'ai plusieurs classes dans un policy-map, y aurait-t'il une correspondance séquentielle comme un ACL. Si le trafic correspond à une classe, il ne peut pas correspondre à une autre. Si oui, je pourrais faire quelque chose comme ceci:

class-map match-any VOICE_CLASS
match dscp ef

policy-map WAN_Input
  class class-NON_VOICE_CLASS
   police 10000000 conform-action transmit exceed-action drop

 class default-class
  police 290000000 conform-action transmit exceed-action drop

Merci d'avance.

Joris

Message d'origine:

Hi Community,

I have a little issue. I have to sites link by a 300Mbps EVPL. On both sides of the EVPL I have A 9300 and a 3750.
All traffic is mixed in the inter site link data and voice.
I want to use traffic shaping/policing to reserve some bandwidth (let says 10Mbps) for the voice.
On the 9300 i did something like this

class-map match-any VOICE_CLASS
match dscp ef

policy-map WAN_Child
  class VOICE_CLASS
    bandwidth 10000
  class class-default
    bandwidth 290000

policy-map WAN_Parent
  class class-default
    shape average 300000000
    service-policy WAN_Child

This should do the trick for the output.
But I can't use shape average or bandwidth statement on input (no queue)
I can't set the same config on the 3750 on the other side of the link since it does not support output policing/shaping

Is there a way i can police my input link to limit all non VOIP traffic to 290Mbps and so reserving 10Mbps for the VOIP ?
I can't figure out how to make a class-map that would match non VOIP traffic.
Something like

class-map match-any NON_VOICE_CLASS
match NOT dscp ef

policy-map WAN_Input
  class class-NON_VOICE_CLASS

   police 290000000 conform-action transmit exceed-action drop

Another question is if I have multiple class in a policy-map will it be match sequetially like a ACL. If the traffic match a class then it can't match another one. If yes then i could do something like.

class-map match-any VOICE_CLASS
match dscp ef

policy-map WAN_Input
  class class-NON_VOICE_CLASS

   police 10000000 conform-action transmit exceed-action drop

 class default-class

  police 290000000 conform-action transmit exceed-action drop

 

Thanks in advance.

Joris

1 RÉPONSE 1
educruz
Cisco Employee

Bonjour,

 

Cela peut nécessiter une bonne planification. Tout d'abord, Cat3750 et Cat9300 sont des plates-formes différentes, il faut donc vérifier ce qui est pris en charge sur chaque plate-forme. Par exemple, en termes de QoS, Cat3750 utilise une QoS de commutation multicouche (MLS) alors que Cat9300 et les plates-formes plus récentes utilisent Modular QoS CLI (MQC).

 

Voici un document qui explique comment convertir une configuration de MLS en MQC et vice-versa. Il montre le Cat3850 à titre d'exemple, mais Cat3850 et Cat9300 partagent le même modèle QoS MQC (avec quelques différences mineures).
https://www.cisco.com/c/en/us/support/docs/switches/catalyst-3850-series-switches/118629-technote-qos-00.html

 

Dans la plate-forme Cat3750, shaping et policing ne sont pas pris en charge dans une direction de sortie à l'aide de MQC (les policy-maps sont uniquement à des fins de classification et de marquage).
https://www.cisco.com/c/en/us/support/docs/switches/catalyst-3750-series-switches/91862-cat3750-qos-config.html

 

De plus, pour le policing sur l'entrée, Cat3750 ne le prend en charge qu'en utilisant une interface SVI, donc quelque chose comme ceci :
https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/12-2_55_se/configuration/guide/3750xscg/swqos.html#93444

 

mls qos
!
interface GigabitEthernet1/0/2
switchport access vlan 500
switchport mode access
mls qos vlan-based
mls qos trust dscp
!
class-map match-all CUSTOMER
match input-interface GigabitEthernet1/0/2
!
policy-map VLAN500_POLICE
class CUSTOMER
police 290000 10000 exceed-action drop
!
policy-map VLAN500_PARENT
class class-default
set dscp default
service-policy VLAN500_POLICE
!
interface Vlan500
ip address 192.168.203.1 255.255.255.248
ip ospf 1 area 0
service-policy input VLAN500_PARENT <<<<<
!


Si cette configuration fonctionne pour vous, alors la manière dont vous feriez correspondre le trafic non-VoIP est soit avec une liste ACL, soit avec DSCP. 

 

!
class-map match-any CUSTOMER_NOVOIP
match ip dscp default 1
match ip dscp default 1 2 3 4 5 6 7
match ip dscp cs1 9 af11 11 af12 13 af13
match ip dscp 15 cs2 17 af21 19 af22 21 af23
match ip dscp 23 cs3 25 af31 27 af32 29 af33
match ip dscp 31 cs4 33 af41 35 af42 37 af43
match ip dscp 39 cs5 41 42 43 44 45 47
!
class-map match-all CUSTOMER_VOIP
match input-interface GigabitEthernet1/0/2

!
policy-map VLAN500_POLICE
class CUSTOMER_NOVOIP
police 290000 10000 exceed-action drop
class CUSTOMER_VOIP
police 10000 1000 exceed-action drop
!

 

J'avoue que cela n'a pas l'air propre du tout, mais cela pourrait être une voie à suivre.

 

Franchement, étant donné que les switches Cat3750 sont EoL, la meilleure chose à faire est de le remplacer par un modèle plus récent (par exemple Cat9k) et de partir de là.

 

J'espère que cela puisse vous aider.

 

Merci.

 

Cordialement,

Eduardo CRUZ

Consulting Engineer @ Cisco Systems France

Créer
Reconnaître d'autres membres
Content for Community-Ad

Vidéo - Webcast R&S Juillet 2020

Vidéo - Webcast R&S Février 2020