annuler
Affichage des résultats de 
Rechercher plutôt 
Vouliez-vous dire : 
cancel
Annonces
Interview Redouane MEDDANE
1609
Visites
5
Compliment
11
Réponses
zizou6500
Beginner

Problème de mise à niveau de Cisco ASR9k / Cisco ASR9k upgrade issue

Salut,

J'essaye de mettre à niveau mon routeur (ASR-9001) vers la version 6.7.1. Actuellement, il fonctionne sous la version 5.3.3. J'ai téléchargé avec succès le fichier tar pour la nouvelle version. Cependant, lors de l'ajout de packages, j'ai rencontré un problème d'espace disque: 

 (admin)#install add tar disk0:/ASR9K-iosxr-px-k9-6.7.1.tar

RP/0/RSP0/CPU0:(admin)#Error:    Cannot proceed with the add operation because there is insufficient disk space on the following device:
Error:     - 0/RSP0/CPU0: disk0: (2062286837 bytes required, 974582784 bytes available, 0 stale bytes)

PS: j'ai supprimé les paquets inactifs afin de gagner de la place, mais ce n'était pas suffisant.

 

Texte d'origine:

Hi,
I'm trying to upgrade my router (ASR-9001) to version 6.7.1. Currently, he is running under 5.3.3 version. I've successfully uploaded the tar file for the new version. However, when proceeding with the adding packages, I've faced a disk space issue :
[ERROR]
PS: I've deleted the inactive packages in order to gain some space, but this wasn't sufficient.   

 

1 SOLUTION APPROUVÉE

Solutions approuvées

Bonsoir @zizou6500 

Vous devez mettre à niveau vers l'une des versions intermédiaires 6.3.3, 6.4.2 ou 6.5.1,

et après, vous pourrez passer à l'une des versions 7.x.x

Meilleures salutations

Sam

 

*Si les informations vous ont été utiles, veuillez noter la réponse comme "solution acceptée". Pour remercier l'expert veuillez cocher l'étoile*

Voir la solution dans l'envoi d'origine

11 RÉPONSES 11
saguerre
Cisco Employee

Vous devez vérifier avec la commande "show filesystem" l'espace disponible restant sur le disque et supprimer les fichiers puisque 2062286837 octets sont utilisés pour la mise à niveau.
Il peut y avoir des fichiers .tar des mises à jour précédentes, ceux-ci peuvent également être supprimés.

Veuillez consulter la fiche des mises à jour suivante :
https://community.cisco.com/t5/service-providers-documents/ios-xr-install-upgrade-cheat-sheet/ta-p/3141255

Et le data sheet pour la version 5.3.3: https://www.cisco.com/c/en/us/td/docs/routers/asr9000/software/asr9k_r5-3/sysman/configuration/guide/b-sysman-cg-53xasr9k/b-sysman-cg-53xasr9k_chapter_0100.html

Vous pouvez télécharger le fichier ASR9K-px-docs-6.7.1.tar où vous trouverez toute la documentation de cette version, cependant pour passer de 5.3.3 à 6.7.1 vous ne pouvez pas faire la mise à jour directement, veuillez consulter les liens suivants :

https://www.cisco.com/c/en/us/support/docs/ios-nx-os-software/ios-xr-software/213745-ios-xr-upgrade-changes-certificate-expi.html

https://www.cisco.com/c/en/us/td/docs/routers/technotes/MOP-CSS-to-Abraxas.html

 

Meilleures salutations

Sam

 

*Si les informations vous ont été utiles, veuillez noter la réponse comme "solution acceptée". Pour remercier l'expert veuillez cocher l'étoile*

 

 

Salut Sam,

 

Merci de ton retour.

 

Effectivement, je n'ai pas pu effectuer cet upgrade. Pourriez-vous m'indiquer par quelle version intermédiaire dois-je passer avant d'atteindre la 6.7.1?

Bonsoir Zizou,

Si vous exécutez la version 5.3.3, vous pouvez directement mettre à niveau la dernière version sans aucune version intermédiaire, ni besoin d'installer de SMU post-expiration.

https://www.cisco.com/c/en/us/support/docs/ios-nx-os-software/ios-xr-software/213745-ios-xr-upgrade-changes-certificate-expi.html

Pouvez-vous nous fournir plus d'informations sur l'échec lors de votre mise à niveau ?

Meilleures salutations

Sam

 

*Si les informations vous ont été utiles, veuillez noter la réponse comme "solution acceptée". Pour remercier l'expert veuillez cocher l'étoile*

Salut Sam,

 

Merci de votre retour.

 

J'ai attaché les logs d'erreur suite à la mise à niveau du 5.3.3 vers 6.7.1.

 

Merci d'avance.

Bonsoir SAM,

 

Avez-vous eu l'occasion de vérifier les logs que je vous ai communiqué?

zizou6500
Beginner

Salut Sam,

 

Voici les logs d'erreur suite à la tentative d'upgrade, pourriez-vous checker s'il vous plaît?

 

Bonsoir @zizou6500 

Désolée pour le retard, 

Vous devez d'abord effectuer la mise à niveau vers l'une de ces versions 633/642/651, puis mettre à niveau vers l'image cible.
À titre d'exemple, vous pouvez exécuter une procédure en deux étapes : d'abord vers 6.4.2 puis vers 6.7.2

La deuxième option est d'appliquer turboboot, dans cette procédure, vous pouvez aller directement à la version cible - qui dans ce cas est la 6.7.2 - mais cette procédure effacerait la configuration, de toute façon vous pouvez la sauvegarder et la réappliquer une fois que vous avez terminé la procédure de turboboot, permettez-moi de partager avec vous le guide de configuration officiel sur le lien suivant :

J'espère que cela vous sera utile !

Meilleures salutations

Sam

 

*Si les informations vous ont été utiles, veuillez noter la réponse comme "solution acceptée". Pour remercier l'expert veuillez cocher l'étoile*

Bonsoir @saguerre ,

 

Merci de votre retour.

 

Dans le même contexte, est ce que je pourrais vers la mise à jour vers l'une des version intermédiaires proposées "633/642/651" puis vers la version 7.0 ou 7.1?

 

Merci d'avance,

Cordialement.

 

Bonsoir @zizou6500 

Vous devez mettre à niveau vers l'une des versions intermédiaires 6.3.3, 6.4.2 ou 6.5.1,

et après, vous pourrez passer à l'une des versions 7.x.x

Meilleures salutations

Sam

 

*Si les informations vous ont été utiles, veuillez noter la réponse comme "solution acceptée". Pour remercier l'expert veuillez cocher l'étoile*

Salut @saguerre 

 

Merci pour votre aide!

 

Je vais procéder ainsi et vous tiendrais informé du résultat.

 

Cordialement.

Salut @saguerre ,

 

Dans le même contexte, je suis en train de mettre à jours routeur de l'IOS 4.3.0 vers la version 5.3.4. Au cours de l'activation des packages, j'ai eu cette erreur: 

 

Error: Cannot proceed with the activation because of the following package incompatibilities:
Error: asr9K-doc-supp-5.3.4 needs asr9k-base-5.3.4, or equivalent, to be active on the same nodes.
Error: asr9K-doc-supp-5.3.4 needs iosxr-infra-5.3.4, or equivalent, to be active on the same nodes.
Error: asr9K-doc-supp-5.3.4 needs asr9k-os-supp-5.3.4, or equivalent, to be active on the same nodes.
Error: asr9K-doc-supp-5.3.4 needs iosxr-os-5.3.4, or equivalent, to be active on the same nodes.
Error: Suggested steps to resolve this:
Error: - check the installation instructions.
Error: - activate or deactivate the specified packages on the specified nodes.

 

======

 

Voici la liste des packages que j'ai ajouté: 

 

(admin)#sh install inactive summary
Default Profile:
SDRs:
Owner
Inactive Packages:
disk0:asr9k-services-infra-5.3.4
disk0:asr9k-optic-px-5.3.4
disk0:asr9k-services-px-5.3.4
disk0:asr9k-video-px-5.3.4
disk0:asr9k-mpls-px-5.3.4
disk0:asr9k-mgbl-px-5.3.4
disk0:asr9k-mcast-px-5.3.4
disk0:asr9k-li-px-5.3.4
disk0:asr9k-asr901-nV-px-5.3.4
disk0:asr9k-fpd-px-5.3.4
disk0:asr9k-doc-px-5.3.4
disk0:asr9k-bng-px-5.3.4
disk0:asr9k-9000v-nV-px-5.3.4
disk0:asr9k-mini-px-5.3.4

 

Pourriez-vous m'indiquer comment dois-je procéder s'il vous plaît?

 

Merci d'avance.

 

Créer
Reconnaître d'autres membres
Content for Community-Ad

Vidéo - Webcast R&S Juillet 2020

Vidéo - Webcast R&S Février 2020