annuler
Affichage des résultats de 
Rechercher plutôt 
Vouliez-vous dire : 
cancel

[NAT/PAT] Se connecter à un serveur via son adresse publique depuis une le même sous-réseau interne

lildadou3
Beginner
Beginner

Bonsoir,

j'ai la configuration réseau suivante :

Home network

Le réseau local contient plusieurs machines dont un serveur HTTP (mimir) accessible depuis internet. Comme je ne dispose qu'une d'une seule adresse publique, je réalise un PAT pour que les clients puissent accéder à internet et que les ports http et https soient translatés vers l'adresse de mon serveur http. Ce qui donne la configuration suivante:

interface ATM0
 no ip address
 no atm ilmi-keepalive
 bridge-group 1
 pvc 8/36 
  encapsulation aal5snap
 !
!
interface FastEthernet0
 description Vers switch principal
 no cdp enable
!
interface Vlan1
 ip address dhcp hostname bisfrost
 ip nat inside
 ip virtual-reassembly in
!

interface BVI1
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 ipv6 address autoconfig
!
no ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list reseau-domestique interface BVI1 overload
ip nat inside source static tcp 192.168.0.20 80 interface BVI1 80
ip nat inside source static tcp 192.168.0.20 443 interface BVI1 443
!
ip access-list standard reseau-domestique
 permit 192.168.0.0 0.0.255.255

Malheureusement, la translation vers le serveur ne se fait pas lorsque la source est un hôte interne. Pour résoudre ce problème, j'ai mis en place un DNS menteur qui est utilisé par les hôtes internes grâce à DHCP. Problème, les téléphones android ne respectent par l'option DHCP et continuent d'utiliser l'adresse publique et c'est (parfois) impossible de changer cela!

Pouvez m'aider à configurer mon NAT/PAT pour que mes clients internes puissent accéder au serveur http via son adresse publique?

NB: Ce qui a été essayé, sans succès (je n'utilisais qu'une seule interface interne)

0 RÉPONSES 0
Mise en Route
Bienvenue dans la Communauté !

La communauté est un hub pour vous connecter avec vos pairs et les spécialistes Cisco, pour demander de l'aide, partager votre expertise, développer votre réseau et évoluer professionnellement.
Vous êtes un nouvel arrivant ? Cliquez ici pour en savoir plus.

Nous voulons que votre navigation soit la meilleure, donc vous trouverez des liens pour vous aider à être rapidement familiarisé avec la Communauté Cisco :