cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
967
Views
0
Helpful
2
Replies

APK for Android 6, iOS 9 or 12

Nobu_Taka
Level 1
Level 1

I have an LG K210 (X power from Canada) running Android 6, Asus Zenfone running Android 6, iPhone 6 running Android 12 and iPad 2 running iOS 9.

Can any of these install Duo Mobile from an APK or other?

I need the app for school. Georgia Tech.

2 Replies 2

jenrj
Cisco Employee
Cisco Employee

Hi @Nobu_Taka, welcome to the Duo Community!
We support Android 12, but we don’t support the other OS versions that you listed. You can find more information on currently-supported OS versions in our documentation: https://guide.duo.com/
If you’re using this app for school, try contacting your school’s student help desk for IT for more support on using Duo Mobile on these devices to access your school’s resources.
Hope this helps!

kafailam
Level 1
Level 1

Some user's mobile is running on Android 9, The google play cannot download and install the app. The Duo support would not have any help. Just repeat and repeat go to document https://guide.duo.com/ as same as AI CS.
why DUO app set min OS Andriod requirement is andriod 14?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Quick Links